Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Программы устанавливаются в ubuntu server но не запускаются [РЕШЕНО]  (Прочитано 1128 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Axel Mak

  • Автор темы
  • Любитель
  • *
  • Сообщений: 51
    • Просмотр профиля
Здравствуйте. Я впервые знакомлюсь с Linux вообще и с Ubuntu в частности. Вообщето с компами на ты и так как начинал еще с Доса то командной строки не боюсь и уже много что узнал. Короче сначала все было нормально. Все работало и устанавливалось и удалялось. Когда я шаманил с transmission-daemon LAMP приложениями и вообще изучал права, пользователей и группы, копался в меню aptitude и mc что то видимо сделал и теперь при очередном сносе и установке transmission-daemon или переустановке (в процессе изучения нюансов) LAMP у меня ничего этого не запускается. Например:
transmission-daemon: unrecognized service
или
/etc/init.d/apache2: command not found
или еще как нибудь но главное что ничего никак не запускается.
Далее например там где раньше после установки находился transmission-daemon теперь есть один испорченный файл настроек: !settings.json в других местах вообще ничего нет араньше было. Я переустанавливал после этого несколько раз но все бесполезно.
С Apache и PHP тоже самое. Ничего не работает после настроек пищет в браузере The connection was reset
Пытаюсь перезапустить сервисы но ничего не выходит.
В папке /etc/init.d/ их тоже нет.

Что мне делать и что мог я испортить?
Вроде захожу под суперадмином. И даже активировал root. Просто раньше все устанавливалось и запускалось а после моего копания и изучения перестало все работать и даже переустановка ничего не дает.
Пробовал команду sudo apt-get autoremove и всякие апдэйты и апгрейды. Ничего!
Хэлп!!! не хочу пока полностью с нуля опять систему переустанавливать не выяснив причину проблем. А то буду после каждой проблемы переустанавливать с нуля, а это не выход!

Пользователь решил продолжить мысль 25 Апрель 2011, 12:23:47:
забыл сказать что стоит 10.04
transmission-daemon ставил 2.22 (до сбоя работал) LAMP последних сборок из стандартного репозитария
« Последнее редактирование: 25 Апрель 2011, 16:39:37 от Axel Mak »

Оффлайн Alie Alexandross

  • Старожил
  • *
  • Сообщений: 1580
    • Просмотр профиля
Цитировать
Вроде захожу под суперадмином.
Это кто?

Если мне память не изменяет - aptitude purge удаляет не только пакет, но и все принадлежащие настройки.
aptitude purge pkg_name.
Вообще - почитайте статью Федорчука "»Управление deb пакетами«".
Подпись автора jillsmitt истинна...

Оффлайн Axel Mak

  • Автор темы
  • Любитель
  • *
  • Сообщений: 51
    • Просмотр профиля
Я имел в виду что мой экаунт принадлежит группе админ.
Я раньше удалял и переустанавливал например transmission-daemon без проблем. А теперь почти во всех местах после установки ничего нет что было раньше и соответственно как я понимаю и не запускается ХОТЯ! команда  transmission-daemon -h выдает все что надо.
С LAMP почти тоже самое.

Пользователь решил продолжить мысль 25 Апрель 2011, 12:42:49:
Цитировать
Вроде захожу под суперадмином.
Это кто?

Если мне память не изменяет - aptitude purge удаляет не только пакет, но и все принадлежащие настройки.
aptitude purge pkg_name.
Вообще - почитайте статью Федорчука "»Управление deb пакетами«".
Сейчас попробую. Я удалял настройки вручную и не только из var/lib.... а и из других мест которые нарыл на форумах.

Пользователь решил продолжить мысль 25 Апрель 2011, 12:50:53:
СПАСИБО!!!! aptitude purge помогло! Во всяком случае после перезагрузки системы и установки опять transmission-daemon в папке var/lib..... появилось все то что было раньше :D
Кстати вопрос такой. Я с виндами не сталкивался с подобным хотя опыт огромный в настройке и установки винды от 3.1 и NT до 7и Почему после подчистки в ручную нескольких мест где устанавливался transmission-daemon у меня перестало удаляться и устанавливаться стандартным способом??? Да Linux это не винда :-\
« Последнее редактирование: 25 Апрель 2011, 12:50:53 от Axel Mak »

Оффлайн Alie Alexandross

  • Старожил
  • *
  • Сообщений: 1580
    • Просмотр профиля
Цитировать
Почему после подчистки в ручную нескольких мест где устанавливался transmission-daemon у меня перестало удаляться и устанавливаться стандартным способом???
Стандартным - это каким?
Подпись автора jillsmitt истинна...

Оффлайн Axel Mak

  • Автор темы
  • Любитель
  • *
  • Сообщений: 51
    • Просмотр профиля
Цитировать
Почему после подчистки в ручную нескольких мест где устанавливался transmission-daemon у меня перестало удаляться и устанавливаться стандартным способом???
Стандартным - это каким?
sudo apt-get remove smprg
sudo apt-get autoremove

sudo apt-get install smprg

помогло только aptitude purge хотя несколько раз переустанавливал именно без этой команды

Оффлайн фирэфохэ

  • Старожил
  • *
  • Сообщений: 2169
  • straightedge
    • Просмотр профиля
purge удаляет не только пакет, но и все принадлежащие настройки.

Пользователь решил продолжить мысль 25 Апрель 2011, 14:51:50:
Почему после подчистки в ручную нескольких мест где устанавливался transmission-daemon у меня перестало удаляться и устанавливаться стандартным способом???
Читать надо, что тебе команды пишут.

Цитировать
Да Linux это не винда :-\
А должна быть винда?
« Последнее редактирование: 25 Апрель 2011, 14:51:50 от фирэфохэ »
http://i18.ЗАПРЕЩЁННЫЙ РЕСУРС/big/2011/0325/6d/19eaa72dd24048a6fb0587832c4b096d.gif КДЕ - УГ. Дебиан - недоось.

Оффлайн Axel Mak

  • Автор темы
  • Любитель
  • *
  • Сообщений: 51
    • Просмотр профиля
purge удаляет не только пакет, но и все принадлежащие настройки.

Пользователь решил продолжить мысль 25 Апрель 2011, 14:51:50:
Почему после подчистки в ручную нескольких мест где устанавливался transmission-daemon у меня перестало удаляться и устанавливаться стандартным способом???
Читать надо, что тебе команды пишут.
Ответ многозначительный ;D
Устанавливались и удалялись нормально без каких либо комментов! вот только не прописывались в системе до конца и не запускались. Ну да ладно. Тема закрыта Спасибо Alie Alexandross

Оффлайн фирэфохэ

  • Старожил
  • *
  • Сообщений: 2169
  • straightedge
    • Просмотр профиля
Что значит не запускалось?
Цитировать
Устанавливались и удалялись нормально без каких либо комментов!
Такого не бывает.

Пользователь решил продолжить мысль 25 Апрель 2011, 15:32:32:
Ответ многозначительный ;D
Что не понятно, есть apt-get install, есть apt-get remove, есть apt-get autoremove, есть apt-get purge, даже какой-то apt-cache xvcg.
Короче:
$ man apt
« Последнее редактирование: 25 Апрель 2011, 15:32:32 от фирэфохэ »
http://i18.ЗАПРЕЩЁННЫЙ РЕСУРС/big/2011/0325/6d/19eaa72dd24048a6fb0587832c4b096d.gif КДЕ - УГ. Дебиан - недоось.

Оффлайн Alie Alexandross

  • Старожил
  • *
  • Сообщений: 1580
    • Просмотр профиля
Цитировать
Ну да ладно. Тема закрыта Спасибо Alie Alexandross
В шапку допишите [РЕШЕНО]
Подпись автора jillsmitt истинна...

 

Страница сгенерирована за 0.056 секунд. Запросов: 23.