Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: ATI - помехи в видео  (Прочитано 2552 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн shevayura

  • Автор темы
  • Любитель
  • *
  • Сообщений: 52
    • Просмотр профиля
ATI - помехи в видео
« : 30 Апрель 2011, 14:30:26 »
Начну с начала, для ясности ситуации.
Ноутбук ACER Extensa 5620G. C2D T5550 @ 1.83.  3GB RAM. ATI HD2400XT (Mobile).

Вчера установил Ubuntu 11.04 Сменил загрузку на гном2. Поставил кодеки с медибунту. Поставил VLC. Всё прекрасно.

Но так как стандартный драйвер видео не позволяет управлять настройками PowerPlay. Установил проприетарные драйвера с репозитария убунты. И началось.
При включенном компизе видео тормозит. Смотреть такое невозможно.
Если выключить эффекты гнома - то видео не тормозит, но есть помехи в виде горизонтальных полос на видео в динамических сценах (верт.синх).
Ладно. Думал драйвера не те. Полез на сайт амд и скачал оттуда драйвера для своей карточки. Ситуация не очень изменилась. Полосок стало больше, тормозов в "красивом гноме" не меньше.
Чуть позже в какой-то момент VLC перестал воспроизводить видео рассказывая мне что он не может найти декодеры всех форматов :)
VLC пришлось собирать у себя из исходников. Заработал, но кривовато в полноэкранном режиме выводятся меню и панель управления. Не удобно, но и не критично.
Среди моих попыток было:
1. Откат на драйвера из репозитария. (не помогло)
2. Установка сглаживания и принудительной вертикальной синхронизации. (не очень помогло)
3. Включение Tear Free Desktop в CCC (в красивом гноме и так разрывов небыло, а в некрасивом видео теперь не выводится вообще. Пришлось выключить)

После вышеперечисленных действий VLC не показывает видео :) В данный момент перекомпилирую.

Есть идеи как устранить помехи при воспроизведении видео?

ЗЫ. Помехи наблюдаются в видео 720р и выше.


Оффлайн Упс

  • Старожил
  • *
  • Сообщений: 3231
    • Просмотр профиля
Re: ATI - помехи в видео
« Ответ #1 : 30 Апрель 2011, 14:46:51 »
xUbuntu 12.04

Оффлайн shevayura

  • Автор темы
  • Любитель
  • *
  • Сообщений: 52
    • Просмотр профиля
Re: ATI - помехи в видео
« Ответ #2 : 30 Апрель 2011, 14:52:23 »
Нет. К сожалению не оно... Там у всех всё в порядке. Возможно проблемы генерирует тот факт, что у меня мобилити видеокарта.

Пользователь решил продолжить мысль 30 Апрель 2011, 14:59:59:
sudo aticonfig --sync-video=on
Тоже не помогло.

Пользователь решил продолжить мысль 30 Апрель 2011, 15:07:49:
может из-за этого

$ glxgears
304 frames in 5.0 seconds = 60.761 FPS
298 frames in 5.0 seconds = 59.220 FPS
303 frames in 5.0 seconds = 60.553 FPS
299 frames in 5.0 seconds = 59.609 FPS

+ каждую секунду анимация "дёргается" (приостанавливается как-бы)...

Пользователь решил продолжить мысль 30 Апрель 2011, 15:13:42:
Включив Tear Free Desktop запустил тест. Мягко говоря - тест глючил. Шестерни не крутились. Изображение жутко мигало (пропадало/появлялось) со скоростью ~60к/с. Но вывод был :)

$ glxgears
308 frames in 5.0 seconds = 61.534 FPS
300 frames in 5.0 seconds = 59.981 FPS
299 frames in 5.0 seconds = 59.780 FPS
299 frames in 5.0 seconds = 59.780 FPS
299 frames in 5.0 seconds = 59.781 FPS


Пользователь решил продолжить мысль 30 Апрель 2011, 15:42:46:
Включил эффекты гнома (классическая). Выключил "Синхронизировать с VBlank". Тормоза пропали - появились разрывы.
Включил принудительную верт.синхронизацию в ССС - разрывов стало намного меньше.
Включил Tear Free Desktop - разрывов почти нету, но видео притормаживает.

Всё же нужен вариант избавления от разрывов в схеме "без эффектов".
« Последнее редактирование: 30 Апрель 2011, 15:42:46 от shevayura »

Оффлайн t800

  • Новичок
  • *
  • Сообщений: 37
  • Гентушный тролль
    • Просмотр профиля
Re: ATI - помехи в видео
« Ответ #3 : 01 Май 2011, 12:26:25 »
Как вариант юзать свободный radeon.
 Gigabyte GA-G31M-ES2L v2, Dualcore 2.93 Ghz, 4 ГБ DDRII, HDD 250+320+500 GB, nVidia GT 120 / Gentoo Linux

Оффлайн shevayura

  • Автор темы
  • Любитель
  • *
  • Сообщений: 52
    • Просмотр профиля
Re: ATI - помехи в видео
« Ответ #4 : 01 Май 2011, 12:28:09 »
А разве в них уже реализовано управление PowerPlay?

Оффлайн gopnick

  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Re: ATI - помехи в видео
« Ответ #5 : 01 Май 2011, 18:23:45 »
Реализовано, но работает хуже чем проприетарный. http://www.x.org/wiki/RadeonFeature

Оффлайн shevayura

  • Автор темы
  • Любитель
  • *
  • Сообщений: 52
    • Просмотр профиля
Re: ATI - помехи в видео
« Ответ #6 : 01 Май 2011, 21:08:54 »
Вариант конечно интересный, но у меня в ноуте вся система охлаждения - это кулер над видеокартой :) Их на ноутбуки не противопоказано ставить?

ЗЫ: А кто-то пробовал установить на наврале xvba-va-driver? У меня такое:
(Нажмите, чтобы показать/скрыть)

Оффлайн shevayura

  • Автор темы
  • Любитель
  • *
  • Сообщений: 52
    • Просмотр профиля
Re: ATI - помехи в видео
« Ответ #7 : 06 Май 2011, 23:45:38 »
АП. Проблема актуальна. Решение не найдено. Многочисленные разрывы при отключённом компизе очень отвлекают. Тормоза при включённом раздражают.

Пользователь решил продолжить мысль 07 Май 2011, 13:09:01:
Вернулся к самым последним дровам. Разрывы повсюду (особенно заметно в "Доктор Кто" в заставке).
Tear Free Desktop можно заставить работать в без компиза. Он глючит только при оверлейном выводе видео. Выключив в VLC оверлейный режим видео показывает, но тормоза жуткие.
Принудительная вертикальная синхронизация не даёт эффекта вообще.

Пользователь решил продолжить мысль 07 Май 2011, 13:47:26:

Есть решение (ограниченное):
Устанавливаем SMPlayer

[Настройки => Быстродействие => Допускать выпадение кадров] Отключить
[Настройки => Быстродействие => Потоков декодирования] Столько, сколько ядер в процессоре.
[Настройки => Основные => Видео => Устройство вывода] выбрать [gl(быстро - видеокарты ATI)]

Далее в терминале набрать.
gstreamer-properties
В появившемся окне:
Вкладка "Видео" => Группа "Ввод"
Модуль => Система ХWindows (с расширениями Х11/XShm/Xv)
Устройство => ATI Radeon AVIVO Video

Разрывов практически нет (а если и есть, то я их просто не замечаю на фоне того поломанного видео, которое зрел до данных твиков)

Пользователь решил продолжить мысль 07 Май 2011, 16:03:59:
Почему "ограниченный":
Работает только в SMPlayer
Иногда на динамических сценах картинка начинает жутко тормозить вплоть до зависания. От тормозов помогает пауза на пару секунд. Если зависнет - помогает перемотка (например перемотать чуть назад клавишей "влево"). Скорее всего это из-за отсутствия аппаратного ускорения. Кто знает как его включить без пакета xvba?
« Последнее редактирование: 07 Май 2011, 16:03:59 от shevayura »

Оффлайн ekzotech

  • Новичок
  • *
  • Сообщений: 37
  • Экзотический раздолбай
    • Просмотр профиля
    • ekzotech.org
Re: ATI - помехи в видео
« Ответ #8 : 07 Май 2011, 18:41:11 »
У меня тоже ноутбук. ATi Mobility 4570.
Тиринг (так называются проблемы с вертикальной синхронизацией) у меня появились на ubuntu 10.04 / mint 9. В mint 7 (если не ошибаюсь, это 9.04 Ubuntu) и с драйвером 9.4 все было отлично. В слаке все тоже отлично и было и есть. В генту/арче и по сей день нет тиринга, хоть компиз включен, хоть выключен.
С Ubuntu 10.10 / mint 10 в проприетарном драйвере помогало отключение/включение вертикальной синхронизации в настройках ati catalyst.
Сейчас в генту/арче/слаке/Ubuntu-mint использую открытый драйвер. Замеров не проводил, но я бы не сказал, что ноутбук стал сильно горячее при использовании открытого драйвера (в сравнении с оффтопик7). Критичного ничего нет.
И я бы посоветовал попробовать тот же 10.10 (если не ставили еще) - как там работает видео?
Сдается мне, что это просто мелкие глюки в сыроватой 11.04. Я например сегодня с неприятным удивлением обнаружил, что в ноутбуке не работает кардридер и скорость записи на флешку 3 мбайта/сек с перерывами (а должно быть 20 и стабильно).
"И никакие мы не сектанты. Мы просто группа ошалелых вооруженных фанатиков." (с) Balanar
KISS = Keep it simple, stupid!

Оффлайн shevayura

  • Автор темы
  • Любитель
  • *
  • Сообщений: 52
    • Просмотр профиля
Re: ATI - помехи в видео
« Ответ #9 : 07 Май 2011, 20:19:12 »
В 10.04  тиринга не наблюдалось. Во всяком случае здесь он обалденно ломает картинку (даже встречаются искажения по диагонали О_о)
Переустанавливать ось не очень хочется :) Всё-ещё надеюсь что все наблюдаемые мной глюки (сабж, низкая скорость WiFi, др.) от сыроватости навральчика. 10.04 тоже не сразу был классным. 
Жду новых дров от АТИ (они их вроде каждый месяц выпускают). Пока решение есть и просмотрщик видео не критичен. Пока буду думать над https://forum.ubuntu.ru/index.php?topic=151059.0 и над сглаживанием тачпада, ибо уж очень курсор дёргает (навести на границу окна сложновато).

Оффлайн GothicTux

  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Re: ATI - помехи в видео
« Ответ #10 : 07 Май 2011, 22:23:51 »
В настройках SMPlayer мне после некоторых экспериментов помогло именно отключение прямого рендеринга и двойной буферизации, с устройством  ATI Radeon AVIVO Video.
Все стало намного лучше работать, нужно экспериментировать, иногда что-то работает индивидуально :)
HP Pavilion dv6-3151er (XR550EA#ACB)
WXGA+/Intel Core i3-370M 2.4Ghz/3Gb/320Gb/ATI HD5650 1Gb/Wi-Fi,BT,cam
11.10_x64

Оффлайн shevayura

  • Автор темы
  • Любитель
  • *
  • Сообщений: 52
    • Просмотр профиля
Re: ATI - помехи в видео
« Ответ #11 : 07 Май 2011, 22:36:20 »
Таки индивидуально. Мне отключение двойной буферизации вернуло половину разрывов.

Оффлайн ekzotech

  • Новичок
  • *
  • Сообщений: 37
  • Экзотический раздолбай
    • Просмотр профиля
    • ekzotech.org
Re: ATI - помехи в видео
« Ответ #12 : 07 Май 2011, 23:45:43 »
Возможно и от сырости (я таки больше склоняюсь к этому варианту). С ядром 2.6.38 в генту и арче все норм (на открытом драйвере; fglrx для меня бесполезен, пока там нет kms).
Искажение по диагонали - это уже что-то не то.
А если live-cd попробовать? Ту же Ubuntu например.
"И никакие мы не сектанты. Мы просто группа ошалелых вооруженных фанатиков." (с) Balanar
KISS = Keep it simple, stupid!

Оффлайн mixxx_a

  • Новичок
  • *
  • Сообщений: 11
  • Ubuntu 12.04 x86_64
    • Просмотр профиля
Re: ATI - помехи в видео
« Ответ #13 : 30 Апрель 2012, 20:39:13 »
присоединяюсь к теме, такая же проблема после установки драйверов ATI.Раздражает,причем без драйверов всё заметно лучше, кроме конечно игр wine.
Asrock 780lm-s|ati hd3000|Phenom-x3 tm 8750|HDD Sata 2 500gb && IDE 40|DDR2-4gb|

 

Страница сгенерирована за 0.064 секунд. Запросов: 24.