Форум русскоязычного сообщества Ubuntu


Автор Тема: [РЕШЕНО] Медленная Ubuntu или старое оборудование?  (Прочитано 2426 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Victor Zemtsov

  • Автор темы
  • Новичок
  • *
  • Сообщений: 45
    • Просмотр профиля
Здравствуйте!

Имеет место следующая проблема. После установки Ubuntu (сначала была 10.04, потом 10.10, теперь 11.04) спустя пару дней начинается заметное торможение системы: медленнее открываются приложения, до ужаса замедляется перемещение окон, сама работа приложений тоже замедляется. Много софта не ставлю, так что фрагментация тут явно не играет роли. С чем это может быть связано?

Система не самая слабая (полтора года ноутбуку):
Acer Aspire 6530G
AMD Turion X2 2ГГц
ATI RADEON HD 3470 gybryd x2
3Гб ОЗУ 533МГц
HDD 320Гб (ext4 на / и на /home)

P.S. на Win все было отлично, даже 40Гб ремуксы игрались без тормозов (что говорит в пользу производительности оборудования). Видео здесь тоже очень медленно работает (даже очень легкие сериальчики). Причем, что интересно, на свободных драйверах видео играется лучше, на проприетарных же вчера ~500Мг эпизод Firefly не смог посмотреть - картинка рывками.
« Последнее редактирование: 06 Май 2011, 14:40:23 от Victor Zemtsov »

Оффлайн Softwayer

  • Активист
  • *
  • Сообщений: 706
  • Arch Linux
    • Просмотр профиля
ATI RADEON HD 3470 gybryd x2
Вероятно, проблемы с дровами. Почитай тему про 11.04, там рекомендовали что-то по этому поводу.

Zaratustra

  • Гость
Попробую рассказать что бы я сделал:

1) посмотреть top, может что-то грузит систему
2) выйти из иксов, попробовать поработать в терминале - будут тормоза или нет
3) скачать лайв сиди/дивиди другой системы и проверить его работу на вашем ноуте

у меня подозрение что какой-то драйвер устройства флудит по шине и затыкает всю работу. имхо.

Оффлайн Victor Zemtsov

  • Автор темы
  • Новичок
  • *
  • Сообщений: 45
    • Просмотр профиля
После установки 11.04 (да и предыдущих выпусков) всегда ставил проприетарные драйвера на видео. На ноуте идиотская модная нынче ситуация с двумя видеокартами:

(Нажмите, чтобы показать/скрыть)

все остальные драйвера "ис каропки".

В проприетарных драйверах видно, какая из видимокарт сейчас работает (вторую можно в режиме "кроссфайр" подключить), в свободных - нет (и фиг знает, то ли "встроенная" слабенькая работает, то ли "внешняя" помощнее). В предыдущих выпусках всегда были проблемы с оборудованием: и с видео, и с аудио.

Благодарю за советы, сегодня буду экспериментировать. Поставил качаться xUbuntu, она подойдет для тестов? Или лучше дистрибутив не *buntu скачать?

Цитировать
Почитай тему про 11.04, там рекомендовали что-то по этому поводу
Не подскажете, где эту тему найти?

Zaratustra

  • Гость
надо дёрнуть какую-нить другую систему, можно отечественную например, поскольку грабли Ubuntu могут быть и в других сборках, а вам бы провести исследование как можно более точнее. (и то это может ничего не дать, но всё же)

Оффлайн Victor Zemtsov

  • Автор темы
  • Новичок
  • *
  • Сообщений: 45
    • Просмотр профиля
Цитата: Zaratustra
а вам бы провести исследование как можно более точнее

Не могли бы Вы пояснить эту мысль? Может быть посоветуете какие-нибудь методы/способы/утилиты для более точного исследования?:)

Цитата: Zaratustra
какую-нить другую систему, можно отечественную

Не подскажете, какую?:) Особенно заинтересовало наличие "отечественных" дистрибутивов? Разве есть такие? И разве LiveCD может показать адекватную картину? Там же вроде и так все довольно медленно работает...

На данный момент удалил через "Дополнительные драйвера" проприетарные от ATI. Результат - легкое видео стало плавно идти, тяжелое - немногим лучше, чем было (но это уже видимо связано с отсутствием аппаратной поддержки декодирования, т.к. процессор загружен более чем на 80%). Но добавились кой-какие баги, как то:

- дерганное изображение (например, при прокрутке текста в LibreOffice, или веб-страницы) - в проприетарных драйверах это убиралось галкой в "Xinerama" (или как-то так), синхронизирующее частоты обновления экрана и содержимого на ней;
- мигания черного экрана при некоторых действиях (например, при переключении видео в полноэкранный режим);
- медленная работа флеш-видео (с ютуба, например), но исчезли зависания системы (как было неоднократно с проприетарными);
- еще какие-то мелочи, уже не помню точно, но не сильно лезущие в глаза.

top ничего подозрительного не показал, что, по всей видимости, заставляет более пристальное внимание обратить в сторону драйверов. В пользу этой же причины говорят и постоянные проблемы с оборудованием в предыдущих выпусках (10.04 и 10.10). В 11.04 дела обстоят гораздо лучше, но, как видно, до хорошей работоспособности еще не дошли...

Да, как можно посмотреть какая видеокарта используется свободными драйверами? И еще вопрос, на некоторых форумах рекомендуют удалить xorg.conf, не станет ли это причиной отказа клавиатуры, мыши и прочих устройств?

Zaratustra

  • Гость
Цитировать
Не могли бы Вы пояснить эту мысль? Может быть посоветуете какие-нибудь методы/способы/утилиты для более точного исследования?
Я только теоретизирую. Практические советы не дам.

Цитировать
Не подскажете, какую?
Знаю что их несколько и даже вроде хороших, но не интересуюсь.

Цитировать
И разве LiveCD может показать адекватную картину? Там же вроде и так все довольно медленно работает...
По какой причине на Лайв-сиди всё должно работать медленно? Запуск программы которая читается с сиди - согласен, но её работа в оперативной памяти не будет медленной.
Можете лайв сиди перенести на усб флэшку или винт и смотреть оттуда.

Оффлайн RustemNur

  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 2937
  • умрешь с вами
    • Просмотр профиля
Не подскажете, где эту тему найти?

Если я правильно понимаю, то имеется в виду тема, которая сейчас в разделе ХауТо прикреплена.

Оффлайн Victor Zemtsov

  • Автор темы
  • Новичок
  • *
  • Сообщений: 45
    • Просмотр профиля
Проблема, кажется, решена:)

Частично - при удалении проприетарных драйверов ATI. Полностью - при выполнении пункта 3 статьи "[How To] Советы по настройке 11.04"

https://forum.ubuntu.ru/index.php?topic=149652.0

Окошки перемещаются дергано, но без тормозов. И в остальном - вроде бы даже все нормально. По крайней мере те операции, что раньше сопровождались "чудесами", теперь работают нормально. Косяки с отображением еще остались, но не все, большая часть ушла.

Прошу прощения, если тема эта банальная и уже набила оскомину, просто я бы ни в жизнь не связал появление сильных тормозов спустя несколько дней после установки системы и проприетарные драйвера (которые я обычно и ставил спустя пару дней, как поставлю софт и т.д.). А еще во множестве мест настоятельно рекомендуют ставить сразу именно драйвера от разработчиков ATI... А с ними даже легкое видео умудряется тормозить, не говоря уже о всей системе в целом.

Благодарю всех добрых людей, кто не остался в стороне, за оказанную помощь:) Тему можно закрывать. Или удалять. Не знаю, что тут на форуме принято:)

Оффлайн RustemNur

  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 2937
  • умрешь с вами
    • Просмотр профиля
Тему можно закрывать. Или удалять. Не знаю, что тут на форуме принято:)

Принято вписывать в Тему слово "[РЕШЕНО]".
Для этого автор подправляет Тему в своем первом посте.

Оффлайн Victor Zemtsov

  • Автор темы
  • Новичок
  • *
  • Сообщений: 45
    • Просмотр профиля
Re: Медленная Ubuntu или старое оборудование?
« Ответ #10 : 06 Май 2011, 14:42:29 »
Цитата: RustemNur
Принято вписывать в Тему слово "[РЕШЕНО]".
Для этого автор подправляет Тему в своем первом посте.

Благодарю за информацию, я думал этим занимаются модераторы раздела. Сделал

 

Страница сгенерирована за 0.19 секунд. Запросов: 23.