Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Ничего не отправляется в интернет [РЕШЕНО]  (Прочитано 4694 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн dennis-75

  • Автор темы
  • Новичок
  • *
  • Сообщений: 18
  • UBUNTU 11.10
    • Просмотр профиля
Добрый день, уважаемые профессионалы эксплуатации UBUNTU 10.04-2 LTS!
Пользуюсь UBUNTU около полугода. Опыта в переустановке уже набрался по полной программе :)) (так как по первости все косяки и проблемы исправлят только таким координальным способом).
Теперь пытаюсь решать все возникающие вопросы с помощью GOOGLE и этого уважаемого форума.
Система нравится (думаю не имеет смысла перечислять все ее плюсы), однако возникающие в процессе эксплуатации некоторые проблемы быстро возвращают меня на землю и заставляют вспоминать высказывания некоторых о Линуксе как о российском автопроме: "после сборки - обработать напильником".
Вот и сейчас перерыл весь инет, но ответа на свой вопрос так и не нашел. В силу обстоятельств я не имею столько свободного времени сколько хотелось бы потратить на допиливание системы. Нужен просто-напросто стабильно работающий комп. А получаю, к сожалению, сплошную нервотрепку...(хотя не исключаю, что и моя излишняя любознательность к всякого рода программкам нужным и не нужным могла к этому привести)

Ну да ладно. Теперь к проблеме.

Главные вопросы:
 
1. НЕ МОГУ ОТПРАВИТЬ ИЗ КОМПЬЮТЕРА ПОЧТУ БОЛЬШОГО ОБЪЕМА (простой текст уходит ито не большой(1-3 слова), если пытаюсь вложить картинку допустим размером от 3 мб получаю ошибку отправки. Думал косячит Evolution, снес его, однако не хотел, думал настрою под себя(хоть и пишут про него всякие гадости), поставил Thunderbird, клиент хороший(на основоной работе стоит на Винде) но проблема не решилась)

2. НЕ МОГУ ЗАГРУЗИТЬ НА ХОСТИНГ САЙТА ИЗ КОМПЬЮТЕРА ФАЙЛЫ НИ ПО FTP НИ ПО SSH (использовал программу filezilla и штатный наутилус. В обоих случаях на сервере оказывается передаваемый файл, но он пустой, т.е. 0 байт. Перегружаюсь в Виндус и с помощью Total-commander все загружается как надо. На стороне сервера проблема не может быть)

Не многим раньше ВСЕ ОТПРАВЛЯЛОСЬ, и почта и файлы в filezilla.

В чем заковырка не пойму. Грешу на то, что удалил какой нибудь пакет (недавно из Synaptic ставил Clamav, но потом от него отказался т.к не понял как с ним управляться. Ну и удалил соответственно.. И еще удалил это
Полностью удалены следующие пакеты:
kpackagekit
Эти пакеты удалены:
kubuntu-debug-installer

раньше его не замечал в главном меню, а когда увидел, запустил, посмотрел и понял, что
тоже не нужный мне пакет, пользуюсь ubuntu-tweak)

Единственный вывод, который напрашивается, это то, что проблема локальная, исключительно не моей машине, но где кроются ее корни непонятно. Возможно - где-то на поверхности, но в силу своей неопытности в пользовании LINUX я ее найти не могу.

ИМЕЮ Desktop

Version: AMD Phenom(tm) II X4 955 Processor                 
   Voltage: 1.5 V
   External Clock: 200 MHz
   Max Speed: 3200 MHz
   Current Speed: 3200 MHz
   Status: Populated, Enabled
   Upgrade: Other
   Serial Number: To Be Filled By O.E.M.
   Asset Tag: To Be Filled By O.E.M.
   Part Number: To Be Filled By O.E.M.
   Core Count: 4
   Core Enabled: 4
   Characteristics: 64-bit capable
Ядро 2.6.32-31-generic
если какая-то информация по железу и софту нужна будет, выложу по запросу.

Помогите плиз, нужно работать а я трачу время на решение этих вопросов...
Буду благодарен за любую, направляющую в нужное русло, информацию.

P.S. Ну вот.... хорошо, что набрал сообщение в текстовом файле. Вставляю его в форму на сайте и мой пост не загружается в инет!!??!!! (браузером Opera и Mozilla Firefox. Хромом и пробовать не буду, перегружаюсь в Виндус)

Задолбался!
« Последнее редактирование: 12 Май 2011, 15:10:27 от dennis-75 »

Оффлайн solint

  • Активист
  • *
  • Сообщений: 673
    • Просмотр профиля
Re: Ничего не отправляется в интернет!
« Ответ #1 : 07 Май 2011, 16:57:50 »
Проверить косяки ли это настроек конкретного пользователя достаточно просто. Нужно создать нового юзера, зайти под ним и попробовать выполнить те же действия. Если результат тот же значит ваши настройки не при чем. Возвращаемся к 1-му юзеру и смотрим отличия настройки сети в винде и лине, до мелочей. Ибо так как вы описываете быть не должно в приципе. (Разве что невероятная ситуация когда провайдер сильно обижен на линукс и вредит)

Оффлайн dennis-75

  • Автор темы
  • Новичок
  • *
  • Сообщений: 18
  • UBUNTU 11.10
    • Просмотр профиля
Re: Ничего не отправляется в интернет!
« Ответ #2 : 07 Май 2011, 17:05:30 »
провайдер сильно обижен на линукс и вредит)
Неужели такое может быть??!
По поводу создания второго юзера я как-то не подумал.. Сейчас буду пробовать.
А вот по поводу настроек сети что-то не уверен... хотя не исключено. Раньше же все отправлялось, а сейчас как-будто режет что-то исходящий трафик. При этом Торрент клиент стоит на раздаче и успешно раздает.

Забыл добавить, комп стоит за роутером. Провайдер Netbynet, думаю не должен ни на что обижаться, я его исправно кормлю ))
« Последнее редактирование: 07 Май 2011, 17:07:59 от dennis-75 »

Оффлайн solint

  • Активист
  • *
  • Сообщений: 673
    • Просмотр профиля
Re: Ничего не отправляется в интернет!
« Ответ #3 : 07 Май 2011, 17:14:48 »
Цитировать
Неужели такое может быть??!
Ну я же сказал что это невероятная ситуация, хотя и возможная. Думаю все гораздо проще. Вполне возможно что торрент забивает канал или что то подобное.

Оффлайн dennis-75

  • Автор темы
  • Новичок
  • *
  • Сообщений: 18
  • UBUNTU 11.10
    • Просмотр профиля
Re: Ничего не отправляется в интернет!
« Ответ #4 : 07 Май 2011, 17:51:15 »
Вобщем попробовал..
Создал нового пользователя,
Зашел под ним,
ничего, кроме Файлзиллы не запущено...
залогинился на сервере, вижу каталог со своими сайтами, захожу в нужный..
отправляю файл...

(Нажмите, чтобы показать/скрыть)

И так, после трех попыток загрузить файл операция закончилась неудачей.
И по прежнему не могу даже ответить на сообщение из Файерфокса нового пользователя (пришлось опять перегрузиться в винду)
Ради прикола, подключился к тому-же каталогу из винды Тотал командером и успешно загрузил тот-же файл на сервер.

Короче... засада полная.. (

Модератор:
для "портянок" используем спойлер


Пользователь решил продолжить мысль 07 Май 2011, 18:03:54:
Ну извините.., не сразу догадался, что кнопка с изображением опасности и есть спойлер.
Спасибо, что  заставили поискать.. Учту.
« Последнее редактирование: 07 Май 2011, 18:03:54 от dennis-75 »

Оффлайн solint

  • Активист
  • *
  • Сообщений: 673
    • Просмотр профиля
Re: Ничего не отправляется в интернет!
« Ответ #5 : 07 Май 2011, 19:02:12 »
Чорт, пока одна мысль, в сторону MTU смотрел? Может увеличить? Опять же, не пользуясь гуем пробовал файл переслать? может доп.инфу получим.
Ну типа как в винде. В cmd telnet xxxx 21 и далее.

Оффлайн dennis-75

  • Автор темы
  • Новичок
  • *
  • Сообщений: 18
  • UBUNTU 11.10
    • Просмотр профиля
Re: Ничего не отправляется в интернет!
« Ответ #6 : 08 Май 2011, 01:26:50 »
в сторону MTU смотрел? Может увеличить? Опять же, не пользуясь гуем пробовал файл переслать? может доп.инфу получим.
Так-так, вот с этого места поподробнее... дело в том, что с командной строкой я не совсем знаком (знаю, сейчас будете больно пинать ногами)), говорить: Ну как? это же UNIX, без ком. строки никуда) в смысле кое что могу, но в основном смотрю примеры как делать и делаю по аналогии или прямо как сказано.
Полностью согласен, но если дадите команды которыми запустить процесс передачи файла и команды на прочие тесты все сделаю и выложу отчет. А там мож что и проясниться...

Оффлайн solint

  • Активист
  • *
  • Сообщений: 673
    • Просмотр профиля
Re: Ничего не отправляется в интернет!
« Ответ #7 : 08 Май 2011, 06:08:47 »
Про MTU https://forum.ubuntu.ru/index.php?topic=47410.0 например тут обсуждалось.
Про FTP здесь http://rus-linux.net/MyLDP/consol/hdrguide/rusman/ftp.htm

Цитировать
Команда:   PASV
Ответ:   227 Entering Passive Mode (9x,1xx,1xx,1x1,9x,1x1).
Команда:   STOR about.html
Ответ:   150 Opening ASCII mode data connection for about.html
Ошибка:   Превышено время ожидания соединения
Каждый раз ошибка возникает при переходе в пассивный режим и последующем запросе на сохранение файла about.html
Вроде безобидная конструкция. Почему ошибка неясно.
« Последнее редактирование: 08 Май 2011, 06:32:09 от solint »

Оффлайн dimlevnik

  • Любитель
  • *
  • Сообщений: 68
    • Просмотр профиля
    • Веб-программирование
Re: Ничего не отправляется в интернет!
« Ответ #8 : 08 Май 2011, 07:47:37 »
 может в файлзиле выбрать другой вариант подключения, а то сейчас там пассивный видимо выбран
| KUbuntu 12.04 | i5-3570K | HD4000 | Z77H2-A3D | RAM 8G |

Оффлайн Красноглазый

  • Активист
  • *
  • Сообщений: 705
    • Просмотр профиля
Re: Ничего не отправляется в интернет!
« Ответ #9 : 08 Май 2011, 07:54:21 »
Я бы предположил ненастроенный локальный файервол. Скорее всего глушит порты передачи данных (1024+).

Оффлайн dennis-75

  • Автор темы
  • Новичок
  • *
  • Сообщений: 18
  • UBUNTU 11.10
    • Просмотр профиля
Re: Ничего не отправляется в интернет!
« Ответ #10 : 08 Май 2011, 11:57:03 »
Цитировать
ненастроенный локальный файервол

хорошая мысль. Я сразу сюда http://asplinux.net/node/18
сделал все как описано в примере и сейчас имею следующие правила
(Нажмите, чтобы показать/скрыть)

только тормознулся в самом конце
вот тут
 
Цитировать
root@dennis-desktop:/home/dennis# chkconfig --list iptables
iptables: unknown service
мне стало не понятно что происходит.
И еще вот этого /etc/rc.d/rc.local файла у меня нет. Есть каталоги rc0.d rc1.d rc2.d rc3.d rc4.d rc5.d rc6.d rcS.d но там что-то свое лежит.
как создать и нужно ли вообще - не знаю

В итоге проверил:
интернет есть
скайп и пидгин работают
filezilla и почта все также выделываются..

Цитировать
может в файлзиле выбрать другой вариант подключения, а то сейчас там пассивный видимо выбран

уже пробовал, вот тут увидел есть действтительно проблемы с брандмауэром вроде
(Нажмите, чтобы показать/скрыть)

Значит копать надо действительно файерволы и брандмауэры..
Только как???

Пользователь решил продолжить мысль 08 Май 2011, 12:07:18:
Цитировать
Чорт, пока одна мысль, в сторону MTU смотрел? Может увеличить? Опять же, не пользуясь гуем пробовал файл переслать? может доп.инфу получим.

имею следующие параметры

(Нажмите, чтобы показать/скрыть)
« Последнее редактирование: 08 Май 2011, 12:07:18 от dennis-75 »

Оффлайн Красноглазый

  • Активист
  • *
  • Сообщений: 705
    • Просмотр профиля
Re: Ничего не отправляется в интернет!
« Ответ #11 : 08 Май 2011, 17:51:34 »
По поводу файервола: если находишься за роутером и себя наружу не выставляешь - зачем вообще файервол? Попробуй убрать его вообще. Если заработает и решишь, что он все-таки нужен, будешь знать с чем бороться.

Оффлайн dennis-75

  • Автор темы
  • Новичок
  • *
  • Сообщений: 18
  • UBUNTU 11.10
    • Просмотр профиля
Re: Ничего не отправляется в интернет!
« Ответ #12 : 09 Май 2011, 23:05:19 »
В дополнение к теме топика некоторые уточнения (проводил различные тестовые отправки)
Цитировать
1. НЕ МОГУ ОТПРАВИТЬ ИЗ КОМПЬЮТЕРА ПОЧТУ БОЛЬШОГО ОБЪЕМА
Это действительно так - письма размером до 1КВ уходят на раз...
Все что больше - застревает после мучительных попыток отправиться ...
Цитировать
2. НЕ МОГУ ЗАГРУЗИТЬ НА ХОСТИНГ САЙТА ИЗ КОМПЬЮТЕРА ФАЙЛЫ НИ ПО FTP НИ ПО SSH
та-же ситуация , что и с почтовыми сообщениями - до 1000 байт любой файл уходит и на сервере вижу его в исправном состоянии.
Все что больше - Failzilla делает три попытки отправить файл, вроде у нее получается, но на сервере оказывается файл размером 0 байт(т.е битый)

и еще:
при заполнении, например, формы отправки сообщения здесь  на форуме, тоже не могу отправить набранное сообщение(думаю так случится и сейчас, буду перегружаться опять в винду)

сейчас в системе такая ситуация
iptables -L выдает что то непонятное(по крайней мере для меня, смотрел всякие сообщения и примеры в интернете там не так)
(Нажмите, чтобы показать/скрыть)

ufw был не активен (по умолчанию в ubuntu)
сделал его активным и сбросил настройки на заводские
(Нажмите, чтобы показать/скрыть)
почему здесь пишет invalid syntax не пойму, вроде из хелпа копирую, не срабатывает.

Если порассуждать на тему закрытых(или блокированных) портов или еще каких нибудь ограничений файерволами, то думаю он (файервол ) не виноват(хотя я не профи в этом и утверждать не могу). Ведь я по ftp и ssh спокойно подключаюсь к серверу, вижу все там и перехожу по каталогам.
Вчера торрент-клиент стоял на раздаче и спокойно раздавал фильмы на скорости до 600 кб/сек.
Месенджеры типа скайпа и qutIM тоже работают.
Все вроде работает, но вот эта непонятная проблема напрягает и очень расстраивает..
Больше всего, конечно, грешу на установку и удаление ClamAV..

В ИТОГЕ: так и не пойму куда копать дальше...
жду помощи...

спасибо всем, кто участвует


Пользователь решил продолжить мысль 09 Май 2011, 23:13:09:
Цитировать
при заполнении, например, формы отправки сообщения здесь  на форуме, тоже не могу отправить набранное сообщение
так и случилось...

Пользователь решил продолжить мысль 10 Май 2011, 11:57:47:
У кого какие мысли есть по этому поводу?????
« Последнее редактирование: 10 Май 2011, 11:57:47 от dennis-75 »

Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13753
    • Просмотр профиля
Re: Ничего не отправляется в интернет!
« Ответ #13 : 10 Май 2011, 12:27:57 »
Жуть сколько слов....
Вам выше про MTU намекали. Давайте посмотрим на
tracepath ip_сервера_хостинга
И тут уже не раз говорилось, что "OUTPUT -P DROP" даёт максимальный шанс на ошибку.
К тому же нет разрешения исходящим пакетам для уже установленных соединений
sudo ipables -A OUTPUT -m conntrack --ctstate RELATED,ESTABLISHED -j ACCEPTпопробуйте.

Если не поможет, то вообще попробуйте изменить правило по умолчанию для цепочки OUTPUT
sudo iptables -P OUTPUT ACCEPT
« Последнее редактирование: 10 Май 2011, 13:10:03 от fisher74 »
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

Оффлайн dennis-75

  • Автор темы
  • Новичок
  • *
  • Сообщений: 18
  • UBUNTU 11.10
    • Просмотр профиля
Re: Ничего не отправляется в интернет!
« Ответ #14 : 10 Май 2011, 12:41:49 »
Извиняюсь за количество слов  :)
Но хотелось объясить проблему поподробнее, да и пользователь форума я начинающий...
fisher74, Спасибо за рекомендации, вечером обязательно попробую (сейчас на работе, а удаленный доступ еще не настраивал)
Результаты обязательно выложу.

 

Страница сгенерирована за 0.064 секунд. Запросов: 24.