Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: не могу скомпилить opengl приложение  (Прочитано 2033 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн atap3d

  • Автор темы
  • Новичок
  • *
  • Сообщений: 26
    • Просмотр профиля
есть main.cpp

#include <qapplication.h>
#include <qgl.h>

int main(int argc,char** argv)
{
  QApplication app(argc,argv);
  QGLWidget qglw;

  app.setMainWidget(&qglw);
  qglw.show();
  return app.exec();
}

есть qtapp.pro

TEMPLATE = app
CONFIG -= moc
INCLUDEPATH += .
CONFIG += opengl
SOURCES += main.cpp

запускаю qmake - все ок, а вот make ругается

atap3d@atap3d-desktop:~/myprogram/qtapp$ make
g++  -o qtapp main.o    -L/usr/share/qt3/lib -L/usr/X11R6/lib -L/usr/X11R6/lib -lqt-mt -lGLU -lGL -lXmu -lXext -lX11 -lm -lpthread
/usr/bin/ld: cannot find -lGL
collect2: выполнение ld завершилось с кодом возврата 1
make: *** [qtapp] Ошибка 1

поставил в синаптике mesa*, opengl*, glu*
что еще надо поставить?
зы все примеры от nehe тоже говорят cannot find -lGL


Оффлайн atap3d

  • Автор темы
  • Новичок
  • *
  • Сообщений: 26
    • Просмотр профиля
Re: не могу скомпилить opengl приложение
« Ответ #1 : 01 Ноябрь 2007, 22:12:03 »
забыл сказать -- ubuntu 7.10

Оффлайн Kwah

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1442
  • Ubuntu 17.10
    • Просмотр профиля
Re: не могу скомпилить opengl приложение
« Ответ #2 : 01 Ноябрь 2007, 22:14:11 »
libgl-dev ?

Оффлайн atap3d

  • Автор темы
  • Новичок
  • *
  • Сообщений: 26
    • Просмотр профиля
Re: не могу скомпилить opengl приложение
« Ответ #3 : 01 Ноябрь 2007, 22:32:43 »
установлено libgl1-mesa* кроме libgl1-mesa-glide3* и libgl1-mesa-swx11* потому что хотят снести все относящееся к opengl. libgl-dev не нашел в синаптике

Оффлайн Kwah

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1442
  • Ubuntu 17.10
    • Просмотр профиля
Re: не могу скомпилить opengl приложение
« Ответ #4 : 01 Ноябрь 2007, 22:57:23 »
Хм.
Цитировать
~$ aptitude show libgl-dev
No current or candidate version found for libgl-dev
Package: libgl-dev
State: not a real package
Provided by: libgl1-mesa-dev, libgl1-mesa-swx11-dev
libGL.so есть вот в таких пакетах

Оффлайн atap3d

  • Автор темы
  • Новичок
  • *
  • Сообщений: 26
    • Просмотр профиля
Re: не могу скомпилить opengl приложение
« Ответ #5 : 01 Ноябрь 2007, 23:37:26 »
боюсь предположить, может, не в libGL.so дело? файл присутствует, но, видимо это ссылка на libGL.so.100.14.11, а может и нет - в mc отображается красным и с восклицательным знаком. а если нажать f3 - написано broken symbolic link to libGL.so.100.14.11
файл libGL.so.100.14.11 присутствует рядышком. почему ссылка то разорвана?
« Последнее редактирование: 01 Ноябрь 2007, 23:39:04 от atap3d »

Оффлайн Yurror

  • Старожил
  • *
  • Сообщений: 1966
    • Просмотр профиля
Re: не могу скомпилить opengl приложение
« Ответ #6 : 05 Ноябрь 2007, 13:26:35 »
Мммм здается мне что дровишки на видюху у вас кривовато встали. попробуйте починить их сначала прежде чем баловаться с 3D

 

Страница сгенерирована за 0.068 секунд. Запросов: 24.