Форум русскоязычного сообщества Ubuntu


Автор Тема: [РЕШЕНО]Не могу обновить webmin-Пакеты, имеющие неудовлетворённые зависимости.  (Прочитано 11530 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Mangekyou

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Доброго времени суток, господа.
Уже не первый день бьюсь и никак не могу решить проблему. А она вот в чем:
Ubuntu 10.04.1 LTS
После очередных обновлений решил обновить webmin. Т.к. через него же он сам не обновляется, запустил обновление вручную по удаленке через ssh.
Выдало вот что...
(Нажмите, чтобы показать/скрыть)
При попытке сделать apt-get -f install
(Нажмите, чтобы показать/скрыть)
Почитал форум, погуглил. Попробовал некоторые вещи, все равно опять 25.
Например советовали очистить кэш, это освободило 100мб, но у меня в корневом разделе еще более 1Гб свободно. К слову своп и /home отдельными разделами.
На часто советуемое dpkg --configure -a выдает
(Нажмите, чтобы показать/скрыть)
Пробовал и apt-get update и apt-get upgrade.. все сводится к зависимости linux-headers-2.6.32-31-generic-pae

В чем может быть дело, подскажите пожалуйста. Уже крыша едет, а своими силами видимо не смогу разобраться. Опыта маловато.
« Последнее редактирование: 17 Мая 2011, 01:07:14 от Mangekyou »

Оффлайн Mangekyou

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Up
вопрос еще актуален. у меня  :idiot2:

Оффлайн fanat1c

  • Участник
  • *
  • Сообщений: 128
  • KDE.
    • Просмотр профиля
Вот на оворужения...
(Нажмите, чтобы показать/скрыть)
Я есть Альфа и Омега, начало и конец.

Оффлайн фирэфохэ

  • Старожил
  • *
  • Сообщений: 2169
  • straightedge
    • Просмотр профиля
http://i18.ЗАПРЕЩЁННЫЙ РЕСУРС/big/2011/0325/6d/19eaa72dd24048a6fb0587832c4b096d.gif КДЕ - УГ. Дебиан - недоось.

Оффлайн Mangekyou

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Вот на оворужения...
(Нажмите, чтобы показать/скрыть)

Спасибо, не очень конечно помогло, но хотя бы я посмотрел, что пакет к которому указывает зависимость установлен.. не понимаю почему он ругается..

$ sudo aptitude update
$ sudo aptitude upgrade

в том то и дело, что я уже это пробовал.. хотя может стоило именно aptitude использовать..


Как это ни странно, решение я нашел ;)
Нашел на одном из форумов, не помню точно на каком, т.к. читал с работы, что вместо apt-get install linux-headers лучше использовать aptitude install linux-headers . Так и вышло. Система перестала ругаться на зависимость от пакета, показала что есть мол такие и такие пакеты, там то там то есть ошибка, предложила удалить пакеты linux-headers , что я и сделал. После чего великолепно сработали и apt-get update и apt-get upgrade. Ну и сам вебмин я тоже поставил корректно aptitude install webmin .

Всем спасибо кто обратил внимание.

 

Страница сгенерирована за 0.055 секунд. Запросов: 23.