Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Установка eclipse с модулем разработки на PHP  (Прочитано 16430 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Delfin

  • Автор темы
  • Участник
  • *
  • Сообщений: 190
  • u 7.10
    • Просмотр профиля
Перепробывал много редакторов, похожиш на PHP Expert Editor от винды не нашел.

Наконец постаил eclips, и он мне понравился.

Ман:
sud apt-get install eclipseПосле установки открываем в разделе програм Программирование.
Далее устанавливаем модуль php:
заходим Help > Software Updates > Find and Install… > Search for new features to install.
Жмем “New Remote Site” вставляем в URL: http://phpeclipse.sourceforge.net/update/releases а название даем любое.
Жмем далее, там находят модуль php. Отмечаем его галочкой и идем дальше, на вопросы вы уверены- отвечаем да, устанавливаем.

Затем можно установить кодировку для файлов cp1251 вместо юникода: window > perferentces > general > workspace поле text file encoding пишем cp1251 и сохраняем.
Все!
« Последнее редактирование: 07 Ноябрь 2007, 20:48:56 от victor53p »

Оффлайн stan

  • Активист
  • *
  • Сообщений: 291
  • Kubuntu
    • Просмотр профиля
Re: Установка eclipse с модулем разработки на PHP
« Ответ #1 : 07 Ноябрь 2007, 17:56:23 »
гораздо лучше будет это:

1) качаем pdt-all-in-one-1.0-R20070917-linux-gtk.tar.gz

2) ставим sun-java6-jre
sudo apt-get install sun-java6-jre
3) распаковываем eclipse в нужное место и работаем.

PS рекомендации предыдущего автора по настройке в силе.

Kubuntu

Оффлайн Delfin

  • Автор темы
  • Участник
  • *
  • Сообщений: 190
  • u 7.10
    • Просмотр профиля
Re: Установка eclipse с модулем разработки на PHP
« Ответ #2 : 07 Ноябрь 2007, 19:16:51 »
чем лучше? :)

Оффлайн stan

  • Активист
  • *
  • Сообщений: 291
  • Kubuntu
    • Просмотр профиля
Re: Установка eclipse с модулем разработки на PHP
« Ответ #3 : 08 Ноябрь 2007, 10:13:48 »
чем лучше? :)

Функциональностью, т.к. PDT это заточенный под PHP Eclipse, сделанный разработчиками eclipse.

Я работаю PHP-программистом уже 2 года и до PDT я использовал PHPeclipse, после начала использования производительность труда увеличилась существенно. Попробуйте и то и то, потом напишите что лучше :)
Kubuntu

Оффлайн Satyrius

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Re: Установка eclipse с модулем разработки на PHP
« Ответ #4 : 23 Ноябрь 2007, 11:27:45 »
1) качаем pdt-all-in-one-1.0-R20070917-linux-gtk.tar.gz
2) ставим sun-java6-jre
3) распаковываем eclipse в нужное место и работаем.
а вы не подскажете куда логичнее распаковать этот архив, где вообще по идее должны храниться общедоступные приложение, устанавливаемые вручную?

Оффлайн stan

  • Активист
  • *
  • Сообщений: 291
  • Kubuntu
    • Просмотр профиля
Re: Установка eclipse с модулем разработки на PHP
« Ответ #5 : 23 Ноябрь 2007, 12:45:05 »
у меня например в home есть папоска bin туда кладу все проги, которые не устанавливаются стандартными средствами.
Kubuntu

Оффлайн Kirill S.

  • Новичок
  • *
  • Сообщений: 21
    • Просмотр профиля
Сделал все по вашей инструкции - получилось, работает. Но как теперь eclipse перевести в режим работы с php, а то он до сих пор ide для java использует?

Оффлайн stan

  • Активист
  • *
  • Сообщений: 291
  • Kubuntu
    • Просмотр профиля
Сделал все по вашей инструкции - получилось, работает. Но как теперь eclipse перевести в режим работы с php, а то он до сих пор ide для java использует?

выбрать перспективу для работы под названием PHP - смотреть в правом верхнем углу на панеле инструментов.
Kubuntu

Оффлайн kusch

  • Новичок
  • *
  • Сообщений: 40
    • Просмотр профиля
у меня такой вопрос: в эклипсе есть подсветка такая как в зенде? а то оч привык к ней

Оффлайн stan

  • Активист
  • *
  • Сообщений: 291
  • Kubuntu
    • Просмотр профиля
у меня такой вопрос: в эклипсе есть подсветка такая как в зенде? а то оч привык к ней

если очень привык, то просто настрой такие же цвета для каждой синтаксической единицы в eclipse, не вижу в этом проблемы.


Update: только заметил, что это мой 500й пост в этом форуме  :coolsmiley: прикольно
Kubuntu

Оффлайн mariachi

  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
как заставить еклипс запускать скрипты что то не хочет совсем....?

Оффлайн murich

  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Установка eclipse с модулем разработки на PHP
« Ответ #11 : 14 Июнь 2008, 23:30:46 »
Цитировать
Requested operation cannot be performed because it would invalidate the current configuration. See details for more information.
  PDT Feature (1.0.3.v20080603-79-7PE7QYGHNH6Gh) requires feature "org.eclipse.wst (2.0.0)", or compatible.
Отето от после того как зеркало выбрал и оно начала его чекать
Что делать?

Оффлайн murich

  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Установка eclipse с модулем разработки на PHP
« Ответ #12 : 15 Июнь 2008, 00:16:59 »
О. Установилось. Немогу понять куда тут кодить - не сочтите за издевательство, подскажите

Оффлайн ferr0r

  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Установка eclipse с модулем разработки на PHP
« Ответ #13 : 06 Август 2008, 08:02:05 »
Поднимем-ка этот вопрос еще раз.

Такая ситуация. Установил с репозитория eclipse:
sudo aptitude install eclipseЗашел в Help -> Software Updates -> Find and Install...
Прописал туда два разныз пути для скачивания PDT, а именно:
http://download.eclipse.org/tools/pdt/updates/
http://downloads.zend.com/pdt/
Ставлю галки напротив них, жмем ОК и коннектимся к серверам. Ставлю галки напротив PDT и PDT Updates и наверху этого окна вылазиет сообщение об ошибке. Жму кнопку "Error Details...", получаю следующее
Цитировать
Current configuration contains errors that are not corrected by the requested operation and more errors would be introduced. See details for more information.
  ----- Current configuration problems -----
    Eclipse BIRT Report Designer Feature (2.1.2.v20070205-1728) requires plug-in "org.eclipse.tomcat (4.1.130)", or compatible.
    Eclipse BIRT Example (2.1.2.v20070205-1728) requires plug-in "org.eclipse.tomcat (4.1.130)", or compatible.
    Eclipse BIRT Report Runtime Feature (2.1.2.v20070205-1728) requires plug-in "org.eclipse.tomcat (4.1.130)", or compatible.
    Eclipse RCP Patch 2 for 3.2.2 (3.2.2.v20070417_322) requires feature "org.eclipse.rcp (3.2.2.r322_v20070104-8pcviKVqd8J7C1U)".
    Eclipse RCP Patch 3 for 3.2.2 (3.2.2.v20070507_322) requires feature "org.eclipse.rcp (3.2.2.r322_v20070104-8pcviKVqd8J7C1U)".
    Eclipse RCP Patch 1 for 3.2.2 (3.2.2.v20070330_322) requires feature "org.eclipse.rcp (3.2.2.r322_v20070104-8pcviKVqd8J7C1U)".
  ----- Configuration problems after the operation -----
    Eclipse BIRT Report Designer Feature (2.1.2.v20070205-1728) requires plug-in "org.eclipse.tomcat (4.1.130)", or compatible.
    Eclipse BIRT Example (2.1.2.v20070205-1728) requires plug-in "org.eclipse.tomcat (4.1.130)", or compatible.
    Eclipse BIRT Report Runtime Feature (2.1.2.v20070205-1728) requires plug-in "org.eclipse.tomcat (4.1.130)", or compatible.
    Eclipse RCP Patch 2 for 3.2.2 (3.2.2.v20070417_322) requires feature "org.eclipse.rcp (3.2.2.r322_v20070104-8pcviKVqd8J7C1U)".
    Eclipse RCP Patch 3 for 3.2.2 (3.2.2.v20070507_322) requires feature "org.eclipse.rcp (3.2.2.r322_v20070104-8pcviKVqd8J7C1U)".
    Eclipse RCP Patch 1 for 3.2.2 (3.2.2.v20070330_322) requires feature "org.eclipse.rcp (3.2.2.r322_v20070104-8pcviKVqd8J7C1U)".
    PDT Feature (1.0.3.v20080603-79-7PE7QYGHNH6Gh) requires feature "org.eclipse.wst (2.0.0)", or compatible.
Выхожу из обновления, чтобы посмотреть какие плагины у меня стоят (Help -> About Eclipse SDK -> Plug-In Details)
Сортирую список по Plug-In ID... и нахожу там этот самый org.eclipse.tomcat (4.1.130)

Для пущей уверенности делаю еще так:
locate tomcatи получаю:
Цитировать
/usr/lib/eclipse/plugins/org.eclipse.tomcat_5.5.17
/usr/lib/eclipse/plugins/org.eclipse.platform.source_3.2.2.r322_v20070119-CXMbUe9K_WF26uA/src/org.eclipse.tomcat_5.5.17
/usr/lib/eclipse/plugins/org.eclipse.platform.source_3.2.2.r322_v20070119-CXMbUe9K_WF26uA/src/org.eclipse.tomcat_5.5.17/about.html
/usr/lib/eclipse/plugins/org.eclipse.platform.source_3.2.2.r322_v20070119-CXMbUe9K_WF26uA/src/org.eclipse.tomcat_5.5.17/tomcatwrappersrc.zip
/usr/lib/eclipse/plugins/org.eclipse.tomcat_5.5.17/META-INF
/usr/lib/eclipse/plugins/org.eclipse.tomcat_5.5.17/about.html
/usr/lib/eclipse/plugins/org.eclipse.tomcat_5.5.17/about_files
/usr/lib/eclipse/plugins/org.eclipse.tomcat_5.5.17/conf
/usr/lib/eclipse/plugins/org.eclipse.tomcat_5.5.17/lib
/usr/lib/eclipse/plugins/org.eclipse.tomcat_5.5.17/plugin.properties
/usr/lib/eclipse/plugins/org.eclipse.tomcat_5.5.17/plugin.xml
/usr/lib/eclipse/plugins/org.eclipse.tomcat_5.5.17/preferences.ini
/usr/lib/eclipse/plugins/org.eclipse.tomcat_5.5.17/tomcatwrapper.jar
/usr/lib/eclipse/plugins/org.eclipse.tomcat_5.5.17/webapps
/usr/lib/eclipse/plugins/org.eclipse.tomcat_5.5.17/META-INF/MANIFEST.MF
/usr/lib/eclipse/plugins/org.eclipse.tomcat_5.5.17/conf/catalina.policy
/usr/lib/eclipse/plugins/org.eclipse.tomcat_5.5.17/conf/tomcat-users.xml
/usr/lib/eclipse/plugins/org.eclipse.tomcat_5.5.17/conf/web.xml
/usr/lib/eclipse/plugins/org.eclipse.tomcat_5.5.17/lib/bootstrap.jar
/usr/lib/eclipse/plugins/org.eclipse.tomcat_5.5.17/lib/catalina-optional.jar
/usr/lib/eclipse/plugins/org.eclipse.tomcat_5.5.17/lib/catalina.jar
/usr/lib/eclipse/plugins/org.eclipse.tomcat_5.5.17/lib/commons-beanutils.jar
/usr/lib/eclipse/plugins/org.eclipse.tomcat_5.5.17/lib/commons-collections.jar
/usr/lib/eclipse/plugins/org.eclipse.tomcat_5.5.17/lib/commons-digester.jar
/usr/lib/eclipse/plugins/org.eclipse.tomcat_5.5.17/lib/commons-el.jar
/usr/lib/eclipse/plugins/org.eclipse.tomcat_5.5.17/lib/commons-logging-api.jar
/usr/lib/eclipse/plugins/org.eclipse.tomcat_5.5.17/lib/commons-modeler.jar
/usr/lib/eclipse/plugins/org.eclipse.tomcat_5.5.17/lib/jasper-compiler.jar
/usr/lib/eclipse/plugins/org.eclipse.tomcat_5.5.17/lib/jasper-runtime.jar
/usr/lib/eclipse/plugins/org.eclipse.tomcat_5.5.17/lib/jsp-api.jar
/usr/lib/eclipse/plugins/org.eclipse.tomcat_5.5.17/lib/mx4j-impl.jar
/usr/lib/eclipse/plugins/org.eclipse.tomcat_5.5.17/lib/mx4j-jmx.jar
/usr/lib/eclipse/plugins/org.eclipse.tomcat_5.5.17/lib/naming-factory.jar
/usr/lib/eclipse/plugins/org.eclipse.tomcat_5.5.17/lib/naming-resources.jar
/usr/lib/eclipse/plugins/org.eclipse.tomcat_5.5.17/lib/servlet-api.jar
/usr/lib/eclipse/plugins/org.eclipse.tomcat_5.5.17/lib/servlets-default.jar
/usr/lib/eclipse/plugins/org.eclipse.tomcat_5.5.17/lib/servlets-invoker.jar
/usr/lib/eclipse/plugins/org.eclipse.tomcat_5.5.17/lib/tomcat-coyote.jar
/usr/lib/eclipse/plugins/org.eclipse.tomcat_5.5.17/lib/tomcat-http.jar
/usr/lib/eclipse/plugins/org.eclipse.tomcat_5.5.17/lib/tomcat-util.jar
/usr/lib/eclipse/plugins/org.eclipse.tomcat_5.5.17/webapps/ROOT
/usr/lib/eclipse/plugins/org.eclipse.tomcat_5.5.17/webapps/ROOT/WEB-INF
/usr/lib/eclipse/plugins/org.eclipse.tomcat_5.5.17/webapps/ROOT/index.html
/usr/lib/eclipse/plugins/org.eclipse.tomcat_5.5.17/webapps/ROOT/WEB-INF/web.xml
/usr/share/tomcat5.5
...
В eclipse написано, что версия tomcat 4.1.130.v20060601, а в реале получается, что стоит 5.5.17.

В чем проблема установки PDT? Где я ошибаюсь? Или ошибаюсь не я, а Kubuntu, которая ни разу не переустанавливалась с версии этак 6.10, а стоит уже 8.04.

P.S. Меньше всего грешу на последний вопрос, так как переустановка чего-то там -- это проблема виндузятников :)
P.P.S. Предложения поставить all-in-one не рассматриваю. На то есть свои причины.

Оффлайн rusik

  • Новичок
  • *
  • Сообщений: 36
    • Просмотр профиля
Re: Установка eclipse с модулем разработки на PHP
« Ответ #14 : 10 Август 2008, 20:10:59 »
эм люди подскажите - что то я не понял...
вроде бы как установил модуль всё нормально,
но как теперь открывать php документы и что-либо делать??
а то при попытке у меня вылазиет ошибочка  :(
вообщем я просто создаю php файл пишу какой нить код сохраняю пытаюсь открыть, а оно пишет что
An error was ocurred.See error log for more details. (или оно же прсто выводит серый фон вверху написано php editor но кода и способа его ввести я не вижу)
+ файл скрина почему не прикрепляется на форуме пишет(пишет 0 кб) 
« Последнее редактирование: 10 Август 2008, 20:21:25 от rusik »

 

Страница сгенерирована за 0.06 секунд. Запросов: 24.