Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Настройка MTU в network manager [SOLVED]  (Прочитано 4918 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Istaron

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Настройка MTU в network manager [SOLVED]
« : 18 Июнь 2011, 11:58:16 »
У меня интернет через PPPoE, и я не могу выставить правильный MTU. Нужен 1488, а что бы я ни делал используется 1492 для ppp0. Может кто подскажет как происходит соединение через network manager и какой конфиг поправить? Rp-pppoe не предлагать. При MTU 1492 появляются различные проблемы, например не могу логиниться на gmail.

sudo ifconfig ppp0 mtu 1488 конечно помогает, но до первой перезагрузки.
Цитировать
Эммм...., а в настройке соединения в закладку "Проводные" заглядывали?
Увы, видимо баг, изменять там MTU бесполезно, не работает. Для ethernet тоже не работает.

Цитировать
А правильнее всего, конечно поправить /etc/ppp/options
Код:

mtu 1488
Увы это тоже не сработало

Цитировать
Код: (/etc/ppp/ip-up.d/mtu)

#!/bin/sh
ifconfig $1 mtu 1488

chmod o+x /etc/ppp/ip-up.d/mtu
решило мою проблему, спасибо KT315.
« Последнее редактирование: 18 Июнь 2011, 15:04:20 от Istaron »

Оффлайн babay2004

  • Старожил
  • *
  • Сообщений: 1003
  • Последний герой.
    • Просмотр профиля
Re: Настройка MTU в network manager
« Ответ #1 : 18 Июнь 2011, 12:14:40 »
sudo ifconfig ppp0 mtu 1488 конечно помогает, но до первой перезагрузки.
Ну впиши ifconfig ppp0 mtu 1488 в /etc/rc.local, делов-то!..
Cardiowave. Fedora-18. Gnome-shell. x64. AgiliaLinux.

Оффлайн alecsartania

  • Старожил
  • *
  • Сообщений: 1561
  • УМка.
    • Просмотр профиля
Re: Настройка MTU в network manager
« Ответ #2 : 18 Июнь 2011, 12:53:57 »
/etc/interfaces like this:

iface eth0 inet dhcp
hostname “mymachine”
name LAN Interface
post-up /sbin/ifconfig eth0 mtu 1492
Дома Linux mint 15 ||  Ubuntu 14.04  / Минт 17.03
Работа: Linux Mint 18(Ub 16.04)

Гарри Кашпировский

  • Гость
Re: Настройка MTU в network manager
« Ответ #3 : 18 Июнь 2011, 13:03:24 »
/etc/interfaces like this:

iface eth0 inet dhcp
hostname “mymachine”
name LAN Interface
post-up /sbin/ifconfig eth0 mtu 1492


Почему eth0?
Почему в interfaces?
У ТС ppp0 интерфейс и управляется Network-Manager :)

Istaron, на твоём месте я бы просто написал простенький скрипт в две строчки.
Код: Text
  1. #!/bin/sh
  2. ifconfig $1 mtu 1488
chmod o+x /etc/ppp/ip-up.d/mtu

Пользователь решил продолжить мысль 18 Июнь 2011, 13:12:50:
А правильнее всего, конечно поправить /etc/ppp/options
mtu 1488
« Последнее редактирование: 18 Июнь 2011, 13:12:50 от KT315 »

Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13750
    • Просмотр профиля
Re: Настройка MTU в network manager
« Ответ #4 : 18 Июнь 2011, 14:37:19 »
Может кто подскажет как происходит соединение через network manager и какой конфиг поправить?
Эммм...., а в настройке соединения в закладку "Проводные" заглядывали?
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

ikstlen

  • Гость
Re: Настройка MTU в network manager
« Ответ #5 : 18 Июнь 2011, 14:53:28 »

религия не позволяет?

Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13750
    • Просмотр профиля
Re: Настройка MTU в network manager [SOLVED]
« Ответ #6 : 18 Июнь 2011, 15:55:43 »
Только соединение нужно выбрать соответствующее, а не eth0
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

 

Страница сгенерирована за 0.158 секунд. Запросов: 24.