Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Интерфейс wlan0 отключен и интерфейс wlan0:avahi не существует.  (Прочитано 4626 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн wiktor

  • Автор темы
  • Любитель
  • *
  • Сообщений: 64
    • Просмотр профиля
Ситуация обычная. Ubuntu 7.10, карта wi-fi от Ралинка Gigabyte WPKG. Драйвер виндовский поставил через ndisgtk. Вроде поставился нормально (конечно две недели ушло на попытки поставить линуксовский драйвер Ралинка, но успехом не увенчались). Теперь проблема с интерфейсом wlan0. Настроить его не могу никак. Все попытки поднять его с использованием разних способов  и поисков в инете к успеху не привели. Он отключен и все тут. Никаких ай-пи или активности не показывает. Так же при этом образовался интерфейс wlan0:avahi (показывает его в сетевых утилитах), который имеет ай-пи 169. 254.6.203, но при попытке его настроить выскакивает табличка, что такого интерфейса не существует.

w@wiktor:~$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11g  ESSID:"nets" 
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
          Retry min limit:7   RTS thr:off   Fragment thr=2346 B   
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0


w@wiktor:~$ ifconfig
lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Диапазон:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:20 errors:0 dropped:0 overruns:0 frame:0
          TX packets:20 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1440 (1.4 KB)  TX bytes:1440 (1.4 KB)

wlan0     Link encap:Ethernet  HWaddr 00:0F:EA:0A:B4:65 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

wlan0:ava Link encap:Ethernet  HWaddr 00:0F:EA:0A:B4:65 
          inet addr:169.254.6.203  Bcast:169.254.255.255  Mask:255.255.0.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1

wmaster0  Link encap:UNSPEC  HWaddr 00-0F-EA-0A-B4-65-00-00-00-00-00-00-00-00-00-00 
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)


w@wiktor:~$ route -n
Таблица маршутизации ядра протокола IP
Destination Gateway Genmask Flags Metric Ref Use Iface
169.254.0.0     0.0.0.0         255.255.0.0     U     0      0        0 wlan0
0.0.0.0         0.0.0.0         0.0.0.0         U     1000   0        0 wlan0


Вопросы

Как включить wlan0 или сделать существующим wlan0:avahi?

Как обойтись без шифрования (подозреваю, что это из-за отсутствия шифрования в сети)?

Как включить Ad-Hoc?

Оффлайн Pegasus

  • Участник
  • *
  • Сообщений: 213
  • Ubuntu 8.04 AthXP 2500+ nForce2 1GB geForce6600GT
    • Просмотр профиля
читай мой топ, там есть ответы на твои вопросы, смотри как я настраивал в 7,04.  у меня тоже проблемы, но у меня и IP есть и сеть видна, нельзя только подключиться, зачем ты вообще драйвера ставил? они есть из коробки и я пробую поднять их, в 7,04 поднял.
« Последнее редактирование: 16 Ноябрь 2007, 14:46:42 от Pegasus »

Оффлайн wiktor

  • Автор темы
  • Любитель
  • *
  • Сообщений: 64
    • Просмотр профиля
Ну прикол. Только сделал ветку и сразу как озарило. :) (Пишу уже с Ubuntu)

Что делал. Отключил нетворк менеджер как пишется тут http://citkit.ru/articles/424/. Сделал это потому что автор там утверждает, что нетворк менеджер не поддерживает Ad-hoc.

Потом в терминале прописал

sudo ifconfig wlan0 down

sudo iwconfig wlan0 mode Ad-Hoc

sudo ifconfig wlan0 192.168.0.71 up (такой ай-пи раздала винда с основного компа на этот комп и я это увидел на паралельной винде на этом компе)

sudo iwconfig wlan0 essid "nets"

sudo iwconfig wlan0 channel auto

sudo ifconfig wlan0 up

Потом включил Пинг 192.168.0.1 через сетевые утилиты. Потом там же Трассировку маршрута 192.168.0.1 (может этого и не надо было делать, но инет появился как раз после успеха в этих функциях). Ай-пи изменило автоматически на другой.

Инет есть. Ура. 

Немного он глючный. Видно надо еще ковыряться, но основное сделано.

Оффлайн Pegasus

  • Участник
  • *
  • Сообщений: 213
  • Ubuntu 8.04 AthXP 2500+ nForce2 1GB geForce6600GT
    • Просмотр профиля
а вот у меня всё это не работало сразу

Оффлайн wiktor

  • Автор темы
  • Любитель
  • *
  • Сообщений: 64
    • Просмотр профиля
Перегрузил комп, все пропало нафик. Повторяю в терминале, ничего не дает. Вот так.  >:(

 

Страница сгенерирована за 0.055 секунд. Запросов: 22.