Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Не отключается led на камере  (Прочитано 15455 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн uitrix

  • Автор темы
  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Не отключается led на камере
« : 05 Август 2011, 22:46:09 »
Ноут Asus F3Ja, Ubuntu 11.04;
После использования Skype (завершение звонка/выход из программы совсем -- не важно), диодик на веб-камере (встроенной) не гаснет, продолжает гореть. Хотелось бы как-нибудь это пофиксить.. Даже после использования если вручную как-нибудь убивать (не убив совсем камеру, что б снова можно было продолжать с ней работать при необходимости)

Подскажите, в какую сторону и как копать, чтобы без перезагрузки системы с сиим справляться :-)
Заранее спасибо

Axa-Ru

  • Гость
Re: Не отключается led на камере
« Ответ #1 : 05 Август 2011, 23:19:50 »
      # Enable the webcam driver
      modprobe uvcvideo

      # Remove the webcam driver
      modprobe -r uvcvideo

Но это кувалда. Skype должен отключать сам.

Оффлайн uitrix

  • Автор темы
  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Re: Не отключается led на камере
« Ответ #2 : 06 Август 2011, 14:42:39 »
     # Enable the webcam driver
      modprobe uvcvideo

      # Remove the webcam driver
      modprobe -r uvcvideo

Но это кувалда. Skype должен отключать сам.
Никакого внешнего эффекта.

Оффлайн rig

  • Участник
  • *
  • Сообщений: 137
  • Не сидел бы на стене, не свалился бы во сне :)
    • Просмотр профиля
    • Блог интернет варвара :)
Re: Не отключается led на камере
« Ответ #3 : 06 Август 2011, 22:51:51 »
После использования Skype... не гаснет, продолжает гореть.

Может руткит или троянец? Проверяли, что сама камера не активна?
SAMSUNG 900X4C (Core i5 3317U 1700 Mhz/15.0"/1600x900/8192Mb/256Gb/Xubuntu 12.04 64-bit)

Sony VAIO VGN-FW56SR (Core 2 Duo P7450 2130 Mhz/16.4"/1600x900/4096Mb/320.0Gb/Blu-Ray/Xubuntu 12.04 64-bit).

Оффлайн gThumb

  • Новичок
  • *
  • Сообщений: 34
    • Просмотр профиля
Re: Не отключается led на камере
« Ответ #4 : 22 Август 2011, 19:10:43 »
У меня ASUS P81IJ. Система Kubuntu 11.04. Заметил, что светодиод камеры включается и светится в пол тона после загрузки звуковой системы, в момент старта Kubuntu. Поставил Cheese - веб камера работает нормально. После выключения Cheese - диод гаснет (но при следующем старте системы все повторяется). Каждый раз клацать Cheese как то не прикольно...
Добился старта системы без включенного LED заменой библиотек воспроизведения GStreamer на VLC (Не совсем правда понимаю, где логика... при чем тут библиотеки воспроизведения к LED Web-камеры....). Установил пакет phonon-backend-vlc и выбрал Phonon VLC в Параметры системы --> Мультимедиа --> Phonon --> Библиотеки воспроизведения.
Skype 2.2 у меня не заработал, пользуюсь Skype 2.1. В момент запуска он включает светодиод камеры, однако после видеозвонка - диод тухнет и дальше все гуд. Если в Skype снять галочку "Включать мое видео" все вообще гуд... но как это в скайпе без видео? ??? Камера в скайпе тухнет и после "Проверить видео" в разделе "Настройки видео", но это тоже как то не гуд... каждый раз ото клацать.
Т.е. глюк с LED в Skype - остался.
Для чистоты эксперимента.... Я еще снес PulseAudio. После такой манипуляции у меня на буке полноценно заработала звуковая система.  :2funny:
Снос зловредного PulseAudio в классической Ubuntu (Gnome среда) описан тут: http://help.ubuntu.ru/wiki/%D1%83%D0%B4%D0%B0%D0%BB%D0%B5%D0%BD%D0%B8%D0%B5_pulseaudio
Попробуй, может поможет. Ну хоть звуковую систему нормальную получишь.  :)
« Последнее редактирование: 22 Август 2011, 20:28:57 от gThumb »
Открытый код - залог Вашего здоровья!

Оффлайн gThumb

  • Новичок
  • *
  • Сообщений: 34
    • Просмотр профиля
Re: Не отключается led на камере
« Ответ #5 : 22 Август 2011, 20:24:12 »
Проблема похоже новая, в прошлых версиях Ubuntu/Kubuntu я на своем буке с включающимся при старте системы диодом веб-камеры не сталкивался.
Цитировать
Может руткит или троянец? Проверяли, что сама камера не активна?
Какой "троянец" в свежеустановленной системе Linux? И вооще, что за бред про вирусы в Linux... Достаточно много лет линух юзаю, в жизни вирусов не видал.... (может просто повезло :))
Это испорченный ломаной виндой мозг ЖАХИ рисует....  ;)
А вот про "глюк" в какой то из библиотек системных приложений, задуматься стоит. И дело не в Скайпе уж точно....
Предполагаю.

Пользователь решил продолжить мысль 24 Август 2011, 16:04:27:
Дело точно не в скайпе. Google Talk ведет себя аналогично. При звонке включается диод камеры, а вот потом не тухнет после закрытия.
Как чинить?
« Последнее редактирование: 24 Август 2011, 16:04:27 от gThumb »
Открытый код - залог Вашего здоровья!

Оффлайн ravus

  • Новичок
  • *
  • Сообщений: 7
  • Debian 7, MATE
    • Просмотр профиля
Re: Не отключается led на камере
« Ответ #6 : 13 Октябрь 2011, 18:48:12 »
У меня та же проблема. Ноутбук Asus F3Sg. Та же ситуация как и gThumb, постоянно горит led камеры.
Bus 001 Device 002: ID 174f:5a35 Syntek Sonix 1.3MPixel USB 2.0 Camera
 После использования chees тухнет. У меня проблема возникла на Ubuntu 11.04 и 11.10, а так же на последней open suse. Удаление пульса проблему не решает, звук нормально работает и с ним... кто то знает как решить эту проблему  :'(??? где вы гуру??
P.S. Выпаять led из камеры не предлагать  :)
« Последнее редактирование: 13 Октябрь 2011, 21:46:03 от ravus »
Debian Wheezy, MATE

Оффлайн pavlushka333

  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Re: Не отключается led на камере
« Ответ #7 : 15 Октябрь 2011, 20:50:32 »
Такая же фигня. Поставил щас 10.10 на бук asus p50ij и глаза мои бедные мазолит зелёный огонёк веб камеры. cheese если запустить и выключить то огонёк тухнит. Если перезагрузить то опять по новой.
Где искать проблему?

Оффлайн okuntsov

  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
Re: Не отключается led на камере
« Ответ #8 : 17 Октябрь 2011, 19:47:07 »
Поставил 11.10 на свой Asus P50IJ также загорается при старте зеленый индикатор. До это начиная с 10.04 такого не было. Также как и у всех он пропадает при включении и выключении вебкамеры через Cheese или Skype. И еще выяснил вот что: если вставить флешку или мышку или 3G модем через usb он также ативируется и горит зеленым светом. У кого какие соображения как это починить?

Оффлайн retimer

  • Новичок
  • *
  • Сообщений: 31
  • Ubuntism.ru
    • Просмотр профиля
    • Убунтизм для пользователя
Re: Не отключается led на камере
« Ответ #9 : 23 Октябрь 2011, 17:12:56 »
Вот такое решение предложено у буржуев:
cd /etc/pm/sleep.d/
gksudo gedit 99-uvc-webcam-reset
В открывшийся файл копипастим следующее:
#!/bin/bash

case "$1" in
    thaw|resume)
        rmmod uvcvideo; sleep 2; modprobe uvcvideo
        ;;
    *)
        ;;
esac
exit $?
Сохраняем и выполняем в консоли:
sudo chmod a+x 99-uvc-webcam-reset

Axa-Ru

  • Гость
Re: Не отключается led на камере
« Ответ #10 : 23 Октябрь 2011, 17:38:44 »
retimer, смотрим ответ 1

Оффлайн okuntsov

  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
Re: Не отключается led на камере
« Ответ #11 : 23 Октябрь 2011, 20:03:50 »
Вот такое решение предложено у буржуев:
cd /etc/pm/sleep.d/
gksudo gedit 99-uvc-webcam-reset
В открывшийся файл копипастим следующее:
#!/bin/bash

case "$1" in
    thaw|resume)
        rmmod uvcvideo; sleep 2; modprobe uvcvideo
        ;;
    *)
        ;;
esac
exit $?
Сохраняем и выполняем в консоли:
sudo chmod a+x 99-uvc-webcam-reset
Этот код для состояния sleep - на моем Asus P50IJ этот скрипт вылечил сосотояние sleep
А вот похоже включение светодиода камеры на активацию порта usb кроется в ошибке https://bugs.launchpad.net/ubuntu/+source/gspca/+bug/525959

Оффлайн gThumb

  • Новичок
  • *
  • Сообщений: 34
    • Просмотр профиля
Re: Не отключается led на камере
« Ответ #12 : 23 Октябрь 2011, 23:32:16 »
Спасибо retimer и okuntsov. Предложенный скрипт действительно лечит давнюю проблему с диодом камеры при выходе из спящего режима.
А вот про глюк в драйвере еще надо посмотреть. Дело в том что, включение светодиода при старте системы началось в Kubuntu после замены разработчиками библиотек воспроизведения Xine на GStreamer. И в KDE этот глюк при старте, чинится подменой библиотек воспроизведения GStreamer например на VLC (в Параметрах системы). Это я к тому, что Skype (и прочие схожие приблуды) наверняка при работе использует библиотеки GStreamer. А это значит, что баг может быть не в драйвере, а в GStreamer. В общем надо покопаться...
А пока, я например ниче лучше не придумал как прописать в автозапуске команду:
sleep 15s && kstart --iconify --skiptaskbar cheese & sleep 18s && killall cheese
Не я понимаю, что это примерно то же, что чинить двигатель запорожца через выхлопную тубу... :2funny: но зато хоть какое то решение.
Для тех кот не понял - запускаем и убиваем cheese после старта системы. Это для КДЕ. Для классической убунты kstart --iconify --skiptaskbar естественно не надо. Поэтому будет мигать окно cheese.
sleep 15s && cheese & sleep 18s && killall cheese
Все это работает только после загрузки звуковой системы т.е. когда светодиод уже загорелся, так что подбираем при необходимости свои цифры 15s и 18s. Ну и естественно при установленном Сheese. :)
Skype запускаю скриптом:
#!/bin/sh
skype & sleep 3s && kstart --iconify --skiptaskbar cheese & sleep 5s && killall cheese
Сheese тут просто тушит диод.
Согласен, это не совсем правильный подход к решению этой проблемы, но пока хоть какой то.
Открытый код - залог Вашего здоровья!

Оффлайн okuntsov

  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
Re: Не отключается led на камере
« Ответ #13 : 24 Октябрь 2011, 09:38:34 »
А у меня я так понял светодиод реагирует на активацию порта USB. Жду обновления ядра на Ubuntu 11.10
Не выдержал, поставил ядро 3.1 http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.1-oneiric/ но проблему это не решило :(
« Последнее редактирование: 25 Октябрь 2011, 09:43:23 от okuntsov »

Оффлайн gThumb

  • Новичок
  • *
  • Сообщений: 34
    • Просмотр профиля
Re: Не отключается led на камере
« Ответ #14 : 25 Октябрь 2011, 16:24:15 »
Ну установка новой версии ядра к сожалению не гарантирует что в этом ядре исправили баг в драйвере...  :)
Если проблема в кривых кодах драйверов. Я все сильнее думаю, что дело не в драйверах, а в глюке в GStreamer.
В классической Ubuntu этот эксперимент не пройдет, там (как я понимаю) GStreamer зашит "навсегда"..., а вот в Kubuntu библиотеки GStreamer можно подменить на альтернативные на уровне системы (например на phonon-backend-vlc).
Так вот, если по умолчанию стоит GStreamer, то не только проблемы с веб-камерой, а еще и в Dolphin не работает предварительное прослушивание аудиофайлов. При наведении курсора на аудиофайл Dolphin пытается его воспроизводить и (внимание!!!) вместо звука запускается светодиод камеры.... и горит в пол тона  ;D .
Меняем GStreamer на альтернативную библиотеку иии... все работает...  :)
Думаю, что GStreamer глюкавый.
Цитировать
Это я к тому, что Skype (и прочие схожие приблуды) наверняка при работе использует библиотеки GStreamer.
А это объясняет почему диод активируется при запуске Skype. Тоже я думаю происходит и при использовании других медиа-устройств, рассчитанных на использование GStreamer.
Открытый код - залог Вашего здоровья!

 

Страница сгенерирована за 0.068 секунд. Запросов: 24.