= 1.2.4.0~debian1-1) но он не будет установлен Рекомендует: php5-gd но он не будет установлен E: Неудовлетворённые зависимости." /> = 1.2.4.0~debian1-1) но он не будет установлен Рекомендует: php5-gd но он не будет установлен E: Неудовлетворённые зависимости." /> как переустановить апаче - Ubuntu.ru

Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: как переустановить апаче  (Прочитано 5737 раз)

0 Пользователей и 1 Гость просматривают эту тему.

sersne

  • Автор темы
  • Гость
как переустановить апаче
« : 16 Август 2011, 10:33:44 »
по ошибке снес папки c php и apache. пытался установить заново , но пишет:
"Возможно, для исправления этих ошибок вы захотите воспользоваться `apt-get -f install':
Пакеты, имеющие неудовлетворённые зависимости:
 apache2 : Зависит: apache2-mpm-worker (= 2.2.16-1ubuntu3.1) но он не будет установлен или
                           apache2-mpm-prefork (= 2.2.16-1ubuntu3.1) но он не будет установлен или
                           apache2-mpm-event (= 2.2.16-1ubuntu3.1) но он не будет установлен или
                           apache2-mpm-itk (= 2.2.16-1ubuntu3.1) но он не будет установлен
           Зависит: apache2.2-common (= 2.2.16-1ubuntu3.1) но он не будет установлен
 phpmyadmin : Зависит: libapache2-mod-php5 но он не будет установлен или
                              php5-cgi но он не будет установлен или
                              php5 но он не будет установлен
              Зависит: php5-mysql но он не будет установлен или
                              php5-mysqli но он не может быть установлен
              Зависит: php5-mcrypt но он не будет установлен
              Зависит: dbconfig-common но он не будет установлен
              Зависит: libjs-mootools (>= 1.2.4.0~debian1-1) но он не будет установлен
              Рекомендует: php5-gd но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить 'apt-get -f install', не указывая имени пакета, (или найдите другое решение)."
подскажите как переустановить apache2+php

Оффлайн ArcFi

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 15189
    • Просмотр профиля
    • aetera.net
Re: как переустановить апаче
« Ответ #1 : 16 Август 2011, 10:39:45 »
Отключить все левые репы, обновить индекс, повторить.

sersne

  • Автор темы
  • Гость
Re: как переустановить апаче
« Ответ #2 : 16 Август 2011, 10:44:01 »
чуть подробнее, как "Отключить все левые репы, обновить индекс".

Оффлайн ArcFi

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 15189
    • Просмотр профиля
    • aetera.net
Re: как переустановить апаче
« Ответ #3 : 16 Август 2011, 10:46:51 »
lsb_release -d
grep -v '^#\|^$' /etc/apt/sources.list{,.d/*.list}
?

Цитировать
обновить индекс
sudo apt-get update

sersne

  • Автор темы
  • Гость
Re: как переустановить апаче
« Ответ #4 : 16 Август 2011, 11:16:47 »
phpmyadmin был удален коряво...

Удаляется пакет phpmyadmin ...
.: 5: Can't open /usr/share/dbconfig-common/dpkg/prerm.mysql
dpkg: не удалось обработать параметр phpmyadmin (--remove):
 подпроцесс установлен сценарий pre-removal возвратил код ошибки 127
.: 35: Can't open /usr/share/dbconfig-common/dpkg/postinst.mysql
dpkg: ошибка при очистке -
 подпроцесс установлен сценарий post-installation возвратил код ошибки 127
При обработке следующих пакетов произошли ошибки:
 phpmyadmin
E: Sub-process /usr/bin/dpkg returned an error code (1)

Оффлайн ArcFi

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 15189
    • Просмотр профиля
    • aetera.net

 

Страница сгенерирована за 0.064 секунд. Запросов: 25.