Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Настройка l2tp соединения в ubuntu  (Прочитано 2321 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн dsw2

  • Автор темы
  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Настройка l2tp соединения в ubuntu
« : 03 Сентябрь 2011, 19:39:36 »
Здравствуйте, никак не получается настроить интернет в ubuntu v 10.04. делал следующее.
1) Удаляю стандартный network manager

2)Ставлю пакет xl2tpd

3)Редактирую /etc/network/interfaces:
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

4)Правлю /etc/resolv.conf
nameserver  94.230.128.3
nameserver  94.230.129.3

Вывод netstat -nr:

Таблица маршутизации ядра протокола IP
10.255.0.128    10.20.232.1     255.255.255.128 UG        0 0          0 eth0
10.20.232.0     0.0.0.0         255.255.255.0   U         0 0          0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U         0 0          0 eth0
10.0.0.0        10.20.232.1     255.128.0.0     UG        0 0          0 eth0
0.0.0.0         10.20.232.1     0.0.0.0         UG        0 0          0 eth0


*Здесь возникает проблема, dns сервера постоянно скидываются на стандартный
nameserver 10.255.0.2

5)Правлю /etc/ppp/options.xl2tpd:

unit 0
name ЛОГИН
remotename l2tp
ipparam provaider
connect /bin/true
mru 1450
mtu 1450
nodeflate
nobsdcomp
persist
maxfail 0
nopcomp
noaccomp
#usepeerdns
defaultroute
replacedefaultroute

6)Правлю /etc/ppp/chap-secrets:
Логин * Пароль *

7)Правлю /etc/xl2tpd/xl2tpd.conf

[global]
access control = yes

[lac provaider]
lns = 172.16.0.1
redial = yes
redial timeout = 1
require chap = yes
require authentication = no
name = Логин
ppp debug = yes
pppoptfile = /etc/ppp/options.xl2tpd
require pap = no
autodial = yes

8) Запускаю sudo /etc/init.d/xl2tpd start
Вывод ifconfig`a:
eth0      Link encap:Ethernet  HWaddr 00:25:22:8f:02:65 
          inet addr:10.20.232.27  Bcast:10.20.232.255  Mask:255.255.255.0
          inet6 addr: fe80::225:22ff:fe8f:265/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:14 errors:0 dropped:0 overruns:0 frame:0
          TX packets:34 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1900 (1.9 KB)  TX bytes:5440 (5.4 KB)
          Interrupt:26 Base address:0x2000

lo        Link encap:Локальная петля (Loopback) 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:16 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:984 (984.0 B)  TX bytes:984 (984.0 B)

*ppp0 не появляется...
Подскажите пожалуйста что я делаю не так?

Оффлайн kraleksandr

  • Участник
  • *
  • Сообщений: 106
    • Просмотр профиля
Re: Настройка l2tp соединения в ubuntu
« Ответ #1 : 04 Сентябрь 2011, 14:50:53 »
Плюсодин к проблеме с л2тп.

Оффлайн satch

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1561
  • Kubuntu 15.10 amd64
    • Просмотр профиля
Re: Настройка l2tp соединения в ubuntu
« Ответ #2 : 04 Сентябрь 2011, 18:05:09 »
логи смотрите
Наше желание помочь прямопропорционально вашему желанию решить проблему

Оффлайн mozart82

  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Re: Настройка l2tp соединения в ubuntu
« Ответ #3 : 05 Сентябрь 2011, 08:59:12 »
попробуйте запустить xl2tpd с ключом -D

Оффлайн Tolik_

  • Активист
  • *
  • Сообщений: 334
    • Просмотр профиля
Re: Настройка l2tp соединения в ubuntu
« Ответ #4 : 05 Сентябрь 2011, 11:29:53 »
dsw2 а чем тебе не нравится http://code.google.com/p/vpnpptp/
или "прикипел" к консоли?  ;D
Вроде-бы все доступно и понятно, и работает очень даже не дурно. Год уже как пользуюсь, проблем не наблюдаю.
 

 

Страница сгенерирована за 0.068 секунд. Запросов: 25.