Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Установка PHP 5.3 на Ubuntu 8.04 LTS  (Прочитано 1611 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн WestWest

  • Автор темы
  • Новичок
  • *
  • Сообщений: 15
    • Просмотр профиля
Установка PHP 5.3 на Ubuntu 8.04 LTS
« : 17 Сентябрь 2011, 17:51:23 »
Проблема в том, что нельзя обновить Ubuntu.

Как правильно установить на нее PHP 5.3 и иметь возможность обновлять его?
Не тупо же компилировать и прописывать.

Оффлайн vadim-nsk

  • LoCo команда
  • Старожил
  • *
  • Сообщений: 1318
  • Жить надо так, как горит пламя!
    • Просмотр профиля
    • Linux в Новосибирске
Re: Установка PHP 5.3 на Ubuntu 8.04 LTS
« Ответ #1 : 18 Сентябрь 2011, 20:54:31 »
так пробовали?
в /etc/apt/sources.list добавить:
deb http://php53.dotdeb.org stable all
deb-src http://php53.dotdeb.org stable all
затем
apt-get update && apt-get upgrade

Пользователь решил продолжить мысль 18 Сентябрь 2011, 20:57:19:
PS
gpg --keyserver keys.gnupg.net --recv-key 89DF5277
gpg -a --export 89DF5277 | sudo apt-key add -

чтоб на отсутствие ключа не ругался
« Последнее редактирование: 18 Сентябрь 2011, 20:57:19 от vadim-nsk »

Оффлайн WestWest

  • Автор темы
  • Новичок
  • *
  • Сообщений: 15
    • Просмотр профиля
Re: Установка PHP 5.3 на Ubuntu 8.04 LTS
« Ответ #2 : 19 Сентябрь 2011, 00:56:10 »
Спасибо, а какой командой список пакетов с репа можно узнать?
Такое чувство, что он пустой

Оффлайн vadim-nsk

  • LoCo команда
  • Старожил
  • *
  • Сообщений: 1318
  • Жить надо так, как горит пламя!
    • Просмотр профиля
    • Linux в Новосибирске
Re: Установка PHP 5.3 на Ubuntu 8.04 LTS
« Ответ #3 : 19 Сентябрь 2011, 17:37:10 »
да stable сейчас пусто замените на oldstable

Оффлайн akimchik

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Re: Установка PHP 5.3 на Ubuntu 8.04 LTS
« Ответ #4 : 20 Апрель 2012, 11:22:27 »
Да, сейчас уже используестся stable, но при обновлении получил следующие неудовлетворительные зависимости...sudo apt-get upgrade
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Reading state information... Готово                       
Пакеты, которые будут оставлены в неизменном виде:
  libapache2-mod-php5 mysql-client mysql-server php-pear php5 php5-cli php5-common php5-gd php5-mcrypt php5-mysql
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 10 пакетов не обновлено.

Когда попытался выполнит apt-get dist-upgrade получил следующее:
sudo apt-get dist-upgrade
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Reading state information... Готово                       
Расчёт обновлений... Готово
Пакеты, которые будут УДАЛЕНЫ:
  libapache2-mod-php5 php-auth php-db php-mail-mime php-net-smtp php-net-socket php-pear php5 php5-cli php5-gd php5-mcrypt php5-mysql phpmyadmin roundcube roundcube-core
  roundcube-mysql roundcube-webmail
НОВЫЕ пакеты, которые будут установлены:
  libonig2 libqdbm14
Пакеты, которые будут оставлены в неизменном виде:
  mysql-client mysql-server
Пакеты, которые будут обновлены:
  php5-common
обновлено 1, установлено 2 новых пакетов, для удаления отмечено 17 пакетов, и 2 пакетов не обновлено.
Необходимо скачать 0B/538kB архивов.
After this operation, 32,2MB disk space will be freed.
Хотите продолжить [Д/н]?

Попробовал установить просто:
sudo apt-get install --fix-missing php5 libapache2-mod-php5
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Reading state information... Готово                       
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
  libapache2-mod-php5: Зависит: libc6 (>= 2.11) но 2.7-10ubuntu8.1 будет установлен
                       Зависит: libdb4.8 но он не может быть установлен
                       Зависит: libgssapi-krb5-2 (>= 1.6.dfsg.2) но он не может быть установлен
                       Зависит: libk5crypto3 (>= 1.6.dfsg.2) но он не может быть установлен
                       Зависит: libkrb5-3 (>= 1.6.dfsg.2) но он не может быть установлен
                       Зависит: libssl0.9.8 (>= 0.9.8m-1) но 0.9.8g-4ubuntu3.17 будет установлен
                       Зависит: libxml2 (>= 2.7.4) но 2.6.31.dfsg-2ubuntu1.8 будет установлен
E: Сломанные пакеты

Подскажите, куда копать? :-\
для уточнения приведу:
uname -a
Linux daemon 2.6.24-31-server #1 SMP Wed Mar 7 00:15:03 UTC 2012 x86_64 GNU/Linux

dpkg -l |grep php5
ii  libapache2-mod-php5                    5.2.4-2ubuntu5.23                server-side, HTML-embedded scripting languag
ii  php5                                   5.2.4-2ubuntu5.23                server-side, HTML-embedded scripting languag
ii  php5-cli                               5.2.4-2ubuntu5.23                command-line interpreter for the php5 script
ii  php5-common                            5.2.4-2ubuntu5.23                Common files for packages built from the php
ii  php5-gd                                5.2.4-2ubuntu5.23                GD module for php5
ii  php5-mcrypt                            5.2.3-0ubuntu1                   MCrypt module for php5
ii  php5-mysql                             5.2.4-2ubuntu5.23                MySQL module for php5

и на конец:
grep -v -e ^$ -e '^[[:space:]]*#' /etc/apt/sources.list
deb http://ua.archive.ubuntu.com/ubuntu/ hardy main restricted
deb-src http://ua.archive.ubuntu.com/ubuntu/ hardy main restricted
deb http://ua.archive.ubuntu.com/ubuntu/ hardy-updates main restricted
deb-src http://ua.archive.ubuntu.com/ubuntu/ hardy-updates main restricted
deb http://ua.archive.ubuntu.com/ubuntu/ hardy universe
deb-src http://ua.archive.ubuntu.com/ubuntu/ hardy universe
deb http://ua.archive.ubuntu.com/ubuntu/ hardy-updates universe
deb-src http://ua.archive.ubuntu.com/ubuntu/ hardy-updates universe
deb http://ua.archive.ubuntu.com/ubuntu/ hardy multiverse
deb-src http://ua.archive.ubuntu.com/ubuntu/ hardy multiverse
deb http://ua.archive.ubuntu.com/ubuntu/ hardy-updates multiverse
deb-src http://ua.archive.ubuntu.com/ubuntu/ hardy-updates multiverse
deb http://security.ubuntu.com/ubuntu hardy-security main restricted
deb-src http://security.ubuntu.com/ubuntu hardy-security main restricted
deb http://security.ubuntu.com/ubuntu hardy-security universe
deb-src http://security.ubuntu.com/ubuntu hardy-security universe
deb http://security.ubuntu.com/ubuntu hardy-security multiverse
deb-src http://security.ubuntu.com/ubuntu hardy-security multiverse
deb http://ppa.launchpad.net/ubuntu-clamav/ppa/ubuntu hardy main
deb http://php53.dotdeb.org stable all
deb-src http://php53.dotdeb.org stable all
« Последнее редактирование: 20 Апрель 2012, 11:31:26 от akimchik »

 

Страница сгенерирована за 0.055 секунд. Запросов: 24.