Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Не могу установить Samba 3.6.0  (Прочитано 1868 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ltd1

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Не могу установить Samba 3.6.0
« : 17 Сентябрь 2011, 23:03:01 »
Есть сервер, стоит Linux Ubuntu 11.04 32bit. Если устанавливать самбу из репозиториев, то ставится только 3.5.8 и далее не обновляется. Скачал архив последней версии 3.6.0 с сайта samba.org и уже всяко разно пытался установить, например по этой инструкции - http://smb-conf.ru/2-ustanovka-samba.html. В ходе всех операций никаких ошибок нет, но после прописывания команд /usr/local/samba/sbin/smbd -D и /usr/local/samba/sbin/nmbd -D ничего не происходит. Конкретно команда smbd --version пишет, что для установки самбы наберите apt-get install samba.

Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13750
    • Просмотр профиля
Re: Не могу установить Samba 3.6.0
« Ответ #1 : 17 Сентябрь 2011, 23:06:57 »
А /usr/local/samba/sbin/smbd --version что-нибудь говорит?

Пользователь решил продолжить мысль 17 Сентябрь 2011, 23:08:01:
А почему выбор пал именно на 3.6? В репах Natty вроде 4-ая самба даже уже есть
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

Оффлайн ltd1

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Re: Не могу установить Samba 3.6.0
« Ответ #2 : 17 Сентябрь 2011, 23:16:30 »
Потому что последняя стабильная считается 3.6.0. А почему не устраивает 3.5.8 - из под Win7 не могу зайти в папки, которые в конфиге smb.conf отданы конкретному пользователю. Уже все инструкции интернета перебрал, даже настривал через system-config-samba, всё-равно Win7 говорит, что неверный пароль.
Команду /usr/local/samba/sbin/smbd --version попробую только завтра, но после всех этих действий, пытался зайди хотя-бы в общедоступную папку, которая работала на 3.5.8 - сервер был вообще не доступен, так что я думаю, что эта команда тоже ничего не скажет.

Пользователь решил продолжить мысль 17 Сентябрь 2011, 23:32:38:
Нашёл deb пакеты, может помогут http://ftp.psn.ru/debian/pool/main/s/samba/
« Последнее редактирование: 17 Сентябрь 2011, 23:32:38 от ltd1 »

Оффлайн progmo

  • Участник
  • *
  • Сообщений: 105
    • Просмотр профиля
Re: Не могу установить Samba 3.6.0
« Ответ #3 : 18 Сентябрь 2011, 00:25:03 »
У меня 3.5.4 исправно трудится в 10.10
Мне кажется тебе надо копать в сторону настроек. снеси самбу под корень, поставь с нуля из репов, настрой визуально через Система - Администрирование - Samba. Проблем быть не должно.
Ubuntu 14.04.2

Оффлайн ltd1

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Re: Не могу установить Samba 3.6.0
« Ответ #4 : 18 Сентябрь 2011, 15:23:07 »
/usr/local/samba/sbin/smbd --version    говорит что версия самбы 3.6.0
Но я сейчас на сервер вообще никак зайти не могу из под Win7. Т.е. самба получается не работает и команды /usr/local/samba/sbin/smbd -D и /usr/local/samba/sbin/nmbd -D  не помогают.
progmo, выложи свой smb.conf

Пользователь решил продолжить мысль 18 Сентябрь 2011, 15:49:45:
Вот мой конф
(Нажмите, чтобы показать/скрыть)
« Последнее редактирование: 18 Сентябрь 2011, 15:51:04 от ltd1 »

Оффлайн progmo

  • Участник
  • *
  • Сообщений: 105
    • Просмотр профиля
Re: Не могу установить Samba 3.6.0
« Ответ #5 : 19 Сентябрь 2011, 19:32:24 »
вот мой
(Нажмите, чтобы показать/скрыть)
Ubuntu 14.04.2

Оффлайн YaAllex

  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Не могу установить Samba 3.6.0
« Ответ #6 : 15 Октябрь 2011, 19:29:31 »
Как успехи у автора темы? Просто ситуация похожая ) Самба 3.5.4 и виндовсы 7  :-\ Тоже пароли не очень любят  :-\

progmo, сюдя по конфигу твоей самбы ты для хп-винды делал шару))) с семеркой не пробовал?

« Последнее редактирование: 15 Октябрь 2011, 19:33:42 от YaAllex »

Гарри Кашпировский

  • Гость
Re: Не могу установить Samba 3.6.0
« Ответ #7 : 15 Октябрь 2011, 22:21:18 »
Не знаю как у автора, а 3.6.0  работает на Lucid Lynx i386, правда почему то не собирается для amd64 :(

 

Страница сгенерирована за 0.092 секунд. Запросов: 25.