Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: И сново OpenVPN (Intrenet не доступен)  (Прочитано 1133 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн screeble

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
  • Here we go!
    • Просмотр профиля
И сново OpenVPN (Intrenet не доступен)
« : 05 Октябрь 2011, 15:01:33 »
Доброго времени суток,

Прочел несколько похожих тем на Вашем форуме но никак не могу их адаптировать под свою ситуацию.
Вообщем проблема такая. Есть сервер который расположен в другой стране (UBUNTU) и на нем поднят OpenVPN. Есть клиент (UBUNTU) который к нему успешно конектится в результате чего созадется туннель, но на клиенте нет выхода в Internet.

Необходимая информация:

Серверная часть:

server.conf

(Нажмите, чтобы показать/скрыть)

ifconfig -a

(Нажмите, чтобы показать/скрыть)

route -n

(Нажмите, чтобы показать/скрыть)

cat /proc/sys/net/ipv4/ip_forward
(Нажмите, чтобы показать/скрыть)

iptables-save

(Нажмите, чтобы показать/скрыть)


Клиентская часть:

client.conf

(Нажмите, чтобы показать/скрыть)

openvpn --config client.conf

(Нажмите, чтобы показать/скрыть)

ifconfig -a

(Нажмите, чтобы показать/скрыть)

ping -c4 10.8.0.1

(Нажмите, чтобы показать/скрыть)

ping -c4 8.8.8.8

(Нажмите, чтобы показать/скрыть)

Где я налажал, подскажите пожалуйста??? :-\

Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13750
    • Просмотр профиля
Re: И сново OpenVPN (Intrenet не доступен)
« Ответ #1 : 05 Октябрь 2011, 15:15:39 »
Если посмотреть на route -n на клиенте, то увилите, что default-маршрут не туда смотрит.
Добавьте опцию pull в клиентский конфиг. И после рестарта сервиса показывайте route
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

Оффлайн screeble

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
  • Here we go!
    • Просмотр профиля
Re: И сново OpenVPN (Intrenet не доступен)
« Ответ #2 : 05 Октябрь 2011, 15:27:07 »
Вот результат (route -n):

(Нажмите, чтобы показать/скрыть)

Спасибо

Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13750
    • Просмотр профиля
Re: И сново OpenVPN (Intrenet не доступен)
« Ответ #3 : 05 Октябрь 2011, 16:01:33 »
Не совсем понятно - всё стало ОК?
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

Оффлайн screeble

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
  • Here we go!
    • Просмотр профиля
Re: И сново OpenVPN (Intrenet не доступен)
« Ответ #4 : 05 Октябрь 2011, 16:13:28 »
К сожалению нет :(

Может проблема в IpTables?

Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13750
    • Просмотр профиля
Re: И сново OpenVPN (Intrenet не доступен)
« Ответ #5 : 05 Октябрь 2011, 16:34:58 »
Нет. Там никаких запретов и с маскарадом всё нормально
Попробуйте на клиенте
sudo route delete 0.0.0.0 netmask 0.0.0.0 gw 10.0.2.2 dev eth0
ping -c4 8.8.8.8
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

Оффлайн screeble

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
  • Here we go!
    • Просмотр профиля
Re: И сново OpenVPN (Intrenet не доступен)
« Ответ #6 : 05 Октябрь 2011, 17:05:06 »
Когда удалил:

sudo route del -net 0.0.0.0 netmask 0.0.0.0 gw 10.0.2.2 dev eth0

route -n
(Нажмите, чтобы показать/скрыть)

Результат:
/etc/openvpn# ping -c4 8.8.8.8
connect: Network is unreachable

root@ubuntu:/etc/openvpn# openvpn --config client.conf
Wed Oct  5 16:55:29 2011 OpenVPN 2.1.0 i686-pc-linux-gnu [SSL] [LZO2] [EPOLL] [PKCS11] [MH] [PF_INET6] [eurephia] built on Jul 12 2010
Enter Auth Username:moscow
Enter Auth Password:
Wed Oct  5 16:55:38 2011 WARNING: No server certificate verification method has been enabled.  See http://openvpn.net/howto.html#mitm for more info.
Wed Oct  5 16:55:38 2011 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
Wed Oct  5 16:55:38 2011 RESOLVE: Cannot resolve host address: develop.no-ip.org: [HOST_NOT_FOUND] The specified host is unknown.
Wed Oct  5 16:55:38 2011 RESOLVE: Cannot resolve host address: develop.no-ip.org: [HOST_NOT_FOUND] The specified host is unknown.
Wed Oct  5 16:55:43 2011 RESOLVE: Cannot resolve host address: develop.no-ip.org: [HOST_NOT_FOUND] The specified host is unknown.
Wed Oct  5 16:55:48 2011 RESOLVE: Cannot resolve host address: develop.no-ip.org: [HOST_NOT_FOUND] The specified host is unknown.

Нашел такое правило на форуме: iptables -t nat -A POSTROUTING -s 10.8.0.0/8 -o ИСХ_ИНТЕРФЕЙС -j SNAT --to-source ТВОЙ_БЕЛЫЙ_IP

Может мне следует добавить его?

Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13750
    • Просмотр профиля
Re: И сново OpenVPN (Intrenet не доступен)
« Ответ #7 : 05 Октябрь 2011, 21:36:34 »
А всё... увидел грабельки.
У Вас на сервере используется eth1, а в iptables маскарадите eth0.
pull оставляем и меняем правило
Цитировать
sudo iptables -t nat -A POSTROUTING -s 10.8.0.0/24 -o eth0 -j MASQUERADE

Если у Вас статический адрес, то можете
sudo iptables -t nat -A POSTROUTING -s 10.8.0.0/8 -o eth1 -j SNAT --to-source ваш_статический_ип
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

Оффлайн screeble

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
  • Here we go!
    • Просмотр профиля
Re: И сново OpenVPN (Intrenet не доступен)
« Ответ #8 : 06 Октябрь 2011, 12:03:40 »
Спасибо, fisher74,

интеренета на клиенте пока еще нет  но надежды остаются:)
Вообщем теперь таблица выглядит так:

(Нажмите, чтобы показать/скрыть)


178.74.248.230 это мой статический IP.

На всякий случай (route -n клиента)
(Нажмите, чтобы показать/скрыть)


Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13750
    • Просмотр профиля
Re: И сново OpenVPN (Intrenet не доступен)
« Ответ #9 : 06 Октябрь 2011, 12:11:51 »
ifconfig -a ещё с сервера посмотреть бы
« Последнее редактирование: 06 Октябрь 2011, 13:03:45 от fisher74 »
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

Оффлайн screeble

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
  • Here we go!
    • Просмотр профиля
Re: И сново OpenVPN (Intrenet не доступен)
« Ответ #10 : 06 Октябрь 2011, 13:00:14 »
Да конечно я вроде выложил его в своем первом посте:


(Нажмите, чтобы показать/скрыть)

Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13750
    • Просмотр профиля
Re: И сново OpenVPN (Intrenet не доступен)
« Ответ #11 : 06 Октябрь 2011, 13:05:49 »
Да, извините.. "гол в мои ворота"

Для Вашего сервера (по его мнению) внешним адресом является 192.168.1.10 (видимо в DMZ)
потому правило должно звучать так
sudo iptables -t nat -A POSTROUTING -s 10.0.0.0/8 -o eth1 -j SNAT --to-source 192.168.1.10
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

Оффлайн screeble

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
  • Here we go!
    • Просмотр профиля
Re: И сново OpenVPN (Intrenet не доступен)
« Ответ #12 : 06 Октябрь 2011, 13:38:58 »
Спасибо,

Изменил как посоветовали, к сожалению результат тот же.

(Нажмите, чтобы показать/скрыть)

Но заметил странную вещь

Когда с клиента пингую внутренний IP сервера то все проходит:

ping -c4 192.168.1.10
(Нажмите, чтобы показать/скрыть)

Но вот когда хочу пройти дальше например IP адрес роутера 192.168.1.1:

 ping -c4 192.168.1.1
(Нажмите, чтобы показать/скрыть)

следовательно можно сделать вывод что пакеты не проходят дальше сервера, хотя фаерволов на сервере нет.

Есть идеи? :-[

Пользователь решил продолжить мысль 06 Октябрь 2011, 14:58:42:
добавил следующую строку и теперь сайты пингуются но только по IP адресу а по доменему имени почему то нет:

[b]-A FORWARD -m state --state RELATED,ESTABLISHED -j ACCEPT[/b]
уже совсем близко...

(Нажмите, чтобы показать/скрыть)



Пользователь решил продолжить мысль 06 Октябрь 2011, 15:32:07:
может проблема здесь:

/etc/resolv.conf

# Generated by NetworkManager
nameserver 212.188.4.10
nameserver 195.34.32.116
nameserver 192.168.0.1

 ???

Пользователь решил продолжить мысль 06 Октябрь 2011, 15:37:18:
Да именно, мы сделали это!!!!

Спасибо!!!!!!!!!!!!!!!!!!!!!!

на клиенте применил тот же файл что и на сервере и все!!!

-------------
# Generated by NetworkManager
nameserver 192.168.1.1
-------------

fisher74 Вам отдельное спасибо!!!
« Последнее редактирование: 06 Октябрь 2011, 15:37:18 от screeble »

 

Страница сгенерирована за 0.081 секунд. Запросов: 25.