Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: apache под ubuntu  (Прочитано 2829 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн odu_1

  • Автор темы
  • Новичок
  • *
  • Сообщений: 2
  • rastoman 100%
    • Просмотр профиля
apache под ubuntu
« : 03 Декабрь 2007, 22:29:56 »
Люди те кто сталкивался  с Apache  под  линухом !!! Есть  ли готовые  сервера на Linux а конкретно на   Ubuntu  как под виндой , ну типо как Top server  или Denver ??? Если нет таковых  поподробней объясните тому кому не в тягость как тогда поставить апача прикрутить к нему  моську и phpmyadmina   воот.......

Оффлайн stranger1231

  • Любитель
  • *
  • Сообщений: 87
    • Просмотр профиля
Re: apache под ubuntu
« Ответ #1 : 03 Декабрь 2007, 23:46:10 »
Да вроде было - lamp.
пишешь tasksel в консольке, а дальше все просто )

Оффлайн BoroDaemon

  • Новичок
  • *
  • Сообщений: 43
  • Be linux 8) [Админ]
    • Просмотр профиля
Re: apache под ubuntu
« Ответ #2 : 04 Декабрь 2007, 11:44:41 »
apt-get install libapache2-mod-php5 php5 php5-common php5-curl php5-dev php5-gd php5-idn php-pear php5-imagick php5-imap php5-json php5-mcrypt php5-memcache php5-mhash php5-ming php5-mysql php5-ps php5-pspell php5-recode php5-snmp php5-sqlite php5-tidy php5-xmlrpc php5-xsl
apt-get install apache2 apache2-doc apache2-mpm-prefork apache2-utils libexpat1 ssl-cert
А для простейшей настройки скачай webmin.
http://prdownloads.sourceforge.net/webadmin/webmin_1.380_all.deb

Оффлайн saber

  • Участник
  • *
  • Сообщений: 224
    • Просмотр профиля
    • Блог админа
Re: apache под ubuntu
« Ответ #3 : 14 Январь 2008, 19:00:17 »
По дефолту ставится апач 2.2.4 а я хочу 2.0.XX
как быть?
odmin4eg.ru - Мои шпаргалки по ubuntu

Оффлайн Kwah

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1442
  • Ubuntu 17.10
    • Просмотр профиля
Re: apache под ubuntu
« Ответ #4 : 14 Январь 2008, 22:21:43 »
По дефолту ставится апач 2.2.4 а я хочу 2.0.XX
как быть?
Поставить Ubuntu в которой использовался апач 2.0.ХыХы

burgua

  • Гость
Re: apache под ubuntu
« Ответ #5 : 14 Январь 2008, 23:10:23 »
А чем это "хочу" аргументируется?

Оффлайн saber

  • Участник
  • *
  • Сообщений: 224
    • Просмотр профиля
    • Блог админа
Re: apache под ubuntu
« Ответ #6 : 15 Январь 2008, 16:19:08 »
Это так сильно надо знать почему? я задал вопрос хочу найти ответ %)
ну хотябы хочу модуль для webdav именно тот который работает с линейкой 2.0. потому что в 2.2 оно работает подругому!
odmin4eg.ru - Мои шпаргалки по ubuntu

burgua

  • Гость
Re: apache под ubuntu
« Ответ #7 : 15 Январь 2008, 22:34:15 »
Нарыл в manpage по apt-get
самому тестить не охота (сносить-ставить ужасно обломно)
но вроде это позволяет поставить нужную версию ПО.

       -t, --target-release, --default-release
           This option controls the default input to the policy engine, it creates a
           default pin at priority 990 using the specified release string. The preferences
           file may further override this setting. In short, this option lets you have
           simple control over which distribution packages will be retrieved from. Some
           common examples might be -t ’2.1*’ or -t unstable. Configuration Item:
           APT::Default-Release; see also the apt_preferences(5) manual page

p.s. Сначала удали более новую версию.

p.p.s Даже если я сморозил фигню,  то найдется пяток знатоков,
которые ткнут носом в ошибку. Уж они точно разгребут что и как )

Оффлайн BoroDaemon

  • Новичок
  • *
  • Сообщений: 43
  • Be linux 8) [Админ]
    • Просмотр профиля
Re: apache под ubuntu
« Ответ #8 : 16 Январь 2008, 13:34:34 »

Оффлайн saber

  • Участник
  • *
  • Сообщений: 224
    • Просмотр профиля
    • Блог админа
Re: apache под ubuntu
« Ответ #9 : 16 Январь 2008, 16:11:26 »
конечно после генты немного не удобно ставить нужную версию.
После ручной сорки что произойдёт при дистр апдейт или просто плановых апдейтов системы?
odmin4eg.ru - Мои шпаргалки по ubuntu

burgua

  • Гость
Re: apache под ubuntu
« Ответ #10 : 16 Январь 2008, 16:53:38 »
обновление  конечно же )

Оффлайн saber

  • Участник
  • *
  • Сообщений: 224
    • Просмотр профиля
    • Блог админа
Re: apache под ubuntu
« Ответ #11 : 16 Январь 2008, 17:43:50 »
тогда очень плохо
odmin4eg.ru - Мои шпаргалки по ubuntu

Оффлайн doff

  • Новичок
  • *
  • Сообщений: 23
    • Просмотр профиля
Re: apache под ubuntu
« Ответ #12 : 16 Январь 2008, 17:59:28 »
apt-get install libapache2-mod-php5 php5 php5-common php5-curl php5-dev php5-gd php5-idn php-pear php5-imagick php5-imap php5-json php5-mcrypt php5-memcache php5-mhash php5-ming php5-mysql php5-ps php5-pspell php5-recode php5-snmp php5-sqlite php5-tidy php5-xmlrpc php5-xsl
apt-get install apache2 apache2-doc apache2-mpm-prefork apache2-utils libexpat1 ssl-cert
А для простейшей настройки скачай webmin.
http://prdownloads.sourceforge.net/webadmin/webmin_1.380_all.deb


doff@voldemar:/var/www$ sudo apt-get install libapache2-mod-php5 php5 php5-common php5-curl php5-dev php5-gd php5-idn php-pear php5-imagick php5-imap php5-json php5-mcrypt php5-memcache php5-mhash php5-ming php5-mysql php5-ps php5-pspell php5-recode php5-snmp php5-sqlite php5-tidy php5-xmlrpc php5-xsl
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Reading state information... Готово                       
Пакет php5-json - виртуальный, его функции предоставляются пакетами:
  php5-common 5.2.3-1ubuntu6.3
Вы должны явно указать, какой именно вы хотите установить.
E: Для пакета php5-json не найдены кандидаты на установку

так что пришлось вычеркнуть php5-json
« Последнее редактирование: 16 Январь 2008, 18:02:00 от doff »

Оффлайн oleg-limon

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Re: apache под ubuntu
« Ответ #13 : 14 Ноябрь 2008, 22:11:39 »
вобщем поставил я webmin, кто может помоч с его использованием, просто не совсем понятно. Если есть люди которые могут помоч то я буду рад задать вам пару вопросов

Оффлайн Lenski

  • Новичок
  • *
  • Сообщений: 27
    • Просмотр профиля

 

Страница сгенерирована за 0.066 секунд. Запросов: 23.