Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Неправильно отображается расскладка клавиатуры в Ubuntu 11.10  (Прочитано 1784 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн dmifedorenko

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Дефолтная расскладка - English (US). Переключение между раскладками - alt+shift.

Открываю два терминала, в одном выбираю английскую раскладку, в другом русскую.
При переключении между окнами терминала индикатор клавиатуры не изменятся.

Например, в первом окне была русская раскладка и русский индикатор, во втором окне английская раскладка. При переключении на второе окно индикатор остаётся русским, а вот текст набирается на английском.

Очень раздражает. Подскажите в какую сторону копать?

Оффлайн Rasskazow

  • Участник
  • *
  • Сообщений: 142
    • Просмотр профиля
Это глюк. У меня тоже бывает.
Попробуй использовать одинаковую раскладку для всех окон. Помогает, но не всегда.

Оффлайн bosyi

  • Активист
  • *
  • Сообщений: 557
    • Просмотр профиля
Это баг. Одно из возможных? решений проблемы:

1. Ставим gxneur
sudo add-apt-repository ppa:andrew-crew-kuznetsov/xneur-unstable
sudo apt-get update
sudo apt-get install gxneur
и добавляем его в автозагрузку.
Если не понравиться автоматический переключатель его можно отключить,а программу использовать в качестве индикатора.

2. отключаем индикатор раскладки.
sudo apt-get install dconf-toolsЗатем,
dconf-editor: org -> gnome -> settings-daemon -> plugins -> keyboard: active - false
если понадобиться что-то поднастроить(добавить язык, настроить комбинации клавиш) его можно будет включить обратно, а затем опять выключить.

Оффлайн dmifedorenko

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Одинаковая раскладка для всех окон помогает, но это не то что мне нужно.

gxneur корректно отображает раскладку, так что можно считать его решением проблемы.

Цитировать
dconf-editor: org -> gnome -> settings-daemon -> plugins -> keyboard: active - false
если понадобиться что-то поднастроить(добавить язык, настроить комбинации клавиш) его можно будет включить обратно, а затем опять выключить.
У меня после отключения plugins/keyboard не работает переключение раскладки. Всегда английский.

Стандартный индикатор пришлось оставить, заменил его иконки на 1x1.png.

Всем спасибо за ответы!  8)

Оффлайн Пeтрович

  • Активист
  • *
  • Сообщений: 585
    • Просмотр профиля

 

Страница сгенерирована за 0.091 секунд. Запросов: 25.