Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Не поднимается eth0 в Ubuntu server 11.10  (Прочитано 2469 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Int_20h

  • Автор темы
  • Участник
  • *
  • Сообщений: 137
    • Просмотр профиля
Не поднимается eth0 в Ubuntu server 11.10
« : 31 Октябрь 2011, 22:49:16 »
Ребята, спасите меня. Бьюсь головой об стенку и не понимаю что происходит!!!!
Есть Ubuntu server amd64 11.10, который был поставлен с нуля (не обновлением). В компе 3 сетевых карты, поскольку он смотрит в 3 сетки и должен отвечать другим серверам. Никакой сложной маршрутизации на нем не предполагается.

До сегодняшнего дня все работало превосходно (система грузилась секунд за 10), пока я не попробовал прописать еще один статический маршрут в /etc/network/interfaces. С маршрутом немножко накосячил и система стала при загрузке выдавать надписи:

Waiting for network configuration...
Waiting up to 60 more seconds for network configuration...
Booting system without full network configuration...

Долго мучался, читал форумы где описана подобная ошибка из-за dbus, все делал по инструкции - ничего не помогает. С чего вдруг он начал искать эту сетувую конфигурацию - вообще не понятно.

Ладно, думаю, уберу косячный маршрут. Привел конфиг к первоначальному виду, а ошибка никуда не делась. Более того, eth0 перестал автоматически подниматься (из-за чего не запускается ssh, который смотрит в этот интерфейс), и маршруты в eth1 и eth2 теперь не прописываются. Я загружаюсь - eth0 в down'е. Через ifconfig вручную его поднимаю, прописываю шлюз по умолчанию, прописываю необходимые маршруты и все работает. Но это же не дело каждый раз так изголяться...

Куда копать? Понятия не имею.

/etc/network/interfaces прилагаю.

(Нажмите, чтобы показать/скрыть)

Пользователь решил продолжить мысль 31 Октябрь 2011, 23:18:27:
На всякий случай добавлю логи syslog. Вот как было утром:

(Нажмите, чтобы показать/скрыть)

А вот то что есть теперь:

(Нажмите, чтобы показать/скрыть)

Больше 5 минут (иногда до 10) на подъем интерфейса... Это с чего его так переколбасило?
« Последнее редактирование: 31 Октябрь 2011, 23:18:27 от Int_20h »

Оффлайн xeon_greg

  • Активист
  • *
  • Сообщений: 981
    • Просмотр профиля
Re: Не поднимается eth0 в Ubuntu server 11.10
« Ответ #1 : 01 Ноябрь 2011, 00:32:17 »
Цитировать
auto eth0
iface eth0 inet static
address 10.78.12.49
netmask 255.225.225.0
gateway 10.78.12.12
маску случайно не попутал ?

Оффлайн Int_20h

  • Автор темы
  • Участник
  • *
  • Сообщений: 137
    • Просмотр профиля
Re: Не поднимается eth0 в Ubuntu server 11.10
« Ответ #2 : 01 Ноябрь 2011, 09:18:37 »
Нет. Сетка гигантская, разделенная на сегменты. В этом здании всего 200 компов и Cisco, который маршрутизирует все остальные пакеты, которые не укладываются в 10.78.12.*.

Оффлайн xeon_greg

  • Активист
  • *
  • Сообщений: 981
    • Просмотр профиля
Re: Не поднимается eth0 в Ubuntu server 11.10
« Ответ #3 : 01 Ноябрь 2011, 11:22:58 »
Цитировать
255.225.225.0
не знаю откуда ты такую маску взял, но она не является действительной

Пользователь решил продолжить мысль 01 Ноябрь 2011, 11:25:38:
Нет. Сетка гигантская, разделенная на сегменты. В этом здании всего 200 компов и Cisco, который маршрутизирует все остальные пакеты, которые не укладываются в 10.78.12.*.
вероятно она должна быть 255.255.255.0
« Последнее редактирование: 01 Ноябрь 2011, 11:25:38 от xeon_greg »

Оффлайн glory_man

  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Re: Не поднимается eth0 в Ubuntu server 11.10
« Ответ #4 : 01 Ноябрь 2011, 11:29:19 »
может быть дело в драйвере сетевой карты ?
давече у меня похожая проблема была - обновил систему - слетел драйвер для rtl8168. после перезапуска eth0 пропал. переустановил драйвер для сетевухи - всё вернулось на место.

Оффлайн xeon_greg

  • Активист
  • *
  • Сообщений: 981
    • Просмотр профиля
Re: Не поднимается eth0 в Ubuntu server 11.10
« Ответ #5 : 01 Ноябрь 2011, 11:32:57 »
да пусть разберется с сетями, и адресацией тк косяк именно там, нет такой маски

Оффлайн Int_20h

  • Автор темы
  • Участник
  • *
  • Сообщений: 137
    • Просмотр профиля
Re: Не поднимается eth0 в Ubuntu server 11.10
« Ответ #6 : 01 Ноябрь 2011, 22:27:25 »
Блин, точно!

Я даже не заметил, как по запарке поменял местами 2 и 5. Конечно маска должна быть 255.255.255.0.

xeon_greg, спасибо тебе огромное. Все пришло в норму.

 

Страница сгенерирована за 0.08 секунд. Запросов: 25.