Форум русскоязычного сообщества Ubuntu


За новостями русскоязычного сообщества и Ubuntu в целом можно следить на нашей страничке в Google+

Автор Тема: Сборка правильного пакета для 10.04  (Прочитано 794 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн systempapa

  • Автор темы
  • Участник
  • *
  • Сообщений: 120
    • Просмотр профиля
Сборка правильного пакета для 10.04
« : 17 Ноябрь 2011, 13:17:06 »
Привет! прочитал кучу мануалов, кучу haw to и то вопросы есть. непонимаю, везде по разному пишут способы, везде свои "правила и алгоритмы" . Прошу помощи. Имеется программа (исходники) состоит из 3х архивов: name.tar; name_0.1-1.diff; name_0.1.orig.tar.  надо собрать пакет для нее, чтоб без проблем вставала на 10.04 Ubuntu. Хочу сразу научится по правильному, чтоб и обновлялась и удалялась корректно, подскажите люди милые и не очень :) с ЧЕГО начать? читаю инструкции, там примеры с одним файлом, да и там многое не догоняю :( хотя не дурак.
(Нажмите, чтобы показать/скрыть)

Оффлайн systempapa

  • Автор темы
  • Участник
  • *
  • Сообщений: 120
    • Просмотр профиля
Re: Сборка правильного пакета для 10.04
« Ответ #1 : 18 Ноябрь 2011, 15:45:12 »
разобрался, щас такая ерунда:

test@pc:~/test/name-prog-1.0$ make -j4
cd src/ && make -f Makefile
make[1]: Вход в каталог `/home/name/test/name-prog-1.0/src'
g++ -c -pipe -O2 -Wall -W -D_REENTRANT -DQT_WEBKIT -DQT_NO_DEBUG -DQT_SQL_LIB -DQT_XML_LIB -DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++ -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtXml -I/usr/include/qt4/QtSql -I/usr/include/qt4 -Iwidgets -Ibuild -Ibuild -o build/dblineedit.o widgets/dblineedit.cpp
make[1]: g++: Команда не найдена
make[1]: *** [build/dblineedit.o] Ошибка 127
make[1]: Выход из каталога `/home/test/test/name-prog-1.0/src'
make: *** [sub-src-make_default] Ошибка 2

чего не хватает доустановить?

Оффлайн БТР

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 5108
    • Просмотр профиля
Re: Сборка правильного пакета для 10.04
« Ответ #2 : 18 Ноябрь 2011, 15:46:54 »
sudo apt-get install build-essential

Оффлайн SergeyIT

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 4288
  • Все по палатам!
    • Просмотр профиля
Re: Сборка правильного пакета для 10.04
« Ответ #3 : 18 Ноябрь 2011, 15:47:38 »
make[1]: g++: Команда не найдена
Извините, я все еще учусь

Оффлайн systempapa

  • Автор темы
  • Участник
  • *
  • Сообщений: 120
    • Просмотр профиля
Re: Сборка правильного пакета для 10.04
« Ответ #4 : 19 Ноябрь 2011, 08:40:51 »
sudo apt-get install build-essential
Благодарю.... по g++ поиск выдал много разностей, я не смог найти нужную :(


ура. вроде как собрал первый пакет из исходников программы :)  :D :D
(Нажмите, чтобы показать/скрыть)
« Последнее редактирование: 19 Ноябрь 2011, 09:06:26 от systempapa »

Оффлайн danulo1245

  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Re: Сборка правильного пакета для 10.04
« Ответ #5 : 13 Октябрь 2012, 14:21:14 »
чтобь создать Деб пакет вводи dpkg-buildpackage -us -uc если ето не для репозитория

 

Страница сгенерирована за 0.057 секунд. Запросов: 25.