Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Не работает https  (Прочитано 1765 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн kwlsoft

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
    • Мир увлечений!
Не работает https
« : 19 Ноябрь 2011, 20:03:56 »
Здравствуйте.

Есть машина с ubuntu server 10.04.1. Подключена в сеть напрямую к провайдеру без vpn, proxy, роутера и т.п., выделен "белый" адрес IPv4. Машина используется как сервер виртуального хостинга для себя, поднят apache, mysql, ftp. Расположенный на сервере php скрипт обращается по https к шлюзу платежной системы, в ответ получает could not connect to host. Для обращения к шлюзу использовал два варианта - curl и сокеты, результат один и тот же. Если в консоли выполнить wget https://paygate.com пишет:
Преобразование адреса paygate.com... 79.142.1919
Устанавливается соединение с paygate.com|79.142.19.19|:443... время ожидания соединения истекло.

Http соединения работают без проблем. В iptables 443 порт открыт. Подскажите, куда смотреть?

Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13746
    • Просмотр профиля
Re: Не работает https
« Ответ #1 : 19 Ноябрь 2011, 23:18:19 »
nmap -p 443 paygate.com -P0дабы проверить работоспособность того самого шлюза

Ну и всё-таки предлагаю показать iptables-save
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

Оффлайн kwlsoft

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
    • Мир увлечений!
Re: Не работает https
« Ответ #2 : 20 Ноябрь 2011, 09:48:56 »
iptables-save:
(Нажмите, чтобы показать/скрыть)
nmap:
(Нажмите, чтобы показать/скрыть)

Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13746
    • Просмотр профиля
Re: Не работает https
« Ответ #3 : 20 Ноябрь 2011, 11:21:38 »
Классическое подтверждение народной приметы данного форума, что OUTPUT -P DROP - это обычно ошибка в правилах.
У Вас не разрешен исходящий траффик на 443 порт внешних ресурсов
Цитировать
-A OUTPUT -s 89.XXX.XXX.XXX/32 -p tcp -m tcp --sport 1024:65535 --dport 443 -j ACCEPT
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

Оффлайн kwlsoft

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
    • Мир увлечений!
Re: Не работает https
« Ответ #4 : 20 Ноябрь 2011, 11:24:21 »
Там написано ACCEPT, а не DROP. При сбросе правил файервола проблема не уходит.

Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13746
    • Просмотр профиля
Re: Не работает https
« Ответ #5 : 20 Ноябрь 2011, 11:50:17 »
*filter
:INPUT DROP [3105:397688]
:FORWARD ACCEPT [0:0]
:OUTPUT DROP [13154:565712]
Там написано ACCEPT, а не DROP.
Вы меня пытаетесь обмануть или себя?

При сбросе правил файервола проблема не уходит.
Тогда показывайте результаты команд со сброшенными правилами
sudo iptaboes-save
sudo nmap -p 443 paygate.com -P0

P.S. Хотя решение проблемы я уже показал
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

Оффлайн kwlsoft

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
    • Мир увлечений!
Re: Не работает https
« Ответ #6 : 20 Ноябрь 2011, 12:21:23 »
Там написано ACCEPT, а не DROP. При сбросе правил файервола проблема не уходит.
Перепроверил, Вы оказались правы. Спасибо большое за подсказку.

Оффлайн eugenydn

  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Не работает https
« Ответ #7 : 17 Март 2014, 17:40:27 »
В оффисе на 5 человек машина раздаёт инет (yota).

iptables:
(Нажмите, чтобы показать/скрыть)
Некоторые сайты работают, некоторые нет.

https://link.alfabank.ru/ - не работает
https://www.cyberplat.ru/ - не работает
https://welcome.planfix.ru/ - работает

chrome говорит connection_reset,
nmap говорит что все ок, порты открыты.

Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13746
    • Просмотр профиля
Re: Не работает https
« Ответ #8 : 17 Март 2014, 18:16:49 »
Может проблема в хроме?
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

Оффлайн eugenydn

  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Не работает https
« Ответ #9 : 17 Март 2014, 20:08:35 »
Нет.

 

Страница сгенерирована за 0.057 секунд. Запросов: 24.