Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Проблемы с интернетом!  (Прочитано 702 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Viper666

  • Автор темы
  • Новичок
  • *
  • Сообщений: 13
    • Просмотр профиля
Проблемы с интернетом!
« : 22 Ноябрь 2011, 15:31:03 »
Здравствуйт! Почитал разные темы по настройки сети ubuntu 10.04, но нечего не нашел по своей проблеме!
У меня не работает интернет. Поставил вчера ubuntu 10.04 в индикаторе выходить красный восклицательный знак.При соединении или отключении провода комп не реагирует. Потом открыл консоль написал ifconfig -a lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:76 errors:0 dropped:0 overruns:0 frame:0
          TX packets:76 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:5840 (5.8 KB)  TX bytes:5840 (5.8 KB)

wlan0     Link encap:Ethernet  HWaddr e0:b9:a5:00:89:15 
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
Не пойму почему у меня нет eth0,eth1?

Потом набрал route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface

Потом sudo gedit /etc/network/interfaces auto lo
iface lo inet loopback
« Последнее редактирование: 22 Ноябрь 2011, 15:42:54 от Viper666 »

Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13750
    • Просмотр профиля
Re: Проблемы с интернетом!
« Ответ #1 : 22 Ноябрь 2011, 15:47:34 »
открываем снова её, консоль, и показываем, что она ответит на
lspci -vv | grep Ethernet -A16
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

Оффлайн Viper666

  • Автор темы
  • Новичок
  • *
  • Сообщений: 13
    • Просмотр профиля
Re: Проблемы с интернетом!
« Ответ #2 : 22 Ноябрь 2011, 15:50:53 »
01:00.0 Ethernet controller: Atheros Communications AR8152 v2.0 Fast Ethernet (rev c1)
Subsystem: ASUSTeK Computer Inc. Device 8468
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0, Cache Line Size: 32 bytes
Interrupt: pin A routed to IRQ 11
Region 0: Memory at f7fc0000 (64-bit, non-prefetchable) [size=256K]
Region 2: I/O ports at ec00 [size=128]
Capabilities: [40] Power Management version 3
Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA PME(D0+,D1+,D2+,D3hot+,D3cold+)
Status: D0 PME-Enable- DSel=0 DScale=0 PME-
Capabilities: [48] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
Address: 0000000000000000  Data: 0000
Capabilities: [58] Express (v1) Endpoint, MSI 00
DevCap: MaxPayload 4096 bytes, PhantFunc 0, Latency L0s unlimited, L1 unlimited
ExtTag- AttnBtn+ AttnInd+ PwrInd+ RBE+ FLReset-
DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-


Оффлайн kostryukov

  • Старожил
  • *
  • Сообщений: 1588
  • everybody lies
    • Просмотр профиля
    • kostryukov.net
Re: Проблемы с интернетом!
« Ответ #3 : 22 Ноябрь 2011, 16:37:07 »
может их нужно просто поднять ?)
у меня можно спросить=)

Оффлайн Viper666

  • Автор темы
  • Новичок
  • *
  • Сообщений: 13
    • Просмотр профиля
Re: Проблемы с интернетом!
« Ответ #4 : 22 Ноябрь 2011, 16:39:08 »
может их нужно просто поднять ?)
Хмм...интересно,а как это?

Оффлайн kostryukov

  • Старожил
  • *
  • Сообщений: 1588
  • everybody lies
    • Просмотр профиля
    • kostryukov.net
Re: Проблемы с интернетом!
« Ответ #5 : 22 Ноябрь 2011, 16:43:32 »
ну где вы сеть настраиваете? NM ? включить eth
или раз уж залезли уже в интерфейсы, то настроить там и поднять

nano /etc/network/interfaces

auto eth0
iface eth0 inet static
        address 192.168.0.5
        netmask 255.255.255.0
        gateway 192.168.0.1

поднять ifup eth0
у меня можно спросить=)

Оффлайн Viper666

  • Автор темы
  • Новичок
  • *
  • Сообщений: 13
    • Просмотр профиля
Re: Проблемы с интернетом!
« Ответ #6 : 22 Ноябрь 2011, 16:51:04 »
NM, а как через него включить?

Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13750
    • Просмотр профиля
Re: Проблемы с интернетом!
« Ответ #7 : 22 Ноябрь 2011, 16:55:08 »
kostrukov, боюсь не полнимется. ifconfig с параметром -а показывает и опущенные интерфейсы. Видимо проблема с драйверами к сетёвке.
ТС, я извиняюсь. Не думал, что у Вас выдаст так много инфы по этой сетевой, да так что не видно драйвер подцепился или нет
Давайте повторим
lspci -vv | grep Ethernet -A24
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

Оффлайн Viper666

  • Автор темы
  • Новичок
  • *
  • Сообщений: 13
    • Просмотр профиля
Re: Проблемы с интернетом!
« Ответ #8 : 22 Ноябрь 2011, 17:00:07 »
01:00.0 Ethernet controller: Atheros Communications AR8152 v2.0 Fast Ethernet (rev c1)
Subsystem: ASUSTeK Computer Inc. Device 8468
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0, Cache Line Size: 32 bytes
Interrupt: pin A routed to IRQ 11
Region 0: Memory at f7fc0000 (64-bit, non-prefetchable) [size=256K]
Region 2: I/O ports at ec00 [size=128]
Capabilities: [40] Power Management version 3
Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA PME(D0+,D1+,D2+,D3hot+,D3cold+)
Status: D0 PME-Enable- DSel=0 DScale=0 PME-
Capabilities: [48] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
Address: 0000000000000000  Data: 0000
Capabilities: [58] Express (v1) Endpoint, MSI 00
DevCap: MaxPayload 4096 bytes, PhantFunc 0, Latency L0s unlimited, L1 unlimited
ExtTag- AttnBtn+ AttnInd+ PwrInd+ RBE+ FLReset-
DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop-
MaxPayload 128 bytes, MaxReadReq 512 bytes
DevSta: CorrErr- UncorrErr+ FatalErr- UnsuppReq+ AuxPwr+ TransPend-
LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 unlimited, L1 unlimited
ClockPM+ Suprise- LLActRep- BwNot-
LnkCtl: ASPM L1 Enabled; RCB 64 bytes Disabled- Retrain- CommClk+
ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-

« Последнее редактирование: 22 Ноябрь 2011, 17:09:07 от Viper666 »

Оффлайн victor00000

  • Забанен
  • Старожил
  • *
  • Сообщений: 15570
  • Глухонемой (Deaf)
    • Просмотр профиля
Re: Проблемы с интернетом!
« Ответ #9 : 22 Ноябрь 2011, 17:08:59 »
https://forum.ubuntu.ru/index.php?topic=118665.0

Пользователь решил продолжить мысль 22 Ноябрь 2011, 17:10:05:
https://forum.ubuntu.ru/index.php?topic=168538.15
Нельзя друзья, дулу - AnrDaemon видите?
~.o

Оффлайн Viper666

  • Автор темы
  • Новичок
  • *
  • Сообщений: 13
    • Просмотр профиля
Re: Проблемы с интернетом!
« Ответ #10 : 22 Ноябрь 2011, 18:17:09 »
Проблема наполовину решился! 
Если в консоль написать этот код ifconfig -a

sudo modprobe atl1c

echo "`lspci -n | grep 1969: | awk '{print $3}' | sed 's/:/ /g'`" | sudo tee /sys/bus/pci/drivers/atl1c/new_id

dmesg | tail

ifconfig -a
то интернет подключается, а после перезагрузки компа, интернет уже не работает.

Гарри Кашпировский

  • Гость
Re: Проблемы с интернетом!
« Ответ #11 : 22 Ноябрь 2011, 18:50:07 »
тогда
echo atl1c >>/etc/modules

Оффлайн Viper666

  • Автор темы
  • Новичок
  • *
  • Сообщений: 13
    • Просмотр профиля
Re: Проблемы с интернетом!
« Ответ #12 : 23 Ноябрь 2011, 19:03:32 »
тогда
echo atl1c >>/etc/modules
Пишет bash: /etc/modules: Отказано в доступе

sudo поставил!

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27663
    • Просмотр профиля
Re: Проблемы с интернетом!
« Ответ #13 : 23 Ноябрь 2011, 20:44:46 »
sudo -E -s
echo atl1c >>/etc/modules
reboot
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн Viper666

  • Автор темы
  • Новичок
  • *
  • Сообщений: 13
    • Просмотр профиля
Re: Проблемы с интернетом!
« Ответ #14 : 23 Ноябрь 2011, 21:16:29 »
sudo -E -s
echo atl1c >>/etc/modules
reboot
Перегрузился, и все также.

 

Страница сгенерирована за 0.078 секунд. Запросов: 26.