Форум русскоязычного сообщества Ubuntu


Автор Тема: [обновлено]требует то что уже есть  (Прочитано 2327 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн 1saturn1

  • Автор темы
  • Новичок
  • *
  • Сообщений: 33
    • Просмотр профиля
Ubuntu 11.10
при собирании mesa
(Нажмите, чтобы показать/скрыть)


теперь configure: error: LLVM is required to build Gallium R300 on x86 and x86_64
какой конкретно он может требовать пакет? пробывал
sudo apt-get install llvm-dev
sudo apt-get install llvm-gcc-4.5



« Последнее редактирование: 04 Январь 2012, 14:48:32 от 1saturn1 »

Оффлайн yaa13

  • Активист
  • *
  • Сообщений: 311
    • Просмотр профиля
Re: требует то что уже есть
« Ответ #1 : 04 Январь 2012, 13:34:19 »
*-dev пакеты установлены?
libxext-dev
libxdamage-dev
libxfixes-dev
« Последнее редактирование: 04 Январь 2012, 13:38:20 от yaa13 »

Оффлайн Charles Malaheenee

  • Активист
  • *
  • Сообщений: 756
  • Учтите, мы можем дать и вредный совет.
    • Просмотр профиля
Re: требует то что уже есть
« Ответ #2 : 04 Январь 2012, 13:38:16 »
А еще лучше скачать исходники из репов, установить build-depends...
Debian Sid (XFCE) x 2; Debian Sid (Openbox) x 1.
Все мы где-то, когда-то и в чем-то были новичками.

Оффлайн yaa13

  • Активист
  • *
  • Сообщений: 311
    • Просмотр профиля
Re: требует то что уже есть
« Ответ #3 : 04 Январь 2012, 13:52:07 »
да, кстати
Цитата: man apt-get
...
build-dep

    build-dep causes apt-get to install/remove packages in an attempt to satisfy the build dependencies for a source package.

т.е.
sudo apt-get build-dep PKG

Оффлайн 1saturn1

  • Автор темы
  • Новичок
  • *
  • Сообщений: 33
    • Просмотр профиля
Re: требует то что уже есть
« Ответ #4 : 04 Январь 2012, 14:37:04 »
*-dev пакеты установлены?
libxext-dev
libxdamage-dev
libxfixes-dev
помогло , спасибо

 

Страница сгенерирована за 0.061 секунд. Запросов: 24.