Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Проблемы с обновлением (установка ненадежных пакетов)  (Прочитано 1557 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн torren108

  • Автор темы
  • Новичок
  • *
  • Сообщений: 39
  • Совсем зеленый.
    • Просмотр профиля
При попытке установить в Центре приложений Skype, Сhromium и многое другое ПО, выскакивает предупреждение "Необходима установка ненадежных пакетов" с кнопкой "ОК", естественно, программы не устанавливаются. Пока выкручиваюсь Синаптиком, ставлю пакеты оттуда (благо позволительно), но хотелось бы восстановить функциональность Центра приложений.

Так же зачастую прерывается обновление из-за неподписаных пакетов. Так же, ставлю в ручную и продолжаю апдейт.
Ubuntu 10.10 / i686 / AMD Athlon II X2 2.2 GHz / 2 Gb RAM / ATI Mobility Radeon HD 5470.

Оффлайн ArcFi

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 15189
    • Просмотр профиля
    • aetera.net
sudo mv /etc/apt/trusted.gpg{,.bak}
sudo gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /etc/apt/secring.gpg --trustdb-name /etc/apt/trustdb.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver keyserver.ubuntu.com --recv-keys
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys $(sudo apt-get update 2>&1 | grep -o "[0-9A-F]\{16\}" | xargs)
sudo apt-get update

Оффлайн torren108

  • Автор темы
  • Новичок
  • *
  • Сообщений: 39
  • Совсем зеленый.
    • Просмотр профиля
sudo mv /etc/apt/trusted.gpg{,.bak}
sudo gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /etc/apt/secring.gpg --trustdb-name /etc/apt/trustdb.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver keyserver.ubuntu.com --recv-keys
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys $(sudo apt-get update 2>&1 | grep -o "[0-9A-F]\{16\}" | xargs)
sudo apt-get update

К сожалению, проблема осталась. Пробовал установить KTorrent, сначала было сообщение о необходимости включения источника "main", затем вновь сообщение о необходимости установки из ненадежных источников.
Ubuntu 10.10 / i686 / AMD Athlon II X2 2.2 GHz / 2 Gb RAM / ATI Mobility Radeon HD 5470.

Оффлайн ArcFi

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 15189
    • Просмотр профиля
    • aetera.net
Выполняем в терминале, результат под спойлер.

Оффлайн torren108

  • Автор темы
  • Новичок
  • *
  • Сообщений: 39
  • Совсем зеленый.
    • Просмотр профиля
(Нажмите, чтобы показать/скрыть)
Ubuntu 10.10 / i686 / AMD Athlon II X2 2.2 GHz / 2 Gb RAM / ATI Mobility Radeon HD 5470.

Оффлайн ArcFi

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 15189
    • Просмотр профиля
    • aetera.net
Теперь:
sudo apt-get -y upgrade
sudo apt-get -f install

Оффлайн torren108

  • Автор темы
  • Новичок
  • *
  • Сообщений: 39
  • Совсем зеленый.
    • Просмотр профиля
Терминал:
(Нажмите, чтобы показать/скрыть)

После этого KTorrent встал без проблем, вроде бы все :)

Теперь заметил вот еще что: при попытке активировать проприетарный драйвер на видеокарту (ATI), следущее сообщение:
SystemError: Failed to lock /var/cache/apt/archives/lock
Что делать?
Ubuntu 10.10 / i686 / AMD Athlon II X2 2.2 GHz / 2 Gb RAM / ATI Mobility Radeon HD 5470.

Оффлайн ArcFi

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 15189
    • Просмотр профиля
    • aetera.net
sudo apt-get -y autoremove
Теперь заметил вот еще что: при попытке активировать проприетарный драйвер на видеокарту (ATI), следущее сообщение:
SystemError: Failed to lock /var/cache/apt/archives/lock
Что делать?
А это тема отдельного разговора.

Оффлайн torren108

  • Автор темы
  • Новичок
  • *
  • Сообщений: 39
  • Совсем зеленый.
    • Просмотр профиля
sudo apt-get -y autoremove
Теперь заметил вот еще что: при попытке активировать проприетарный драйвер на видеокарту (ATI), следущее сообщение:
SystemError: Failed to lock /var/cache/apt/archives/lock
Что делать?
А это тема отдельного разговора.

Окей, спрошу в другом разделе. Спасибо большое за помощь, впредь буду самостоятельно решать такие проблемы :)
Ubuntu 10.10 / i686 / AMD Athlon II X2 2.2 GHz / 2 Gb RAM / ATI Mobility Radeon HD 5470.

 

Страница сгенерирована за 0.119 секунд. Запросов: 24.