Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Видеофайлы перестали показываться  (Прочитано 1582 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн st544

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Всем привет.

В какой-то момент перестали проигриваться видеофайлы - звук есть, а изображения вообще нет.
Ни VLC, ни штатный Totem, ни специально установленный для проверки SMPlayer.

Из 1й темы в разделе попробовал sudo apt-get install ubuntu-restricted-extras,
но ответом было - все давно уже установлено.

Из изменений в системе были только обновления.
Ubuntu 11.10

Оффлайн easy2002

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 2786
  • Мурманск
    • Просмотр профиля
Re: Видеофайлы перестали показываться
« Ответ #1 : 07 Январь 2012, 21:41:00 »
покажи выхлоп терминала
mplayer /путь/до/видеофайла
Tempora mutantur et nos mutantur in illis

Оффлайн st544

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Видеофайлы перестали показываться
« Ответ #2 : 07 Январь 2012, 22:06:57 »
MPlayer2 UNKNOWN (C) 2000-2011 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing test.avi.
Detected file format: AVI format (libavformat)
[lavf] stream 0: video (mpeg4), -vid 0
[lavf] stream 1: audio (mp3), -aid 0
VIDEO:  [MP4V]  720x400  12bpp  23.976 fps    0.0 kbps ( 0.0 kbyte/s)
Clip info:
 encoder: VirtualDubMod 1.5.10.2 (build 2540/release)
Load subtitles in .
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
[vdpau] Error when calling vdp_device_create_x11: 1
[ass] auto-open
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Asking decoder to use 4 threads if supported.
Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
==========================================================================
==========================================================================
Requested audio codec family [mpg123] (afm=mpg123) not available.
Enable it at compilation.
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 44100 Hz, 2 ch, floatle, 224.0 kbit/7.94% (ratio: 28000->352800)
Selected audio codec: [ffmp3float] afm: ffmpeg (FFmpeg MPEG layer-3 audio)
==========================================================================
[AO OSS] audio_setup: Can't open audio device /dev/dsp: No such file or directory
AO: [alsa] 44100Hz 2ch floatle (4 bytes per sample)
Starting playback...

Оффлайн gregory5

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5085
    • Просмотр профиля
Re: Видеофайлы перестали показываться
« Ответ #3 : 07 Январь 2012, 22:10:49 »
sudo apt-get install libvdpau1

Оффлайн st544

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Видеофайлы перестали показываться
« Ответ #4 : 07 Январь 2012, 22:23:31 »
sudo apt-get install libvdpau1
Уже был установлен, но переустановил.
Результат без изменений - видео нет.

Оффлайн gregory5

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5085
    • Просмотр профиля
Re: Видеофайлы перестали показываться
« Ответ #5 : 07 Январь 2012, 22:41:38 »
Версия ос х64?

Оффлайн st544

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля

Оффлайн gregory5

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5085
    • Просмотр профиля
Re: Видеофайлы перестали показываться
« Ответ #7 : 07 Январь 2012, 22:55:20 »
Попробуйте установить эту вдпау либу lib32-vdpau1 или как то так, гляьте в синаптике

Оффлайн st544

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Видеофайлы перестали показываться
« Ответ #8 : 08 Январь 2012, 10:22:16 »
Порылся в Synaptic.
Переустанавливал различные драйвера к VDPAU - результат не поменялся.
Стал смотреть в сторону X11. Нашел ссылку у VDPAU на libx11-6
Пытался этот пакет переустановить, но вылазит ошибка "E: Internal Error, No file name for libx11-6" и для загрузки предлагает 0 байт.
Также настораживает, что плейер пытается найти "libvdpau_nvidia.so", но у меня видеокарта не nVidia, а Intel HD Graphics 3000.
Раньше же работало, изменениия произошли только через обновления системы.
Где смотреть ?


Пользователь решил продолжить мысль 08 Январь 2012, 10:28:42:
Может вопрос будет странным: А после переустановки в Synaptic драйверов и библиотек систему перезагружать нужно ?  ???
Вроде не предлагали.

Пользователь решил продолжить мысль 08 Январь 2012, 10:36:19:
Перезагрузил систему. Заработало  :)

Пользователь решил продолжить мысль 08 Январь 2012, 10:40:46:
И еще: лог плейера НЕ МОМЕНЯЛСЯ, точно такой же !!!  ???
« Последнее редактирование: 08 Январь 2012, 10:40:46 от st544 »

 

Страница сгенерирована за 0.137 секунд. Запросов: 24.