Форум русскоязычного сообщества Ubuntu


За новостями русскоязычного сообщества и Ubuntu в целом можно следить на нашей страничке в Google+

Автор Тема: Не заводится интернет Ubuntu 10.04.3  (Прочитано 1344 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ферапонт

  • Автор темы
  • Новичок
  • *
  • Сообщений: 18
    • Просмотр профиля
Не заводится интернет Ubuntu 10.04.3
« : 09 Январь 2012, 23:34:45 »
Здравствуйте, уважаемые!
Итак, есть в наличии:
1. Свежепоставленная Ubuntu 10.04.3
2. ADSL модем ZTE ZXDSL 831, настроенный как роутер, подключен по Ethernet
3. Интернет от МГТС (Стрим).

Что было предпринято до написания этого поста:
1. Испробован метод, изложенный здесь: https://forum.ubuntu.ru/index.php?topic=56454.0
Результат, сами понимаете, отрицательный. Auto eth1 подхватывается моментально, Firefox страниц не видит, ping www.ya.ru в терминале говорит, что хост неизвестен.
2. В терминале запущена утилита pppoeconf, всё сделано как в многочисленных описаниях. В процессе настроек везде "YES", плюс свой логин и пароль.

Вот этот мануал видел: https://forum.ubuntu.ru/index.php?PHPSESSID=e3a48a3941a34ea3fd9c01575b4694dd&topic=2950.0
Но тут вроде как для USB, а у меня Ethernet. Может прокатить?
Этот мануал тоже видел: https://forum.ubuntu.ru/index.php?topic=19628.0;all
Но я в душе не знаю какой чипсет у меня в модеме.

Без бубнов интеннет запустился только в 11.04 и в 11.10. В 9.04, 9.10 и, соответственно, в 10.04.3 не запускается. 11.04 и 11.10 не хочу ставить потому, что через некоторое время ОС перстаёт нормально загружаться, но это тема для другого раздела.

В общем, друзья, если не сложно, расскажите ПОДРОБНО и ПОШАГОВО, как запустить интернет? С Убунтой я только-только знакомлюсь, ось очень нравится, намного больше винды. Хотелось бы научиться её настраивать до состояния полной работоспособности.
Заранее благодарен!

С уважением,
Ферапонт



Гарри Кашпировский

  • Гость
Re: Не заводится интернет Ubuntu 10.04.3
« Ответ #1 : 09 Январь 2012, 23:49:00 »
Оч. интересно, у Вас же
Цитировать
ADSL модем ZTE ZXDSL 831, настроенный как роутер
И тут Вы зачем-то настраиваете
Цитировать
pppoeconf
Интернет уже в готовом виде должен быть от модема. В общем убирайте настройки, сделанные через pppoeconf
sudo -E -s
echo -e "auto lo\niface lo inet loopback" >/etc/network/interfaces
service network-manager restart
И диагностику сделайте, вот как тут

Оффлайн Ферапонт

  • Автор темы
  • Новичок
  • *
  • Сообщений: 18
    • Просмотр профиля
Re: Не заводится интернет Ubuntu 10.04.3
« Ответ #2 : 10 Январь 2012, 00:20:53 »
Итак, поступил в соответствии с Вашими советами, KT315.
Вот, что получилось.
1. Снос настроек pppopconf

2. Результаты диагностики:

ferapont@ferapont-desktop:~$ ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:24:1d:cc:56:09 
          inet addr:192.168.1.2  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::224:1dff:fecc:5609/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:22 errors:0 dropped:0 overruns:0 frame:0
          TX packets:60 errors:0 dropped:0 overruns:0 carrier:1
          collisions:0 txqueuelen:1000
          RX bytes:2608 (2.6 KB)  TX bytes:12430 (12.4 KB)
          Interrupt:27

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:12 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:720 (720.0 B)  TX bytes:720 (720.0 B)

ferapont@ferapont-desktop:~$ route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     0.0.0.0         255.255.255.0   U     1      0        0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 eth0
ferapont@ferapont-desktop:~$

ferapont@ferapont-desktop:~$ ping -c4 $(ip r |grep default |awk '{print $3}' |head -1)

ferapont@ferapont-desktop:~$ for p in $(cat /etc/resolv.conf |grep nameserver |awk '{print $2}'); do ping -c4 $p; nslookup ya.ru $p; done
connect: Network is unreachable
;; connection timed out; no servers could be reached

ferapont@ferapont-desktop:~$ lshw -c network
WARNING: you should run this program as super-user.
  *-network               
       description: Ethernet interface
       product: AR8131 Gigabit Ethernet
       vendor: Atheros Communications
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: eth0
       version: c0
       serial: 00:24:1d:cc:56:09
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical
       configuration: broadcast=yes driver=atl1c driverversion=1.0.0.1-NAPI firmware=N/A ip=192.168.1.2 latency=0 multicast=yes
       resources: irq:27 memory:fdec0000-fdefffff ioport:bf00(size=128)
ferapont@ferapont-desktop:~$

Честно сказать, практически все эти сведения для меня - китайская грамота. Если не сложно, растолкуте, что тут к чему, или хотя бы укажите основное, на что обращать внимание.

P.S. Надеюсь, не нарушил правила, выкладывая такой объём вывода команд диагностики.
« Последнее редактирование: 10 Январь 2012, 00:22:28 от Ферапонт »

Оффлайн Saltty

  • Активист
  • *
  • Сообщений: 362
  • Соль (Ubuntu 14.04)
    • Просмотр профиля
    • Мой сайт
Re: Не заводится интернет Ubuntu 10.04.3
« Ответ #3 : 10 Январь 2012, 00:27:40 »
Шлюза не вижу (gateway).
Для нормального функционирования инета надо либо все настройки получить по DHCP (в вашем случае это роутер и это зависит от его настроек) либо прописать все настройки вручную.
Нужны: ip адрес
адрес шлюза
адреса dns

Оффлайн Ферапонт

  • Автор темы
  • Новичок
  • *
  • Сообщений: 18
    • Просмотр профиля
Re: Не заводится интернет Ubuntu 10.04.3
« Ответ #4 : 10 Январь 2012, 00:47:33 »
Вот что пишет в админке модема в разделе "Статус"

ADSL Port   Enable

Downstream Line Rate   6144
Upstream Line Rate   768
LAN IP Address   192.168.1.1
Default Gateway   79.139.152.1
Primary DNS Server   62.112.113.170
Secondary DNS Server   62.112.106.130
Ethernet MAC Address   00:19:C6:6B:C1:62
Firmware Version   ZXDSL 831AIIV2.1.0b_E09_RU

Вот что пишет в разделе Routing Table

Destination   Subnet Mask   Gateway   Interface   Metric
79.139.152.1   255.255.255.255   0.0.0.0   ppp_1_50   0
192.168.100.0   255.255.255.0   0.0.0.0   br1           0
192.168.1.0   255.255.255.0   0.0.0.0   br0           0
0.0.0.0   0.0.0.0   79.139.152.1   ppp_1_50           0

Этих сведений достаточно?
Если нет, то где посмотреть необходимые?

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 25973
    • Просмотр профиля
Re: Не заводится интернет Ubuntu 10.04.3
« Ответ #5 : 10 Январь 2012, 02:31:09 »
ZXDSL 831 и ZXDSL 831 AII - это разные модемы.

Это не те сведения, которые нас интересуют. Если модем нормально настроен (DHCP сервер включен, дозвон настроен), всё должно само работать.

Сделайте две вещи:

sudo dhclient eth0
cat /etc/resolv.conf ; ifconfig -a ; ip route show

Результаты сюда.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн Ферапонт

  • Автор темы
  • Новичок
  • *
  • Сообщений: 18
    • Просмотр профиля
Re: Не заводится интернет Ubuntu 10.04.3
« Ответ #6 : 10 Январь 2012, 23:31:18 »
Здравствуйте, уважаемые!
По совету AnrDaemon, ввёл указанные им команды. Вот что получилось:
ferapont@ferapont-desktop:~$ sudo dhclient eth0
[sudo] password for ferapont:
Internet Systems Consortium DHCP Client V3.1.3
Copyright 2004-2009 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/eth0/00:24:1d:cc:56:09
Sending on   LPF/eth0/00:24:1d:cc:56:09
Sending on   Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 21
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 3
No DHCPOFFERS received.
No working leases in persistent database - sleeping.


ferapont@ferapont-desktop:~$ cat /etc/resolv.conf ; ifconfig -a ; ip route show
# Generated by NetworkManager
nameserver 195.34.31.50
eth0      Link encap:Ethernet  HWaddr 00:24:1d:cc:56:09 
          inet6 addr: fe80::224:1dff:fecc:5609/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:42 errors:0 dropped:0 overruns:0 carrier:1
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:9626 (9.6 KB)
          Interrupt:27

eth0:avahi Link encap:Ethernet  HWaddr 00:24:1d:cc:56:09 
          inet addr:169.254.5.72  Bcast:169.254.255.255  Mask:255.255.0.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:27

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:12 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:720 (720.0 B)  TX bytes:720 (720.0 B)

169.254.0.0/16 dev eth0  proto kernel  scope link  src 169.254.5.72
ferapont@ferapont-desktop:~$


Судя по результатам вывода первой команды, в системе у меня какой-то косяк. Но какой именно, я не понял. Теперь что касается DHCP. В админке модема это выглядит так.

Это то, что нужно?

Галку напротив Enable DHCP я поставил под виндой, за 20 мин. до написания этого поста. Не знаю, связано ли одно с другим, или просто совпадение, но при загрузке Убунты начались матёрые глюки. Во-первых, ось долго грузилась. Обои, указатель мышки посередине, и всё. Во-вторых, отвалились все диски, кроме файловой системы. Интернета как не было, так и нет.
Ещё вылезло сообщение на предмет чего-то там error в системе управления питанием компа. Но что именно, я не догнал, а скрин сделать не догадался.
После пары перезагрузок нормализовалось. Интернет не появился.
Одно с другим как-то связано?

И, наконец, такой вопрос: почему в 11.04 и 11.10 интернет поднимается с полтычка, при настройках модема в режиме Бридж, при использовании этого метода:  https://forum.ubuntu.ru/index.php?topic=56454.0
В режиме роутера - только при настройке auto eth1, даже настройки DSL поднимать не надо.
И почему в 09.04, 09.10, 10.4.3 сеть лежит мёртво и вставать не хочет???

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 25973
    • Просмотр профиля
Re: Не заводится интернет Ubuntu 10.04.3
« Ответ #7 : 10 Январь 2012, 23:50:19 »
Это оно, но у вас

Цитировать
          RX bytes:0 (0.0 B)  TX bytes:9626 (9.6 KB)
          Interrupt:27

явно нет ответа от модема. Либо неисправен порт, либо кабель.
Либо вы забыли сохранить настройки и перезагрузить роутер.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн Ферапонт

  • Автор темы
  • Новичок
  • *
  • Сообщений: 18
    • Просмотр профиля
Re: Не заводится интернет Ubuntu 10.04.3
« Ответ #8 : 10 Январь 2012, 23:53:39 »
Это оно, но у вас

Цитировать
          RX bytes:0 (0.0 B)  TX bytes:9626 (9.6 KB)
          Interrupt:27

явно нет ответа от модема. Либо неисправен порт, либо кабель.
Либо вы забыли сохранить настройки и перезагрузить роутер.

Я готов согласиться, если бы не одно НО!
Почему, для того, чтобы войти в интернет, мне не нужно и пальцем трогать железо (кабель, порт), но лишь загрузить винду и ткнуть на иконку Хрома?...

Да, и на всякий случай, как перезагрузить роутер? Может, дело действительно в этом. Хотя сомневаюсь, честное слово.
И почему, опять же, 11.04 на тех же настройках и том же железе подхватывает интернет с лёту?

Пользователь решил продолжить мысль 11 Январь 2012, 00:17:09:
Про перезагрузку роутера затупил, извините... но все остальные вопросы остаются в сил: почему на том же железе, на тех же настройках всё работает в винде и 11.04?
« Последнее редактирование: 11 Январь 2012, 00:17:09 от Ферапонт »

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 25973
    • Просмотр профиля
Re: Не заводится интернет Ubuntu 10.04.3
« Ответ #9 : 11 Январь 2012, 01:40:30 »
Картиночку бы? И я ошибся, не NAT, а WAN/Internet
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн Ферапонт

  • Автор темы
  • Новичок
  • *
  • Сообщений: 18
    • Просмотр профиля
Re: Не заводится интернет Ubuntu 10.04.3
« Ответ #10 : 11 Январь 2012, 12:37:42 »
Картиночку бы? И я ошибся, не NAT, а WAN/Internet

Извините, не до конца понял, чего картиночку?
По поводу настроек ясно, попробую.

И ещё, други, вот какое предположение у меня возникло. Итак, у меня есть дистрибутивы 9.04, 9.10, 10.04.3, 11.04, 11.10. Интернет нормально подхватывается и работает только на двух последних. На остальных нет. Более того, 9.04 даже не может увидеть моей сетевой карты, пишет, что устройства отсутствуют.
Чем отличаются два крайних дистрибутива от остальных? А тем, что они на DVD, в то время как все прочие исключительно на CD.
Т.е., может быть, в урезанных CD дистрибутивах просто чего-нибудь не хватает, и ось не может снюхаться с модемом и интернетом? А на DVD это есть сразу, в локальной загрузке, и все получется?
Понимаю, что предположение основано не на знании Ubuntu, а на отвлечённой логике. Но может ли оно быть справедливым?
Или просто в последних дистрибутивах появилось нечто, что подвело их ближе остальных к заветной плуг-энд-плэй?

Пользователь решил продолжить мысль 11 Январь 2012, 18:37:34:
Друзья, так картинку чего вешать?
« Последнее редактирование: 11 Январь 2012, 18:37:34 от Ферапонт »

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 25973
    • Просмотр профиля
Re: Не заводится интернет Ubuntu 10.04.3
« Ответ #11 : 11 Январь 2012, 21:00:41 »
Настройки роутера WAN/Internet
Раз интернет подхватывается на 11,04, видимо, в 10,04 нехватает драйверов вашей карты, либо они некорректно определяют железо.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Гарри Кашпировский

  • Гость
Re: Не заводится интернет Ubuntu 10.04.3
« Ответ #12 : 11 Январь 2012, 21:58:19 »
Цитировать
И ещё, други, вот какое предположение у меня возникло.
Предположение, конечно, правильное, но выводы совершенно неверные.
А попробовать таки поставить на ubuntu 10.04 ядро от 11.04 или выше?
Возможно, вся соль в волшебных пузырьках. :)

Оффлайн Saltty

  • Активист
  • *
  • Сообщений: 362
  • Соль (Ubuntu 14.04)
    • Просмотр профиля
    • Мой сайт
Re: Не заводится интернет Ubuntu 10.04.3
« Ответ #13 : 11 Январь 2012, 22:15:29 »
Можно порыть по названию сетевухи...

Оффлайн Ферапонт

  • Автор темы
  • Новичок
  • *
  • Сообщений: 18
    • Просмотр профиля
Re: Не заводится интернет Ubuntu 10.04.3
« Ответ #14 : 12 Январь 2012, 00:26:19 »
Здравствуйте, уважаемые!
Порядком задолбавшись с поисками интернета, спилил Ubuntu нафиг, и поставил Linyx Mint 11. Встала со свистом, на первой космической скорости. Интернет подхватился моментально, без дополнительных настроек вообще! Глюков при запуске нет, диски видит нормально.
И это та же самая Ubuntu, по крайней мере визуально.
В целом, от линуксовых операционных систем впечатление только положительное, и есть большое желание разобраться с ними до уровня уверенного пользования и настройки. Однако все эти непонятки с поиском интернета в 10.4.3. оставили осадок, как говорится.
Ну да и фиг бы с ним! Зато интересно! Не исключено, что воткну Ubuntu третьей операционкой, и домучаю-таки интернет.
В любом случае, большое всем спасибо за участие и помощь!

С уважением,
Ферапонт

 

Страница сгенерирована за 0.062 секунд. Запросов: 24.