Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Проблема с открытием index.php  (Прочитано 1822 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн akel3d

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Проблема с открытием index.php
« : 12 Январь 2012, 14:53:56 »
Здравствуйте. На моем домашнем сервере стоит ubuntu srver 11.10. Пытаюсь поднять на нем свой сайт на друпале. Собственно все получилось, но вскоре выявилась проблема - с компьтеров, находящихся в домашней сети я могу зайти на этот сайт, а со все других (захожу с рабочего) не получается. Перекопал какие только мог настройки. Пока выяснял причину заметил одну странность - файл index.html открывается прекрасно, если его туда залить. А вот файл index.php не открывается (браузер долго ожидает ответа от сервера, потом выдает ошибку: Ошибка 324 (net::ERR_EMPTY_RESPONSE): Сервер разорвал соединение, не отправив данные.). Прихожу домой - все прекрасно открывается. Есть мысли по такой проблеме?
« Последнее редактирование: 12 Январь 2012, 15:30:50 от akel3d »

Оффлайн terrible_user

  • Активист
  • *
  • Сообщений: 438
    • Просмотр профиля
Re: Проблема с открытием index.php
« Ответ #1 : 13 Январь 2012, 10:22:32 »
Смотри access и error логи сервера когда ты взываешь ошибку
Бери больше, кидай дальше

Оффлайн akel3d

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Проблема с открытием index.php
« Ответ #2 : 13 Январь 2012, 14:09:41 »
Вот что в логах, когда на сервере присутствует сайт на php (drupal):
[Fri Jan 13 14:03:55 2012] [debug] mod_deflate.c(615): [client 77.39.21.133] Zlib: Compressed 0 to 2 : URL /index.php
[Fri Jan 13 14:03:59 2012] [debug] mod_deflate.c(615): [client 77.39.21.133] Zlib: Compressed 4284 to 1441 : URL /install.php

Когда оставляю только один index.html, то в логах выдает следующее:
[error] [client 77.39.21.133] File does not exist: /home/max/www/favicon.ico - заливаю favicon в корень - ошибка пропадает.

Дома все так же прекрасно открывается, причем пишет ошибку с favicon.ico когда на сервере друпал. Я пробовал залить favicon.ico в корень - не помогло (ну разве что только ошибка с favion пропала)
« Последнее редактирование: 13 Январь 2012, 14:17:33 от akel3d »

Оффлайн terrible_user

  • Активист
  • *
  • Сообщений: 438
    • Просмотр профиля
Re: Проблема с открытием index.php
« Ответ #3 : 13 Январь 2012, 15:10:24 »
Вот что в логах, когда на сервере присутствует сайт на php (drupal):
[Fri Jan 13 14:03:55 2012] [debug] mod_deflate.c(615): [client 77.39.21.133] Zlib: Compressed 0 to 2 : URL /index.php
[Fri Jan 13 14:03:59 2012] [debug] mod_deflate.c(615): [client 77.39.21.133] Zlib: Compressed 4284 to 1441 : URL /install.php

Когда оставляю только один index.html, то в логах выдает следующее:
[error] [client 77.39.21.133] File does not exist: /home/max/www/favicon.ico - заливаю favicon в корень - ошибка пропадает.

Дома все так же прекрасно открывается, причем пишет ошибку с favicon.ico когда на сервере друпал. Я пробовал залить favicon.ico в корень - не помогло (ну разве что только ошибка с favion пропала)

На favicon.ico вообще не обращайте внимание.

тут нет ничего интересного, надо смотреть как там php работает ли вообще или еще чего, так-то трудно сказать.

index.php - действительно пустой файл?

А install.php - открывается ?
« Последнее редактирование: 13 Январь 2012, 15:12:08 от terrible_user »
Бери больше, кидай дальше

Оффлайн akel3d

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Проблема с открытием index.php
« Ответ #4 : 13 Январь 2012, 15:56:32 »
ничего не открывается. У меня есть подозрение, что это мой роутер шалит. При попытке зайти на него с рабочего компа, он выдал такую же ошибку. А раньше все работало. Да и сейчас даже с index.html подтупливает иногда. Так что буду вечером разбираться

Оффлайн akel3d

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Проблема с открытием index.php
« Ответ #5 : 16 Январь 2012, 12:22:25 »
Проблема решена. На роутере RT-N12 глючат все прошивки с пробросом портов. Если кто-то столкнется с такой-же проблемой - ставьте прошивку от энтузиастов (Олега)

 

Страница сгенерирована за 0.056 секунд. Запросов: 24.