Форум русскоязычного сообщества Ubuntu


Автор Тема: Факс на Убунте.  (Прочитано 6089 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн yaromir

  • Автор темы
  • Активист
  • *
  • Сообщений: 670
    • Просмотр профиля
Факс на Убунте.
« : 23 Декабрь 2007, 19:14:11 »
Всем привет!
Пару дней назад столкнулся с такой проблемой: нужно было отправить факс. Пришлось делать под офтопиком. Имеется факсмодем U.S.Robotics 56K FAX EXT (модель точно не помню). Нужно установить и настроить его в Убунте и поставить прогу для отправки факсов. Буду благодарен за любые идеи по этому поводу.
P.S. Факсмодем подключается через COM порт.

Оффлайн chain

  • Старожил
  • *
  • Сообщений: 1263
    • Просмотр профиля
Re: Факс на Убунте.
« Ответ #1 : 23 Декабрь 2007, 19:59:26 »
подсоединяешь факс, смотришь порт
com1 это ttyS0, com2 - ttyS1 , если не ошибаюсь
проверь в "пользователях и группах", что бы пользователю можно было отправлять факсы, по умолчанию - выключено
потом ставишь efax-gtk, в настройках меняешь все как тебе нужно, там ничего сложного, единственно, проверь порт факса, и вперед
если нужны настройки модема, рули через команды модема, увидишь где в настройках добавлять команды инициализации
-вечный чайник-

Оффлайн yaromir

  • Автор темы
  • Активист
  • *
  • Сообщений: 670
    • Просмотр профиля
Re: Факс на Убунте.
« Ответ #2 : 23 Декабрь 2007, 22:16:59 »
Спасибо, установил efax-gtk. Модем определился как ttyS1. При попытке поставить в режим автоматического приема пишет следующее:
Сокет запущен на порту 9900
efax-0.9a: 01:10:39 открыли /dev/ttyS1
efax-0.9a: 01:10:45 sync: выкидываем DTR
efax-0.9a: 01:10:50 sync: отправляем escapes
efax-0.9a: 01:10:55 Ошибка: sync: модем не отвечает
efax-0.9a: 01:10:55 завершили - нет ответа от модема
P.S. Где в настроиках опция "Дождаться сигнала готовности линии". В офтопике все заработло только после её отключения.

Оффлайн chain

  • Старожил
  • *
  • Сообщений: 1263
    • Просмотр профиля
Re: Факс на Убунте.
« Ответ #3 : 23 Декабрь 2007, 22:38:40 »
ага, понятно, не ловит тон сигнала, в efax может такой опции и не быть
в принципе эта опция просто посылает команду в модем, то есть если ты добавиш ее в строку инициализации, то получишь нужный результат, если нет под рукой команд модема, погугли на эту тему, был когда то замечательный русский сайт по юс роботикс, со своими прошивками  и оптимизацией под плохие российские линии
еще вариант класс модема на первый поменять, иногда помогает
« Последнее редактирование: 23 Декабрь 2007, 22:59:29 от chain »
-вечный чайник-

Оффлайн chain

  • Старожил
  • *
  • Сообщений: 1263
    • Просмотр профиля
Re: Факс на Убунте.
« Ответ #4 : 23 Декабрь 2007, 22:41:19 »
в догонку, а ты уверен что у тебя модем на первом порту висит? попробуй на ttyS0 поменять
у меня под рукой нет роботикса, для экспериментов,  завтра на работе могу посмотреть
-вечный чайник-

Оффлайн yaromir

  • Автор темы
  • Активист
  • *
  • Сообщений: 670
    • Просмотр профиля
Re: Факс на Убунте.
« Ответ #5 : 24 Декабрь 2007, 21:53:17 »
Действительно, поменял ttyS0 на ttyS1 и модем встал на линию. Спасибо за помощь.
Приятно отметить: в Убунте факс тоже практически из коробки.
Еще раз спасибо.

Оффлайн goldskif

  • Активист
  • *
  • Сообщений: 498
  • www.skif.biz
    • Просмотр профиля
    • Альтернативные проекты
Re: Факс на Убунте.
« Ответ #6 : 07 Март 2008, 04:06:11 »
А как послать документ по факсу?
Модем есть,факс есть - efax
но больше ничего нет.  Офис принтер видит -факс нет.
Факс как принтер должен быть установлен? Может,еще какой клиент нужен?
Ubuntu дружелюбная система, но друзей  она, сцуко, выбирает сама...

Оффлайн chain

  • Старожил
  • *
  • Сообщений: 1263
    • Просмотр профиля
Re: Факс на Убунте.
« Ответ #7 : 07 Март 2008, 08:31:40 »
не очень понял в чем вопрос
как из writer, скажем, факсы посылать?
в мануале к efax, все написано
Цитировать
adding a new CUPS virtual printer for efax-gtk by using lpadmin.  To do this,
log in as whatever user has appropriate permissions (usually root) and
do it from the command line with:

  /usr/sbin/lpadmin -p FaxPrinter -E -v socket://localhost:9900

That will create a printer name for efax-gtk called FaxPrinter for a
case where efax-gtk is listening on port 9900.

You should then start efax-gtk, go to the Socket tab in the settings
dialog, check the "Run socket server" box, and enter 9900 in the "Port
to which faxes to be sent" box.
-вечный чайник-

Оффлайн goldskif

  • Активист
  • *
  • Сообщений: 498
  • www.skif.biz
    • Просмотр профиля
    • Альтернативные проекты
Re: Факс на Убунте.
« Ответ #8 : 08 Март 2008, 00:52:48 »
тогда еще вопрос...
в автозагрузку какой командой модем прописать,чтобы он сразу в режим автоматического приема становился.
Ubuntu дружелюбная система, но друзей  она, сцуко, выбирает сама...

Оффлайн chain

  • Старожил
  • *
  • Сообщений: 1263
    • Просмотр профиля
Re: Факс на Убунте.
« Ответ #9 : 08 Март 2008, 13:23:06 »
автоответ в настройках ставить, а автозапуск можно прописать в сеансе
Система-параметры-сеансы
там выбрать Добавить в "Запускаемые при старте программы"
в строке запуска ввести efax-gtk
-вечный чайник-

Оффлайн goldskif

  • Активист
  • *
  • Сообщений: 498
  • www.skif.biz
    • Просмотр профиля
    • Альтернативные проекты
Re: Факс на Убунте.
« Ответ #10 : 08 Март 2008, 18:29:59 »
нее.. это просто загрузка выходит. А для переключения в "Автоматический прием"наверное еще какую-то  команду еще добавить надо..
Ubuntu дружелюбная система, но друзей  она, сцуко, выбирает сама...

Оффлайн chain

  • Старожил
  • *
  • Сообщений: 1263
    • Просмотр профиля
Re: Факс на Убунте.
« Ответ #11 : 08 Март 2008, 19:37:32 »
efax-gtk -rs
-вечный чайник-

Оффлайн goldskif

  • Активист
  • *
  • Сообщений: 498
  • www.skif.biz
    • Просмотр профиля
    • Альтернативные проекты
Re: Факс на Убунте.
« Ответ #12 : 09 Март 2008, 02:10:28 »
ругается при загрузке
Эта программа запущена с ключом -s, но системная панель не найдена!
Ubuntu дружелюбная система, но друзей  она, сцуко, выбирает сама...

Оффлайн chain

  • Старожил
  • *
  • Сообщений: 1263
    • Просмотр профиля
Re: Факс на Убунте.
« Ответ #13 : 09 Март 2008, 11:12:05 »
а если после загрузки в терминале эту команду набрать, нормально запускаестя?
-s - ключ для того, чтобы в свернутом виде запускался, можешь его убрать
-вечный чайник-

Оффлайн goldskif

  • Активист
  • *
  • Сообщений: 498
  • www.skif.biz
    • Просмотр профиля
    • Альтернативные проекты
Re: Факс на Убунте.
« Ответ #14 : 19 Март 2008, 13:40:26 »
пытался только что принять факс - не вышло. Накидалась куча ошибок красным текстом и все..
где копать? Может, строку инициализации прописать как то иначе? Пока и пустую делал, и по умолчанию..
Ubuntu дружелюбная система, но друзей  она, сцуко, выбирает сама...

 

Страница сгенерирована за 0.054 секунд. Запросов: 22.