Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Проблема с видеодрайверами ATI  (Прочитано 2871 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Neuling

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Проблема с видеодрайверами ATI
« : 25 Январь 2012, 03:13:34 »
Доброго времени суток всем!
Возникла проблема с видеодрайверами. Ноутбук DELL XPS 16 видеокарта ATI RADEON HD 4670, UBUNTU 11.10. После активации проприетарных драйверов система начинает тормозить, появляются артефакты, надписи под иконками превращаются в квадратики и т.п. С Gallium 0.4 on AMD RV730 видео работает идеально, только одно но, не работает звук через HDMI и растягиватся экран, при включении звука на HDMI видео начинавет тормозить, а звук так и не появляется.
Помогите пожалуйста убрать артефакты с проприетартыми драйверами или сделать звук через HDMI c Gallium. Заранее благодарю!

Оффлайн ink71

  • Участник
  • *
  • Сообщений: 200
  • Ку!!!
    • Просмотр профиля
Re: Проблема с видеодрайверами ATI
« Ответ #1 : 25 Январь 2012, 10:06:13 »
Попробуй установить дрова с офф. Сайта: http://support.amd.com/us/gpudownload/linux/Pages/radeon_linux.aspx
Устанавливать лучше по инструкции:
http://ubuntovod.ru/instructions/amd-ati-ubuntu.html
Lin - Ку! Win - Кю!

Оффлайн Neuling

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Проблема с видеодрайверами ATI
« Ответ #2 : 25 Январь 2012, 14:37:48 »
Попробуй установить дрова с офф. Сайта: http://support.amd.com/us/gpudownload/linux/Pages/radeon_linux.aspx
Устанавливать лучше по инструкции:
http://ubuntovod.ru/instructions/amd-ati-ubuntu.html
Устанавливал с офф сайта по инструкции с данного ресурса, результат такой же: все тормозит, артефакты и пр....

Оффлайн gregory5

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5083
    • Просмотр профиля
« Последнее редактирование: 25 Январь 2012, 20:19:41 от gregory5 »

Оффлайн Neuling

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Проблема с видеодрайверами ATI
« Ответ #4 : 25 Январь 2012, 20:19:18 »
Вариант №2
https://forum.ubuntu.ru/index.php?topic=96649.msg732611#msg732611
После выполнения sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core  xserver-xorg-video-radeon xserver-xorg-video-ati пропал звук(при регулировке громкости нет щелчка), а так звук работает.

Оффлайн gregory5

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5083
    • Просмотр профиля
Re: Проблема с видеодрайверами ATI
« Ответ #5 : 25 Январь 2012, 20:22:17 »
По звуку не знаю, есть видимо какие то проблемы с пакетами или конфигами, раз после реинстала некоторых системных пакетов появился такой "глюк"
Можно скачать ubuntu-tweak и с его помощью почистить мусор в системе (там всё понятно)
Ну а после переустановить alsa

так это всё к другому, драйвер и видео завелись, как работает?

Оффлайн Neuling

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Проблема с видеодрайверами ATI
« Ответ #6 : 25 Январь 2012, 20:34:03 »
По звуку не знаю, есть видимо какие то проблемы с пакетами или конфигами, раз после реинстала некоторых системных пакетов появился такой "глюк"
Можно скачать ubuntu-tweak и с его помощью почистить мусор в системе (там всё понятно)
Ну а после переустановить alsa

так это всё к другому, драйвер и видео завелись, как работает?
Драйвер работает, артефакты пропали, но теперь появились проблемы с видео, подтормаживают фильмы (дергается изображение)...Увеличилось время открытия приложений, так же растянуло логотип Ubuntu при загрузке системы...
Разрешение экрана 1600х900
(Нажмите, чтобы показать/скрыть)
« Последнее редактирование: 25 Январь 2012, 20:46:48 от Neuling »

Оффлайн gregory5

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5083
    • Просмотр профиля
Re: Проблема с видеодрайверами ATI
« Ответ #7 : 25 Январь 2012, 21:21:11 »
Включите вертикальную синхронизацию
Делаеться в Каталисте и в настройках компиза там sync VBank вроде
Так же включите или выключите эффекты и посмотрите как лучше

По поводу загрузчика

Исправление сплеш скрина Plymouth в Ubuntu

Оффлайн Neuling

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Проблема с видеодрайверами ATI
« Ответ #8 : 25 Январь 2012, 21:31:12 »
Включите вертикальную синхронизацию
Делаеться в Каталисте и в настройках компиза там sync VBank вроде
Так же включите или выключите эффекты и посмотрите как лучше

По поводу загрузчика

Исправление сплеш скрина Plymouth в Ubuntu
Выключал вертикальную синхронизацию через Компиз, изменений никаких... Видео невозможно смотреть, воспроизведение подьормаживает как с низким битрейтом

Оффлайн ink71

  • Участник
  • *
  • Сообщений: 200
  • Ку!!!
    • Просмотр профиля
Re: Проблема с видеодрайверами ATI
« Ответ #9 : 25 Январь 2012, 22:03:56 »
По поводу видео вам сюда. Пост 152:
https://forum.ubuntu.ru/index.php?topic=125588.150
Lin - Ку! Win - Кю!

Оффлайн Neuling

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Проблема с видеодрайверами ATI
« Ответ #10 : 25 Январь 2012, 22:28:36 »
По поводу видео вам сюда. Пост 152:
https://forum.ubuntu.ru/index.php?topic=125588.150
Сделал все по Вашей инструкции - не помогло. У меня проблема не только с видео высокого развешения, со всеми видео. Изображение накладывается и дергается, полосы палавающие...

Оффлайн gregory5

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5083
    • Просмотр профиля
Re: Проблема с видеодрайверами ATI
« Ответ #11 : 25 Январь 2012, 22:29:13 »
Цитировать
Включите вертикальную синхронизацию

Оффлайн riderr3

  • Любитель
  • *
  • Сообщений: 77
  • Ubuntu 14.04 (Gnome)
    • Просмотр профиля
    • Домашняя страница
Re: Проблема с видеодрайверами ATI
« Ответ #12 : 25 Январь 2012, 22:35:01 »
У меня тоже ATI, драйвера с оф сайта. Компиз удалил нафиг, верт синхронизацию отключил. Разрывы на экране почти не заметны, ничего не тормозит

Оффлайн Neuling

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Проблема с видеодрайверами ATI
« Ответ #13 : 25 Январь 2012, 23:02:04 »
Цитировать
Включите вертикальную синхронизацию
Да, спасибо, не сразу понял, где Вы просили отключить. Помогло вроде, плаги почти незаметны.

Цитировать
ink71
Вам тоже спасибо за советы.

Оффлайн rustamych

  • Участник
  • *
  • Сообщений: 170
    • Просмотр профиля
Re: Проблема с видеодрайверами ATI
« Ответ #14 : 26 Январь 2012, 11:52:16 »
У меня тоже ATI, только HD 2400, тоже были проблемы. Пробовал устанавливать драйвер с сайта, возникли проблемы с пакетом mathematica. В итоге нашел свой путь, установил проприетарный драйвер с репозитария, а потом выбрал "без эффектов" в система - параметры - внешний вид - визуальные эффекты. Теперь все работает быстро. Можно было обойтись и без проприетарного драйвера, но у меня внешний дисплей не хотел цепляться, все дрожало и размывалось. С проприетарным все отлично. Для ускорения развертывания создаешь файл .gtkrc-2.0 , в него пишешь
### Минимальное время в миллисекундах, в течение которого указатель должен оставаться на пункте меню перед появлением подменю
gtk-menu-popup-delay = 0
### Время в миллисекундах перед скрытием подменю, когда указатель перемещается на подменю
gtk-menu-popdown-delay = 0
### Задержка в миллисекундах перед появлением подменю после панели меню
gtk-menu-bar-popup-delay = 0
сохраняешь и помещаешь ее в свою корневую директорию. После этого все открывается махом и все иконки быстро появляются.

 

Страница сгенерирована за 0.06 секунд. Запросов: 24.