Форум русскоязычного сообщества Ubuntu


Автор Тема: Ошибка сегментации в Blender 2.6  (Прочитано 1893 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн LewakoPuntaf

  • Автор темы
  • Любитель
  • *
  • Сообщений: 69
    • Просмотр профиля
Ошибка сегментации в Blender 2.6
« : 26 Январь 2012, 12:51:31 »
Все никак не уймусь в рвении изучить сей 3д-редактор. Но проблемы растут подобно кому снега, пущенному с горы!

Ситуация такая: я таки нашел репы для версии 2.6 и поставил; какое-то время мы с блэндером жили-дружили,система неоднократно предлагала его обновить посредством новой установки, но я отказывал, отжимая галочку в списке предложенных к обновлению программ и пакетов...однажды я забыл это сделать! Система обновилась, все прекрасно, комп перезагружен, но вот блэндер не хочет запускаться ни через иконку, ни в терминале выдавая "ошибку сегментирования". Попробовал переустановить - тот же результат. glxinfo | grep OpenGL выдает, что все нормально.
Выход нашелся только один - скачать вот отсюда http://www.blender.org/download/get-blender/ версию для своей архитектуры и юзать ее, просто запуская вложенный файл. Как бы особой проблемы в этом нет, но что-то неуловимое смущает, ведь он не установлен, а болтается на птичьих правах где-то.

В общем, мне надо как-то исправить эту ситуацию, но решения не нахожу. Здесь, на форуме, много тем с подобным вопросом, но ничего толкового не нашел. В чем проблема и что не нравиться системе - не пойму никак!

Система: Ubuntu 10.04 LTS
Видюха: Mesa DRI Intel(R) 945G GEM 20091221 2009Q4 x86/MMX/SSE2

roco.constantin.b

  • Гость
Re: Ошибка сегментации в Blender 2.6
« Ответ #1 : 27 Январь 2012, 01:13:57 »
переустановить дрова на видиху

Оффлайн LewakoPuntaf

  • Автор темы
  • Любитель
  • *
  • Сообщений: 69
    • Просмотр профиля
Re: Ошибка сегментации в Blender 2.6
« Ответ #2 : 27 Январь 2012, 10:05:35 »
переустановить дрова на видиху
система их как таковые для моей видюхи не видит, так как она интегреная!
да и к тому же - раньше работало ведь...или блэндер обновился и перестал воспринимать мою видюху за адекватное железо(хотя 128 Мб интегр видео - сам нормальным не считаю)?!

Пользователь решил продолжить мысль 27 Январь 2012, 19:31:07:
ЛЮДИ!!!
Ну хоть кто-нибудь, помогите!!!
« Последнее редактирование: 27 Январь 2012, 19:31:07 от LewakoPuntaf »

roco.constantin.b

  • Гость
Re: Ошибка сегментации в Blender 2.6
« Ответ #3 : 27 Январь 2012, 23:27:36 »
Цитировать
система их как таковые для моей видюхи не видит, так как она интегреная!
да и к тому же - раньше работало ведь...или блэндер обновился и перестал воспринимать мою видюху за адекватное железо(хотя 128 Мб интегр видео - сам нормальным не считаю)?!
не знаю как там с интегреной видюхой, но если ошибка segmentation fault то значит слетели дрова видеокарту. Значит их надо переустановить,
без понятия как устанавливаются дрова на интерированые видюхи но почему то уверен, что они как-то устанавливаются. Так как блендер это 3д программа то для нормальной работы дрова нужны проприентарные.
В общем переустанови mesa и дрова и все заработает

P.S. мне при каждом обновлении ядра приходится переустанавливать дрова ниведиа для коректной работы XSI и mudbox.

Оффлайн LewakoPuntaf

  • Автор темы
  • Любитель
  • *
  • Сообщений: 69
    • Просмотр профиля
Re: Ошибка сегментации в Blender 2.6
« Ответ #4 : 28 Январь 2012, 01:52:19 »
тут есть маленькая загвостка...выдает - "проприетарные драйверы устройств не используются в вашей системе".
как их тогда ставить - ХЗ.
простите балванизм, но что такое mesa - я так полагаю чипсет?!


Оффлайн LewakoPuntaf

  • Автор темы
  • Любитель
  • *
  • Сообщений: 69
    • Просмотр профиля
Re: Ошибка сегментации в Blender 2.6
« Ответ #6 : 29 Январь 2012, 13:29:25 »
https://forum.ubuntu.ru/index.php?topic=96649.0
https://forum.ubuntu.ru/index.php?topic=3031.0
Если не совсем все понятно, то разъясню - у меня интегрённый интеловский чипсет!
Может это как-то повлиять на обновленный блендер?!

Оффлайн VlaoMao

  • Активист
  • *
  • Сообщений: 308
  • ArchLinux - eMachines e725 && Nokia N950
    • Просмотр профиля
Re: Ошибка сегментации в Blender 2.6
« Ответ #7 : 29 Январь 2012, 17:25:14 »
не знаю как там с интегреной видюхой, но если ошибка segmentation fault то значит слетели дрова видеокарту.
Ну конечно.
ТС, в синаптике откати пакет до старой версии, делов-то.

Оффлайн LewakoPuntaf

  • Автор темы
  • Любитель
  • *
  • Сообщений: 69
    • Просмотр профиля
Re: Ошибка сегментации в Blender 2.6
« Ответ #8 : 29 Январь 2012, 19:49:07 »
Тут у меня опять же загвостка:
1. Я привык работать на версии 2.6, а 2.5(2.49) различны как юнити и гном2!
2. Не знаю как делать откат. Ни через терминал, ни через синаптик ни разу этого не делал.

Буду очень признателен, если скажите как это делается)))

Оффлайн VlaoMao

  • Активист
  • *
  • Сообщений: 308
  • ArchLinux - eMachines e725 && Nokia N950
    • Просмотр профиля
Re: Ошибка сегментации в Blender 2.6
« Ответ #9 : 29 Январь 2012, 21:33:53 »
В синаптике пакет->указать версию

Оффлайн LewakoPuntaf

  • Автор темы
  • Любитель
  • *
  • Сообщений: 69
    • Просмотр профиля
Re: Ошибка сегментации в Blender 2.6
« Ответ #10 : 30 Январь 2012, 10:09:51 »
Спасибо, а как в терминале? Так, для общего развития)

Оффлайн VlaoMao

  • Активист
  • *
  • Сообщений: 308
  • ArchLinux - eMachines e725 && Nokia N950
    • Просмотр профиля
Re: Ошибка сегментации в Blender 2.6
« Ответ #11 : 31 Январь 2012, 12:17:28 »
Черт его знает, у меня уже нет Ubuntu.

Оффлайн DoctorRover

  • Модератор раздела
  • Старожил
  • *
  • Сообщений: 1845
  • Ubuntu 20.10, 21.04
    • Просмотр профиля
Re: Ошибка сегментации в Blender 2.6
« Ответ #12 : 01 Февраль 2012, 01:00:30 »
Столкнулся ровно с таким же эффектом. Помог только откат к версии 2.58.
А у вас из какого репозитория была установлена версия 2.6? У меня была 2.61 из ppa:oneiric-bleed/ppa.

Update.  А blender 2.61 вот отсюда: ppa:irie/blender заработал.
« Последнее редактирование: 01 Февраль 2012, 01:14:43 от DoctorRover »
You're never too old to Rock'n'Roll if you're too young to die.

Оффлайн LewakoPuntaf

  • Автор темы
  • Любитель
  • *
  • Сообщений: 69
    • Просмотр профиля
Re: Ошибка сегментации в Blender 2.6
« Ответ #13 : 01 Февраль 2012, 12:08:31 »
Черт его знает, у меня уже нет Ubuntu.
0_0
не Ubuntu?!))))

DoctorRover, я отсюда ставил http://ppa.launchpad.net/cheleb/blender-svn/ubuntu
Сейчас попробую репы, вами предложенные.

Замечательно - работает ppa:irie/blender!!!
Можно теперь вернуться к попытка творения)))

Всем огромное спасибо за помощь!
« Последнее редактирование: 01 Февраль 2012, 12:24:14 от LewakoPuntaf »

 

Страница сгенерирована за 0.09 секунд. Запросов: 25.