Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: ASUS O!Play R1 + Ubuntu  (Прочитано 2917 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн roma2000

  • Автор темы
  • Любитель
  • *
  • Сообщений: 81
    • Просмотр профиля
ASUS O!Play R1 + Ubuntu
« : 03 Февраль 2012, 20:03:15 »
Здравствуйте.
Подключил ASUS O!Play R1 к роутеру.
К роутеру подключен Пк, на котором стоит Ubuntu 11.04.
Установил samba.
Расшарил с помощью sudo system-config-samba папки.
проигрыватель видит MAIN-SERVER -> Видео
пробую войти в папку видео
в ответ -  LOGON FAIL.
Подскажите пжлста что надо сделать или про что почитать.

нашел статью
http://gongled.ru/2494.html
там товарищь сталкнулся с такой же воде проблемой

"Разочаровало то, что директории, которые были опубликованы для общего доступа, не хотели отображаться в списках хостов ASUS O!Play. Проблема была решена спустя несколько десятков минут поиска в Google; сообщение на сайте ASUSTeK Computer."

http://vip.asus.com/forum/view.aspx?id=20100124015000859&board_id=19&model=O!Play+HDP-R1&page=1&SLanguage=en-us

к сожалению не владею английским
подскажите о чем там речь если можно
« Последнее редактирование: 03 Февраль 2012, 20:08:17 от roma2000 »

Оффлайн EvgenNsk

  • Участник
  • *
  • Сообщений: 131
    • Просмотр профиля
Re: ASUS O!Play R1 + Ubuntu
« Ответ #1 : 03 Февраль 2012, 20:06:20 »
Здравствуйте.
Подключил ASUS O!Play R1 к роутеру.
К роутеру подключен Пк, на котором стоит Ubuntu 11.04.
Установил samba.
Расшарил с помощью sudo system-config-samba папки.
проигрыватель видит MAIN-SERVER -> Видео
пробую войти в папку видео
в ответ -  LOGON FAIL.
Подскажите пжлста что надо сделать или про что почитать.
У меня этот же плеер свободно подключается к машине на Win7. Анализ сеанса показывает, что подключается он от имени гостевой учетной записи.
Попробуй создать учетку для шареных Samba-папок c именем "Гость" и пустым паролем.

Пользователь решил продолжить мысль 03 Февраль 2012, 20:08:11:
проигрыватель видит MAIN-SERVER -> Видео
И кстати, прежде всего зайди на support.asus.com и скачай последнюю версию прошивки для этого плеера.
Прошивку копируешь на флэшку, флэшку втыкаешь в USB-порт плеера, в меню "Настройки" выбираешь "Обновление ПО".
И переключи уже в настройках интерфейс плеера на русский язык.
« Последнее редактирование: 03 Февраль 2012, 20:08:11 от EvgenNsk »

Оффлайн roma2000

  • Автор темы
  • Любитель
  • *
  • Сообщений: 81
    • Просмотр профиля
Re: ASUS O!Play R1 + Ubuntu
« Ответ #2 : 03 Февраль 2012, 20:11:03 »
У меня этот же плеер свободно подключается к машине на Win7. Анализ сеанса показывает, что подключается он от имени гостевой учетной записи.
Попробуй создать учетку для шареных Samba-папок c именем "Гость" и пустым паролем.

Первым делом прошивку обновил.
Качаешь прошивку - разархивируешь его - в папке 2 файла (мануал и прошивка) -прошивку на флешку и втыкаем!
У меня Ubuntu 11.04
Вопрос - так это мне в Ubuntu гостевую учетку надо сделать?
« Последнее редактирование: 03 Февраль 2012, 20:12:58 от roma2000 »

Оффлайн EvgenNsk

  • Участник
  • *
  • Сообщений: 131
    • Просмотр профиля
Re: ASUS O!Play R1 + Ubuntu
« Ответ #3 : 03 Февраль 2012, 20:15:18 »
Вопрос - так это мне в Ubuntu гостевую учетку надо сделать?
Она в винде называется гостевой, а в Ubuntu я так понимаю надо называть так, как будет ожидать плеер при подключении, т.е. "Гость".

Оффлайн roma2000

  • Автор темы
  • Любитель
  • *
  • Сообщений: 81
    • Просмотр профиля
Re: ASUS O!Play R1 + Ubuntu
« Ответ #4 : 03 Февраль 2012, 20:36:38 »
когда нажимаю на вход в папку Видео появляется окно

ID польз.сети   -   OPlayer
Пароль          -    *****
"ОК и сохр. в "Мои ярлыки""
  ОК          Отмена
Пытался менять ID и пароли - не помогает

Оффлайн EvgenNsk

  • Участник
  • *
  • Сообщений: 131
    • Просмотр профиля
Re: ASUS O!Play R1 + Ubuntu
« Ответ #5 : 03 Февраль 2012, 20:43:45 »
когда нажимаю на вход в папку Видео появляется окно

ID польз.сети   -   OPlayer
Пароль          -    *****
"ОК и сохр. в "Мои ярлыки""
  ОК          Отмена
Пытался менять ID и пароли - не помогает

Ну ID и пароль попробуй ввести такие же, какие есть в разрешенных на доступ к сетевой папке в Ubuntu.
Может в кодировке какие-то проблемы? Ради эксперимента создай также папку Video (чтоб английские буквы были) и попробуй зайти в нее.

Оффлайн roma2000

  • Автор темы
  • Любитель
  • *
  • Сообщений: 81
    • Просмотр профиля
Re: ASUS O!Play R1 + Ubuntu
« Ответ #6 : 03 Февраль 2012, 21:20:05 »
РЕШЕНО!!!
Спасибо братья чайники за попытки помочь, однако вся было напрасно, пока я не решил перевести статью по ссылке выше.
Опишу дальше свои действия может кому поможет.

ИТАК
To everyone who wants to create a shortcut on Asus O!play
Для всех, кто хочет создать ярлык на Asus O!play

1) Open a telnet session to your device:
1) Откройте Telnet сессии на своем устройстве (тут я впал в небольшую кому. на финдоса не знаю про этот телнет. короче это такая штука для удаленного управления, можно со своего компа в командной строке управлять другим устройством.)
надо ввести в терминале
telnet DEVICE_IP (where DEVICE_IP is you o!play IP address, like 192.168.1.2)
                    где DEVICE_IP это ваш  o!play IP адресс, например. 192.168.1.2. я его определил в настройках девайса.
telnet 192.168.1.2

2) For user name, type "root"
спросит имя, надо ввести root

3) Edit/create a file in /usr/local/etc/dvdplayer called NetworkBrowser.ini
потом надоввести эту команду. это создаст файл где-то чтобы потом в него ввести что-то
vi /usr/local/etc/dvdplayer/NetworkBrowser.ini

появится такая фигня в терминале
~
~
~


Press "i"
нажми i

Then cut and paste the these lines:
(Remember to change everything in blue)

Затем вырезать и вставлять эти строки:
(Не забудьте изменить все в синем)

[MAIN]
num=1
 здесь еще один символ почему то не отображается поэтому пишу так -[-0-]- черточки - убрать
label='MY_NETWORK_DEVICE'
id='my_username'
pw='my_password'
Domain=''
Hostname=''
ip1=192
ip2=168
ip3=1
ip4=2
domain=''
hostname=''

To quit, press "ESC" and after, SHIFT+Z two times (ZZ)
Для выхода нажать  "ESC" и потом SHIFT+ZZ

Reboot your system (you can do this in telnet session typing "reboot") and enjoy!
Перезагрузись и будет тебе счастье.
Запустил я свой девай а он опять не хотел входить
Удалил логин и пароль (сделал поля с ними пустыми)
И все заработало!
Вот так то!
« Последнее редактирование: 05 Февраль 2012, 10:26:26 от roma2000 »

Оффлайн EvgenNsk

  • Участник
  • *
  • Сообщений: 131
    • Просмотр профиля
Re: ASUS O!Play R1 + Ubuntu
« Ответ #7 : 03 Февраль 2012, 21:28:02 »
РЕШЕНО!!!
Нифига себе квест.
У меня как то сразу заработало "из коробки", правда под Win7, я и не думал, что дело дойдет до правки конфигов через телнет

 

Страница сгенерирована за 0.079 секунд. Запросов: 24.