Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Непонятки с версиями пакетов  (Прочитано 808 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sla000

  • Автор темы
  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Непонятки с версиями пакетов
« : 07 Февраль 2012, 09:27:42 »
Забрал из репозитория последнюю версию ffmpeg, из trunk. Скомпилировал, все как обычно:

./configure [бла-бла-бла]
make

Здесь проблем нет, все компилится.
Делаю
sudo checkinstall
Ругается что у пакета не указана версия продукта. Помню что в стандартной репе последняя версия 0.9.1, поэтому вписываю номер версии заведомо больше, вроде 0.10.0. Сheckinstall это проглатывает, делает пакет и ставит его. Наслаждаюсь жизнью, но не долго. На следующий день менеджер обновлений говорит мне что в репозитории есть более свежая версия: 4:0.9.1! Я конечно не стал обновлять именно это пакет, но перспектива каждый раз снимать эту галочку не радует.

Собственно вопрос: как правильно назвать версию, чтобы менеджер обновлений не пытался ее заменить?

Пользователь решил продолжить мысль 07 Февраль 2012, 09:40:00:
И вдогонку, что вообще значит такое именование версии, начинающееся с "4:". Столкнулся с этим не первый раз, в синаптике полно таких пакетов, но в первый раз это стало проблемой.
« Последнее редактирование: 07 Февраль 2012, 09:40:00 от sla000 »
Ubuntu 11.04

Оффлайн БТР

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 5424
    • Просмотр профиля
Re: Непонятки с версиями пакетов
« Ответ #1 : 07 Февраль 2012, 10:02:40 »
Попробуй установить версию 4:0.9.2

Цифры в начале применяются для установки в разных релизах Ubuntu

Оффлайн sla000

  • Автор темы
  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Re: Непонятки с версиями пакетов
« Ответ #2 : 08 Февраль 2012, 16:36:47 »
Спасибо! Это помогло.
Ubuntu 11.04

 

Страница сгенерирована за 0.082 секунд. Запросов: 25.