Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Не получается настроить сервер в роли интернет шлюза  (Прочитано 675 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн loki1

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Добрый день.
Я пытаюсь настроить ubuntu server 11.10 в роли роутера, по этой статье http://interface31.ru/tech_it/2009/11/linux-nastrojka-routera-nat-dhcp-squid.html

Настроил сетевые интерфейсы (/etc/network/interfaces) таким образом :

auto lo
iface lo inet loopback
    post-up iptables-restore </etc/iptables.conf

auto eth0
  iface eth0 inet static
    address x.x.x.x
    netmask x.x.x.x
    gateway x.x.x.x

auto eth1
  iface eth1 inet static
    address 192.168.0.250
    netmask 255.255.255.0

Настройки интерфейса eth0 были скопированы с роутера который в данный момент выпускает меня в интернет, это dlink dir-618, его я как раз и хочу заменить полноценным сервером. На сервере задал с помощью ifconfig мак адрес рабочего роутера.

В петле загрузка iptables.conf из вот этой статьи https://forum.ubuntu.ru/index.php?topic=107492.0 в которой я пытался найти решение своей проблемы, но к сожалению безуспешно... вот каким образом был создан этот файл:

echo 'net.ipv4.ip_forward = 1' >>/etc/sysctl.conf; sysctl -p
iptables -t nat -A POSTROUTING -s 192.168.0.0/24 ! -d 192.168.0.0/24 -j MASQUERADE
iptables -t mangle -A FORWARD -p tcp -m tcp --tcp-flags RST,SYN SYN -j TCPMSS --clamp-mss-to-pmtu
iptables-save >/etc/iptables.conf

Так вот, после всех настроек и перезагрузки конфигурации сети я с сервера не могу  попасть в интернет и просто не знаю как продиагностировать проблему свою... пингую внешние адреса и ничего, шлюз моего провайдера тоже не пингуется (тот который gateway x.x.x.x в eth0 ) dns сервера тоже...

Что я делаю не так?

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27655
    • Просмотр профиля
Чем вам d-link не полноценный роутер?
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн loki1

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Дело в том, что мне не достаточно его функционала. Например, я хочу контролировать выход пользователей в интернет, ну и есть еще другие задачи, которые требуют большей гибкости в настройке.
Конечно я могу сделать прокси сервер, но дело не в этом, я просто хочу понять, что я не так делаю, почему на сервере при прямом подключении нет интернета.
Я вот даже не знаю как можно понять в чем проблема...

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27655
    • Просмотр профиля
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн loki1

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Да, спасибо большое за ссылку, но я ознакомился с этой заметкой еще до того как задать вопрос да и в вопросе собственно она тоже фигурирует...
Если выполнить все действия указанный в заметке, то все остается по прежнему.
Наверное я плохо сформулировал вопрос, его думаю можно сократить до такого:
Есть роутер dlink, который отлично справляется с раздачей интернета, ктороый я хочу заменить по не имеющим к делю никакого отношения причинам. Я копирую с него параметры (ip, dns, gateway, netmask, mac-address), вытаскиваю из него провод интернета, вставляю в компьютер под управление ubuntu server, задаю параметры полностью идентичные тем, что были на роутере, перезагружаю сетевой интерфейс и интернет на нем не появляется. Gateway провайдора при этом не пингуется.

Так вот вопрос - где в таком элементарном действии можно ошибиться?
Как можно диагностировать проблему?

Дригие настройки, такие как роуты, я упомянул, только потому что они имели место быть и я не был уверен, что это не повлияло на работу компьютера.
У меня были версии что это побочный эфект работы какого-то ПО на сервере. Может такое быть?

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27655
    • Просмотр профиля
Если БЫ вы выполнили ВСЕ действия, то в вашем первом посте было бы НЕСКОЛЬКО больше информации.

И надо не тупо вбивать "как там", а настраивать интерфейс по инструкции провайдера для подключения к интернету. (Даже если результаты в итоге будут одинаковые - безмозглый копипаст вреден для здоровья.)
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн loki1

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Я выполнил все действия указанные в статье с поправкой на разницу в настроках системы, таких как статический ip адрес в моем eth0 интерфейсе.
Может у Вас есть какие-то идеи или советы, что делать, чтобы решить проблему?

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27655
    • Просмотр профиля
Там ещё спойлер есть... в самом конце статьи...
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

 

Страница сгенерирована за 0.081 секунд. Запросов: 25.