Форум русскоязычного сообщества Ubuntu


Автор Тема: 403 Forbidden  (Прочитано 1712 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн anytup

  • Автор темы
  • Любитель
  • *
  • Сообщений: 58
    • Просмотр профиля
403 Forbidden
« : 18 Февраль 2012, 17:50:28 »
У меня Ubuntu 11.10, до этого работал с Ubuntu Server.
Итак, в чем проблема. Сделал все, как по мануалу, даже
так еще:
chmod -R 777 /home/userName/public_html/Но. Пишется "You don't have permission to access / on this server.", в корне чего лежит index.php, да и он тоже недоступен. Однако, http://localhost/phpmyadmin/ - полностью доступен.
Это читал, гуглил. Сервер раз 100 перезагружал, все равно глухо. Странно, что на Ubuntu Server все норм, а на домашнем компе такая "штучка". Что делать как жить?

Оффлайн drako

  • Старожил
  • *
  • Сообщений: 1422
    • Просмотр профиля
Re: 403 Forbidden
« Ответ #1 : 22 Февраль 2012, 00:27:28 »
В инструкции маленькая подстава - не указано что апачу нужно сообщить(запустить) имя пользователя userName.

Оффлайн anytup

  • Автор темы
  • Любитель
  • *
  • Сообщений: 58
    • Просмотр профиля
Re: 403 Forbidden
« Ответ #2 : 07 Апрель 2012, 17:51:35 »
Я создал группу и юзера:
groupadd apache
useradd apache -c "Apache Server" -d /dev/null -g apache -s /sbin/nologin
а что дальше? httpd.conf пустой, это норм?

Оффлайн gregory5

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5085
    • Просмотр профиля
Re: 403 Forbidden
« Ответ #3 : 07 Апрель 2012, 18:03:20 »
Нормально, он не используеться
Конфиг виртуал хоста покажите

Оффлайн anytup

  • Автор темы
  • Любитель
  • *
  • Сообщений: 58
    • Просмотр профиля
Re: 403 Forbidden
« Ответ #4 : 07 Апрель 2012, 18:08:34 »
<VirtualHost *:80>
ServerAdmin webmaster@localhost

DocumentRoot /home/user/www
<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>
<Directory /home/user/www/>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
AllowOverride None
Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>

ErrorLog ${APACHE_LOG_DIR}/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog ${APACHE_LOG_DIR}/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>
+ делал chmod -r /home/user/www

Оффлайн drako

  • Старожил
  • *
  • Сообщений: 1422
    • Просмотр профиля
Re: 403 Forbidden
« Ответ #5 : 07 Апрель 2012, 19:53:30 »
Уберите алиас на doc, и, если не используете cgi, то и на cgi-bin.
Я таки и не понял зачем вам пользователь apache, если сайт лежит в профиле пользователя user, от его имени и запускайте апач, если все сайты лежат у этого пользователя.
Настройки из httpd.conf апач схватит, но в деб системах его заменяет apache2.conf.

Оффлайн anytup

  • Автор темы
  • Любитель
  • *
  • Сообщений: 58
    • Просмотр профиля
Re: 403 Forbidden
« Ответ #6 : 07 Апрель 2012, 20:13:39 »
Удалил, осталось:
<VirtualHost *:80>
ServerAdmin webmaster@localhost

DocumentRoot /home/user/www
<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>
<Directory /home/user/www/>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
</Directory>

ErrorLog ${APACHE_LOG_DIR}/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog ${APACHE_LOG_DIR}/access.log combined


</VirtualHost>
Но по прежнему forbidden. Апач рестартил

Оффлайн drako

  • Старожил
  • *
  • Сообщений: 1422
    • Просмотр профиля
Re: 403 Forbidden
« Ответ #7 : 07 Апрель 2012, 20:31:45 »
Строчек более одной не читаете? Откройте уже /etc/apache2/apache2.conf и найдите директивы User и Group. Строчкой выше будет написано, что переменные для директив правятся в /etc/apache2/envvars.

Оффлайн anytup

  • Автор темы
  • Любитель
  • *
  • Сообщений: 58
    • Просмотр профиля
Re: 403 Forbidden
« Ответ #8 : 07 Апрель 2012, 20:40:16 »
Я же не знал :)
Спасибо, заработало.

 

Страница сгенерирована за 0.071 секунд. Запросов: 25.