Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: HELP! Постоянно выбрасывает на экран авторизации в Ubuntu 11.10!  (Прочитано 1573 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн GG

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Помогите, пожалуйста! Уже неделю мучаюсь - облазил все форумы и блоги, перепробовал тысячу способов - ничего не помогает.

Суть проблемы. Стоит Ubuntu 11.10 и Gnome 3. Во время работы (скорее всего - только когда запущен Google Chrome или Chromium, без них проблем не замечал) в произвольные моменты времени выбрасывает на экран авторизации. Иногда удается поработать 5 минут, иногда 10, иногда 15, иногда 30 секунд - от чего это зависит - до сих пор не могу понять. Выбрасывает когда нахожусь на абсолютно разных сайтах и произвожу абсолютно любые, разные действия.

Переустанавливал несколько раз Хром и Хромиум, пробовал переустановить ядро, заводил нового пользователя и удалял настройки старого, очищал папку temp, очищал настройки программ в домашней папке, переустанавливал Gnome Shell, сбрасывал к исходным настройки Хрома, удалял кучу программ по советам с разных сайтов - НЕ ПОМОГЛО  Н И Ч Е Г О.

При этом заметил, что в оболочке Unity выбрасывает реже, а в Гноме - гораздо чаще. Но там и там выбрасывает.

Пробовал менять настройки авторизации, менять настройки автоотключения и блокировки системы - ничего не помогло.

Что делал перед тем, как начались глюки:
- обновил драйвера nVidia,
- обновил систему через менеджер обновлений
- устанавливал тему Zukitwo
- удалял значок специальных возможностей из Гнома
- добавлял погоду на верхнюю панель
- добавлял кнопку выхода из системы в Гном
- выключал разблокировку ключей в системе
- устанавливал Gnome Tweak

Я не программист, опыт работы в Ubuntu - 1 неделя. Всё что делал - делал наугад по инструкциям на разных сайтах.

Помогите, может кто-то хотя бы на какую-то мысль наведет!

Оффлайн 2Kill

  • Новичок
  • *
  • Сообщений: 41
    • Просмотр профиля
У меня тоже самое, только выбрасывает, везде, независимо от проги и от настроек... Может не выбрасывать целый день, а может раз пять подряд! Сижу в Unity 2D проблем нет, попробуй сделать так же. Мне кажется это скорее всего Compiz глючит и X сервер падает!

Моя тема (в этом же разделе):
https://forum.ubuntu.ru/index.php?topic=183286.0
Взгляните! Там логи прикреплены, может у вас тоже что-нибуть похожее в логах!??

Оффлайн GG

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
А как можно посмотреть логи?

Пользователь решил продолжить мысль 20 Февраль 2012, 20:44:36:
Если бы хоть что-то ещё понимать в этом...

Цитировать
sergei@gg-System-Product-Name:~$ tail -f /var/log/syslog
Feb 20 16:41:41 gg-System-Product-Name rtkit-daemon[1418]: Successfully made thread 4563 of process 4563 (n/a) owned by '1001' high priority at nice level -11.
Feb 20 16:41:41 gg-System-Product-Name rtkit-daemon[1418]: Supervising 7 threads of 2 processes of 2 users.
Feb 20 20:41:41 gg-System-Product-Name pulseaudio[4563]: [pulseaudio] pid.c: Stale PID file, overwriting.
Feb 20 16:41:42 gg-System-Product-Name rtkit-daemon[1418]: Successfully made thread 4568 of process 4563 (n/a) owned by '1001' RT at priority 5.
Feb 20 16:41:42 gg-System-Product-Name rtkit-daemon[1418]: Supervising 8 threads of 2 processes of 2 users.
Feb 20 20:41:42 gg-System-Product-Name pulseaudio[4563]: [pulseaudio] alsa-mixer.c: Volume element Master has 8 channels. That's too much! I can't handle that!
Feb 20 20:41:42  pulseaudio[4563]: last message repeated 6 times
Feb 20 16:41:42 gg-System-Product-Name rtkit-daemon[1418]: Successfully made thread 4572 of process 4572 (n/a) owned by '1001' high priority at nice level -11.
Feb 20 16:41:42 gg-System-Product-Name rtkit-daemon[1418]: Supervising 9 threads of 3 processes of 2 users.
Feb 20 20:41:42 gg-System-Product-Name pulseaudio[4572]: [pulseaudio] pid.c: Daemon already running.

Пользователь решил продолжить мысль 20 Февраль 2012, 23:03:43:
Кажется, подобрался немного к проблеме - выбрасывание происходит в тот момент, как в браузере задействуется звуковая карта. Если страница не использует звуковую карту - всё нормально. Вне браузера - тоже всё ok.

Как я понял, за звук в Ubuntu отвечает компонент ALSA. Звуковая карта у меня стоит отдельная, не встроенная - ASUS Xonar D1. Родных дров под Линукс для неё нет, используются сторонние (из ALSA?).

Так вот, судя по всему, эта самая ALSA не очень дружит с моей Xonar D1.

И как бы их теперь подружить? Пользоваться встроенной звуковой карточкой нет желания - не для этого деньги тратил на хороший звук. Может быть есть альтернативы этой ALSA? Или можно отключить какие-то проблемные модули ALSA? Глюк проявляется только в интернете, из чего делаю вывод, что глючит модуль ALSA для браузера. Как его откатить на старую версию или заменить другим?
« Последнее редактирование: 20 Февраль 2012, 23:03:43 от GG »

Оффлайн 2Kill

  • Новичок
  • *
  • Сообщений: 41
    • Просмотр профиля
Попробуй сделать:

sudo grep -Ri alsa /var/log/

 - эта команда выведет все строки "alsa" (не зависимо от регистра символов)
   из всех логов!

P.S. я не знаю как у вас, но у меня за звук pulseaudio отвечает
(в Ubuntu 11.10 по умолчанию). Поэтому гляньте еще:

sudo grep -Ri pulseaudio /var/log/



Пользователь решил продолжить мысль 22 Февраль 2012, 09:27:02:
Гляньте еще лог X сервера (отвечает за видеовывод): /var/log/Xorg0.log (или /var/log/Xorg.0.log, точно не помню!)

В домашней папке, есть файл (скрытый!): .xsession-errors, в нем отображаются все ошибки, как повиснет, сразу заходите и глядите что там произошло!

Я тоже не сильно в Linux разбираюсь, поначалу грешил что у меня проблемы (если вы мой пост читали!), в аудиосистеме pulseaudio, но как оказалось не в ней!

Еще вы писали:
Цитировать
При этом заметил, что в оболочке Unity выбрасывает реже, а в Гноме - гораздо чаще. Но там и там выбрасывает.
То есть проблема скорее всего не в браузерах а в системе в целом!
(у меня например чаще всего виснет в synaptic, firefox и еще каких-то прогах!)

СОВЕТ: попробуйте посидеть в Хроме (или Хромиусе), в Unyty 2D, если не будет выбрасывать, то однозначно глюки c Compiz и X сервером!
« Последнее редактирование: 22 Февраль 2012, 09:27:02 от 2Kill »

Оффлайн GG

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
В общем - пришлось решить проблему кардинально - переустановил Ubuntu начисто из-под Windows. Глюки вроде пропали. По-крайней мере - уже часа 3 система работает без выбрасываний, с разными программами, браузерами и на разных сайтах.

Первоначально Ubuntu не нашла драйверов для моей звуковой карты и пыталась работать через встроенную, но после ручного отключения встроенной звуковой и установки ALSA - всё нашлось и заработало.

Оффлайн Васька

  • Новичок
  • *
  • Сообщений: 15
    • Просмотр профиля
Та-же самая проблема - ничего не помогает!
Подскажите, в чем разница между этими двумя видео?
1) http://www.youtube.com/watch?v=8ySUHy7hh9Q&feature=relmfu
2) http://www.youtube.com/watch?v=psAx2G1_ZiM&feature=related
1 и подобные ему могу смотреть нормально.
2 Выбрасывает из системы
Ubuntu 11.04   Firefox 12

Оффлайн senechal

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Вот здесь подсказали решение:
http://linuxforum.ru/viewtopic.php?id=23435

Цитировать
УРА! Всё получилось. Всё было гораздо проще) Всё лежало перед глазами)):
xauth:  error in locking authority file /home/sh/.Xauthority
xauth:  error in locking authority file /home/sh/.Xauthority
РЕШЕНИЕ:
ALT+CTRL+F1 or ALT+CTRL+F2 \\ Ubuntu 12.04
sudo service lightdm stop \\ Ubuntu 12.04
cp /home/ВашеИмя/.Xauthority /home/ВашеИмя/.Xauthority_RENAME \\ на всякий случай
sudo эрэм эрэф /home/ВашеИмя/.Xauthority
sudo reboot

 

Страница сгенерирована за 0.057 секунд. Запросов: 24.