Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Проблемы с зависимостями  (Прочитано 922 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн myr4ik07

  • Автор темы
  • Участник
  • *
  • Сообщений: 239
    • Просмотр профиля
Проблемы с зависимостями
« : 25 Февраль 2012, 00:49:53 »
Здравствуйте, банально но не могу подужать, решить проблему с зависимостями.
Ставил openjdk и то ли не правильно удалил, я уже не помню, но теперь при обновлении
apt-get upgradeполучаю

Возможно, для исправления этих ошибок вы захотите воспользоваться `apt-get -f install'.
Пакеты, имеющие неудовлетворённые зависимости:
 nixnote:i386 : Зависит: openjdk-6-jre:i386 но он не установлен или
                                openjdk-6-jdk:i386 но он не установлен или
                                sun-java6-jdk:i386 но он не может быть установлен или
                                sun-java6-jre:i386 но он не может быть установлен или
                                java6-sdk:i386 или
                                java6-runtime:i386 или
                                default-jre:i386 но он не установлен
E: Неудовлетворённые зависимости. Попытайтесь использовать -f.
делая, что предлагается но в итоге все ровно обновится нормально не могу.
Поделитесь, как решить проблему? :idiot2:

Оффлайн Olej

  • Забанен
  • Активист
  • *
  • Сообщений: 884
    • Просмотр профиля
Re: Проблемы с зависимостями
« Ответ #1 : 25 Февраль 2012, 02:01:41 »
Здравствуйте, банально но не могу подужать, решить проблему с зависимостями.
Ставил openjdk и то ли не правильно удалил, я уже не помню, но теперь при обновлении
apt-get upgradeполучаю

Возможно, для исправления этих ошибок вы захотите воспользоваться `apt-get -f install'.
Пакеты, имеющие неудовлетворённые зависимости:
 nixnote:i386 : Зависит: openjdk-6-jre:i386 но он не установлен или
                                openjdk-6-jdk:i386 но он не установлен или
                                sun-java6-jdk:i386 но он не может быть установлен или
                                sun-java6-jre:i386 но он не может быть установлен или
                                java6-sdk:i386 или
                                java6-runtime:i386 или
                                default-jre:i386 но он не установлен
E: Неудовлетворённые зависимости. Попытайтесь использовать -f.
делая, что предлагается но в итоге все ровно обновится нормально не могу.
Поделитесь, как решить проблему? :idiot2:

у вас nixnote:i386 хочет (и, наверное, не только он захочет) хоть какую установленную Java-машину + и перечисляет альтернативы, которые его устроили бы ... а у вас никакой Java не установлено.

P.S.
см.: https://forum.ubuntu.ru/index.php?topic=184120.0

Оффлайн myr4ik07

  • Автор темы
  • Участник
  • *
  • Сообщений: 239
    • Просмотр профиля
Re: Проблемы с зависимостями
« Ответ #2 : 27 Февраль 2012, 10:32:50 »
Решение проблемы, увы, там так и не нашел.
Смысл в том, что при любой команде, типа
update
install
upgrade
я получаю выше ошибку.
Как быть в таком случаи?

Пользователь решил продолжить мысль 27 Февраль 2012, 10:36:59:
Ребят, все было элементарно, даже стыдно говорить, в ошибке все было с намеком.
Нужно было удалить
Цитировать
nixnote
что бы все заработало.
Стыдно, что создал тему.
« Последнее редактирование: 27 Февраль 2012, 10:36:59 от myr4ik07 »

 

Страница сгенерирована за 0.063 секунд. Запросов: 25.