Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Ошибка при обновлении на сервере  (Прочитано 1622 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн savenko

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Ошибка при обновлении на сервере
« : 27 Февраль 2012, 01:15:09 »
Здравствуйте!
Обновляюсь с Ubuntu 10.04 -minimal  до 11.10 поэтапно.
С 10.10 на 11.04 не могу обновиться выдает ошибку:
Errors were encountered while processing:
 initramfs-tools
 plymouth

ввожу

apt-get install initramfs-tools
выдает
Reading package lists... Done
Building dependency tree
Reading state information... Done
initramfs-tools is already the newest version.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 plymouth : Depends: libdrm-nouveau1a (>= 2.4.23) but it is not going to be installed
            Depends: libplymouth2 (= 0.8.2-2ubuntu22) but 0.8.2-2ubuntu5 is to be installed
            Recommends: plymouth-theme-ubuntu-text but it is not going to be installed or
                        plymouth-theme
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
Как побороть?

Оффлайн Stay_Strong

  • Активист
  • *
  • Сообщений: 611
  • Life in Love... by Romich)
    • Просмотр профиля
    • Натяжные потолки Саранск
Re: Ошибка при обновлении на сервере
« Ответ #1 : 27 Февраль 2012, 01:16:42 »
он просит ввести
sudo apt-get -f install
Искренни укоризны от любящего, и лживы поцелуи ненавидящего.

Оффлайн savenko

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Ошибка при обновлении на сервере
« Ответ #2 : 27 Февраль 2012, 01:19:37 »
Ввожу
sudo apt-get -f installНажимаю Y (Да)
Потом пытаюсь снова повторить комманду "apt-get install initramfs-tools"и все то же самое.

Пользователь решил продолжить мысль 27 Февраль 2012, 01:27:42:
Вот все ошибки:
dpkg-divert: error: `diversion of /sbin/udevadm to /sbin/udevadm.upgrade by fake-udev' clashes with `local diversion of /sbin/udevadm to /sbin/udevadm.upgrade'
dpkg: error processing /var/cache/apt/archives/udev_167-0ubuntu3_i386.deb (--unpack):
 subprocess new pre-installation script returned error exit status 2
No apport report written because MaxReports is reached already
                                                              dpkg-divert: error: mismatch on package
  when removing `diversion of /sbin/udevadm to /sbin/udevadm.upgrade by fake-udev'
  found `local diversion of /sbin/udevadm to /sbin/udevadm.upgrade'
dpkg: error while cleaning up:
 subprocess new post-removal script returned error exit status 2
Errors were encountered while processing:
 /var/cache/apt/archives/udev_167-0ubuntu3_i386.deb
Exception during pm.DoInstall():  E:Sub-process /usr/bin/dpkg returned an error code (1)

Could not install the upgrades

The upgrade has aborted. Your system could be in an unusable state. A
recovery will run now (dpkg --configure -a).

Please report this bug against the 'update-manager' package and
include the files in /var/log/dist-upgrade/ in the bug report.
E:Sub-process /usr/bin/dpkg returned an error code (1)

dpkg: dependency problems prevent configuration of initramfs-tools:
 initramfs-tools depends on udev (>= 147~-5); however:
  Package udev is not installed.
dpkg: error processing initramfs-tools (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of plymouth:
 plymouth depends on libdrm-nouveau1a (>= 2.4.23); however:
  Package libdrm-nouveau1a is not installed.
 plymouth depends on libplymouth2 (= 0.8.2-2ubuntu22); however:
  Version of libplymouth2 on system is 0.8.2-2ubuntu5.
 plymouth depends on udev (>= 166-0ubuntu4); however:
  Package udev is not installed.
 plymouth depends on initramfs-tools; however:
  Package initramfs-tools is not configured yet.
dpkg: error processing plymouth (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 initramfs-tools
 plymouth
« Последнее редактирование: 27 Февраль 2012, 01:27:42 от savenko »

Оффлайн gregory5

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5085
    • Просмотр профиля
Re: Ошибка при обновлении на сервере
« Ответ #3 : 27 Февраль 2012, 01:43:05 »
Цитировать
The upgrade has aborted. Your system could be in an unusable state. A
recovery will run now (dpkg --configure -a).

Оффлайн savenko

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Ошибка при обновлении на сервере
« Ответ #4 : 27 Февраль 2012, 01:45:00 »
Ввел команду. Ответ:
root@beststorer:~# dpkg --configure -a
dpkg: dependency problems prevent configuration of initramfs-tools:
 initramfs-tools depends on udev (>= 147~-5); however:
  Package udev is not installed.
dpkg: error processing initramfs-tools (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of plymouth:
 plymouth depends on libdrm-nouveau1a (>= 2.4.23); however:
  Package libdrm-nouveau1a is not installed.
 plymouth depends on libplymouth2 (= 0.8.2-2ubuntu22); however:
  Version of libplymouth2 on system is 0.8.2-2ubuntu5.
 plymouth depends on udev (>= 166-0ubuntu4); however:
  Package udev is not installed.
 plymouth depends on initramfs-tools; however:
  Package initramfs-tools is not configured yet.
dpkg: error processing plymouth (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 initramfs-tools
 plymouth

Пользователь решил продолжить мысль 27 Февраль 2012, 01:46:50:
root@beststorer:~# apt-get install udev
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 plymouth : Depends: libdrm-nouveau1a (>= 2.4.23) but it is not going to be installed
            Depends: libplymouth2 (= 0.8.2-2ubuntu22) but 0.8.2-2ubuntu5 is to be installed
            Recommends: plymouth-theme-ubuntu-text but it is not going to be installed or
                        plymouth-theme
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
« Последнее редактирование: 27 Февраль 2012, 01:46:50 от savenko »

Оффлайн gregory5

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5085
    • Просмотр профиля
Re: Ошибка при обновлении на сервере
« Ответ #5 : 27 Февраль 2012, 01:50:58 »
Там оно просит пакеты и зависимости, попробуйте дать ему это
странно, плимуты с новеау на сервере вам зачем?

Оффлайн savenko

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Ошибка при обновлении на сервере
« Ответ #6 : 27 Февраль 2012, 01:58:05 »
Там оно просит пакеты и зависимости, попробуйте дать ему это
странно, плимуты с новеау на сервере вам зачем?
Не зачем я только обновляю то что устанавливается на VDS хостинге.
Как это сделать? (Там оно просит пакеты и зависимости, попробуйте дать ему это?)

Пользователь решил продолжить мысль 27 Февраль 2012, 02:04:48:
Вот что еще вылезает :
Цитировать
No apport report written because MaxReports is reached already
                                                              dpkg-divert: error: mismatch on package
  when removing `diversion of /sbin/udevadm to /sbin/udevadm.upgrade by fake-udev'
  found `local diversion of /sbin/udevadm to /sbin/udevadm.upgrade'
dpkg: error while cleaning up:
 subprocess new post-removal script returned error exit status 2
Errors were encountered while processing:
 /var/cache/apt/archives/udev_167-0ubuntu3_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Пользователь решил продолжить мысль 27 Февраль 2012, 10:13:07:
Решение нашел:
Цитировать
dpkg-divert --remove '/sbin/udevadm'

Пользователь решил продолжить мысль 27 Февраль 2012, 11:39:24:
Ошибка при обновлении:
An unresolvable problem occurred while calculating the upgrade:
E:Error, pkgProblemResolver::Resolve generated breaks, this may be
caused by held packages.

This can be caused by:
* Upgrading to a pre-release version of Ubuntu
* Running the current pre-release version of Ubuntu
* Unofficial software packages not provided by Ubuntu


Пользователь решил продолжить мысль 27 Февраль 2012, 11:49:19:
Цитировать
xserver-xorg-video-nouveau
не помогает
« Последнее редактирование: 27 Февраль 2012, 11:49:19 от savenko »

 

Страница сгенерирована за 0.076 секунд. Запросов: 25.