Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Решено. Emacs. Не всегда корректно срабатывает Caps Lock.  (Прочитано 736 раз)

0 Пользователей и 1 Гость просматривают эту тему.

yura_n

  • Автор темы
  • Гость
Дело вот в чем. Изучаю Emacs. Пишу например:
printf ("\nЭто тестовое сообщение);после символов \n нажимаю Caps Lock, ожидая ввода в верхнем регистре, а получаю - первый символ (буква "Э") в нижнем, а прочие идут уже с большой, если не отключать Caps Lock. Но мне не нужно "эТО ТЕСТОВОЕ СООБЩЕНИЕ". ;D Я хочу наоборот. :) Что за полтергейст? Как это победить? Google здесь не помогает.
P.S. Caps Lock так реагирует не на все символы, а только на эти "хъжэбю".
« Последнее редактирование: 09 Март 2012, 08:04:44 от yura_n »

andrey_p

  • Автор темы
  • Гость
Для переключения раскладок в Emacs надо использовать емаксовскую переключалку раскладок, не системную. По умолчанию - это Ctrl-\

Emacs 24 (это бета) самостоятельно (в Ubuntu) определяет язык для переключения, в 23 возможно надо выбрать Options/Select Input Method/...  Выбирать языковое окружение не надо - это для однобайтовых кодировок, не для utf-8.

Совмещение системной и емаксовской переключалок - для меня больная тема. В Интернете есть решение (использовать ibus), но для меня не сработало (при быстрой печати пропускаются символы).

yura_n

  • Автор темы
  • Гость
Для переключения раскладок в Emacs надо использовать емаксовскую переключалку раскладок, не системную. По умолчанию - это Ctrl-\
С системной таких проблем нет. Проблема именно с емаксовской переключалкой. Она некорректно работает с Caps Lock.

Пользователь решил продолжить мысль 09 Март 2012, 08:03:30:
Проблема решилась установкой Emacs без гуев. В таком варианте без особых проблем можно пользоваться системной переключалкой.
« Последнее редактирование: 09 Март 2012, 08:04:21 от yura_n »

 

Страница сгенерирована за 0.091 секунд. Запросов: 23.