Форум русскоязычного сообщества Ubuntu


Автор Тема: SciLab, проблема при построении графиков  (Прочитано 1395 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн __Steiner__

  • Автор темы
  • Новичок
  • *
  • Сообщений: 30
  • Ubuntu 12.04 с Unity
    • Просмотр профиля
Использую ОС Ubuntu 11.10 x86 с графической системой Unity. По необходимости поставил программу для математических рассчетов SciLab 5.3.3. Проблема в том, что при попытке построить график через команду Plot SciLab зависает, одно из ядер процессора грузится на 100%. Окно Plot'а ничего не показывает, нельзя зайти в его меню, но можно свободно переключаться между окнами Plot и SciLab.

Может кто знает как решить данную проблему?
Нет плохих ОС, есть кривые руки...
Не знаешь что делать? Делай что-нибудь! (с) Е.Ю.Куликов

Оффлайн kaspe

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Re: SciLab, проблема при построении графиков
« Ответ #1 : 11 Март 2012, 12:33:46 »
Та же самая проблема. Только внесу уточнение, такое появилось только когда обновился до версии 11.10.

Оффлайн __Steiner__

  • Автор темы
  • Новичок
  • *
  • Сообщений: 30
  • Ubuntu 12.04 с Unity
    • Просмотр профиля
Re: SciLab, проблема при построении графиков
« Ответ #2 : 13 Март 2012, 21:17:07 »
Так, понятно что никто не знает как именно это исправить. Тогда может быть есть какие-то предположения, с чем может быть связана ошибка?
Нет плохих ОС, есть кривые руки...
Не знаешь что делать? Делай что-нибудь! (с) Е.Ю.Куликов

Оффлайн dyadyaMisha

  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
    • дядяМиша.ру
Re: SciLab, проблема при построении графиков
« Ответ #3 : 22 Март 2012, 07:24:54 »
Если запустить в терминале
scilab
 и если ругается на: module_patch: pixmap, попробуйте установить pixbuf:

sudo apt-get install gtk2-engines-pixbuf
У меня дома заработало, но вот в другом месте не помогло видимо что-то ещё.
Продолжение следует... :)
« Последнее редактирование: 22 Март 2012, 07:26:39 от dyadyaMisha »

Оффлайн __Steiner__

  • Автор темы
  • Новичок
  • *
  • Сообщений: 30
  • Ubuntu 12.04 с Unity
    • Просмотр профиля
Re: SciLab, проблема при построении графиков
« Ответ #4 : 23 Март 2012, 13:49:26 »
В том-то и дело, что pixbuf установлен, и scilab не ругается на отсутсвие чего бы то нибыло. Просто неправильно работает функция plot
Нет плохих ОС, есть кривые руки...
Не знаешь что делать? Делай что-нибудь! (с) Е.Ю.Куликов

 

Страница сгенерирована за 0.058 секунд. Запросов: 25.