Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Не работает COM-порт (нет драйвера для контроллера?)  (Прочитано 5302 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн IVT

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Добрый день. Имеется компьютер с Сom-портом. На компьютере установлена ubuntu 10.04, а также виндоус(ХР). В виндоусе ком-порт работает (посылались команды и приходили верные ответы от устройства),в диспетчере устройств com-порт ассоциируется с LPC Interface Controller.
Что происходит в ubuntu - ком-порты определяются,но операции записи-чтения не дают результата. Проверял : 1) утилитой minicom - не происходит ничего при инициализации 2) serial port terminal (gtkterm) из центра приложений Ubuntu - тоже черный экран и всё.
Важный момент - рядом стоит другой компьютер, с той же ubuntu, но совершенно другой конфигурацией самого компьютера - там все операции с com-портом проходили успешно (нуль-модемный кабель в слот одним концом, на другом соединить 2 и 3 контакт - как minicom, так и serial port terminal записывают и читают правильные байты. И с тем устройством ,к-ое в виндоус работало, здесь тоже проблем не возникло).
Результаты команд :
(Нажмите, чтобы показать/скрыть)
это навело на мысль, что возможно нет драйвера для интеловского LPC Controller (см. lspci).
Длительным поиском в гугле драйвера под линукс для данного устройства не нашел.
в linux kernel driver database данное устройство (8086:2815) упоминается лишь раз (модуль iTCO_wdt - но он исп. только для таймера, на всякий случай modprobe-ом подключил его - изменений не принесло в работу com-порта)
 ВОзможно не там и не так искал..или действительно нет драйвера для данного устройства ...или проблема не в нём все-таки.
Заранее спасибо, надеюсь на помощь
« Последнее редактирование: 16 Апрель 2016, 20:13:26 от Alex_ander »

Оффлайн kobzar

  • Активист
  • *
  • Сообщений: 253
  • ooOOOooo
    • Просмотр профиля
вставьте модуль в соседний комп там где все работает - и получите ответы на все ваши вопросы сразу !
Кто понял жизнь, тот не спешит...

Оффлайн IVT

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
не совсем пойму, что имеете в виду под словом "модуль"?

Оффлайн kobzar

  • Активист
  • *
  • Сообщений: 253
  • ooOOOooo
    • Просмотр профиля
я ошибся - почемуто подумал что у вас компорт отдельным модулем.
Хотя странно - если вы его в системе видите... может он умерацию другую получает ? попробуйте попросить напримет TTYS0..1
Кто понял жизнь, тот не спешит...

Оффлайн IVT

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Пробовал все ttyS*

Пользователь решил продолжить мысль 03 Апрель 2012, 14:39:18:
забыл указать фрагмент dmidecode со второго компьютера

(Нажмите, чтобы показать/скрыть)
« Последнее редактирование: 16 Апрель 2016, 20:13:45 от Alex_ander »

Оффлайн honeybeer

  • Любитель
  • *
  • Сообщений: 92
    • Просмотр профиля
В биосе порт не отключен случаем?
ASUS Sandy/Ivy Bridge + PCI = Nobody cares
Ciao mina-san

Оффлайн IVT

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Нет, в биос смотрел, не отключены

Оффлайн IVT

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Да, с проблемой разобраться удалось - причину выяснить так и не удалось, но работа с СОМ-портом на том компьютере была запущена путем непосредственного обращения к стандартным регистрам порта (подробное задание скорости, всяческих битов чтения/записи итп)

 

Страница сгенерирована за 0.078 секунд. Запросов: 25.