Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: 12.04 проблемы с обновлениями  (Прочитано 1498 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн dfm

  • Автор темы
  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
12.04 проблемы с обновлениями
« : 13 Апрель 2012, 17:01:51 »
Привет!
Пользуюсь 12.04 x64.
Хотел поставить xmind из deb пакета, но по невнимательности скачал и запустил версию под i386. Установка закончилась с ошибкой, а в менеджере обновлений висит "OpenJDK окружение Java, использующее Hotspot JIT. openjdk-6-jre:i386(Новая установка)".
при попытке начать установку обновлений появляется сообщение об ошибке:
Цитировать
Система пакетов повреждена

Если вы используете сторонние источники приложений, отключите их, поскольку они являются частым
источником проблем. После этого выполните в терминале следующую команду: apt-get install -f


Следующие пакеты имеют неудовлетворённые зависимости:

icedtea-netx:i386: Depends: icedtea-netx-common (>= 1.2-2ubuntu1) но 1.2-2ubuntu1 уже установлен
                   Depends: openjdk-7-jre но он не установлен
libatk-wrapper-java-jni:i386: Depends: libatk1.0-0 (>= 1.18.0) но 2.4.0-0ubuntu1 уже установлен
                              Depends: libc6 (>= 2.4) но 2.15-0ubuntu6 уже установлен
                              Depends: libglib2.0-0 (>= 2.31.2) но 2.32.1~git20120404.88781d59-0ubuntu1~12.04~ricotz0 уже установлен
                              Depends: libgtk2.0-0 (>= 2.12.0) но 2.24.10-0ubuntu6 уже установлен
                              Depends: libatk-wrapper-java (>= 0.30.4-0ubuntu2) но 0.30.4-0ubuntu2 уже установлен


при попытке ввести в терминале apt-get install -f:
Цитировать
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  language-pack-de-base language-pack-kde-de-base kde-l10n-de kde-l10n-ru kde-l10n-vi language-pack-vi-base language-pack-kde-vi-base language-pack-kde-crh-base language-pack-kde-rw-base language-pack-zh-hant-base
  language-pack-kde-zh-hans-base language-pack-kde-ru-base language-pack-kde-crh language-pack-ta-base language-pack-kde-ta-base language-pack-ps-base language-pack-kde-ps-base firefox-locale-zh-hans firefox-locale-zh-hant
  firefox-locale-de language-pack-kde-de language-pack-kde-en language-pack-kde-hy language-pack-kde-hy-base language-pack-kde-ps kde-l10n-engb firefox-locale-ta language-pack-kde-ta language-pack-kde-ru language-pack-kde-rw
  firefox-locale-vi language-pack-kde-vi language-pack-kde-zh-hant-base language-pack-zh-hans-base kde-l10n-zhcn language-pack-zh-hans language-pack-zh-hant language-pack-kde-zh-hans language-pack-kde-zh-hant kde-l10n-zhtw
  language-pack-kde-en-base language-pack-de language-pack-ps language-pack-ta language-pack-vi
Для их удаления используйте «apt-get autoremove».
Будут установлены следующие дополнительные пакеты:
  openjdk-6-jre:i386
Предлагаемые пакеты:
  icedtea-plugin:i386
НОВЫЕ пакеты, которые будут установлены:
  openjdk-6-jre:i386
обновлено 0, установлено 1 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
не установлено до конца или удалено 1 пакетов.
Необходимо скачать 0 B/232 kB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 706 kB.
Хотите продолжить [Д/н]?
(Чтение базы данных ... на данный момент установлено 350565 файлов и каталогов.)
Распаковывается пакет openjdk-6-jre:i386 (из файла .../openjdk-6-jre_6b24-1.11.1-4ubuntu1_i386.deb)...
dpkg: не удалось обработать параметр /var/cache/apt/archives/openjdk-6-jre_6b24-1.11.1-4ubuntu1_i386.deb (--unpack):
 './usr/share/applications/openjdk-6-policytool.desktop' is different from the same file on the system
Обрабатываются триггеры для desktop-file-utils ...
Обрабатываются триггеры для gnome-menus ...
Обрабатываются триггеры для bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/openjdk-6-jre_6b24-1.11.1-4ubuntu1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Подскажите пожалуйста как этот пакет удалить из менеджера обновлений?

Оффлайн Nikki1993

  • Заслуженный пользователь
  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 3261
  • Owner of Dell XPS 13 Developer Edition :D
    • Просмотр профиля
Re: 12.04 проблемы с обновлениями
« Ответ #1 : 13 Апрель 2012, 17:18:11 »
Почистите кэш менеджера обновлений утилитой Ubuntu tweak tool.
sudo add-apt-repository ppa:tualatrix/ppasudo apt-get update
Цитировать
sudo apt-get install ubuntu-tweak
Разобраться вообще не составляет труда. Вам нужно открыть Janitor и поставить галочки напротив всех возможных параметров. После чего нажать clean справа внизу и удалить все не нужные системе файлы.
+ рекомендую после всего почистить систему командой
sudo apt-get autoremoveтак как у вас есть пакеты которые более не используются системой, но установлены.

По поводу JDK Java установите 7 версию так как у вас пакеты установлены именно для нее, что и вызывает ошибку зависимостей. В центре приложений введите Java 7 и установите пакет OpenJDK Java 7 Runtime и после попробуйте установить свою программу.
First i was like :0 Then i was like :D But now i am like(╯°□°)╯︵ ┻━┻
http://www.abload.de/img/banner_505uxa.png

Оффлайн dfm

  • Автор темы
  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
Re: 12.04 проблемы с обновлениями
« Ответ #2 : 13 Апрель 2012, 18:34:21 »
Почистите кэш менеджера обновлений утилитой Ubuntu tweak tool.
любая попытка установить хоть что то вызывает приведенную выше ошибку
+ рекомендую после всего почистить систему командой
sudo apt-get autoremove
не помогает и sudo apt-get autoclear тоже

По поводу JDK Java установите 7 версию так как у вас пакеты установлены именно для нее, что и вызывает ошибку зависимостей. В центре приложений введите Java 7 и установите пакет OpenJDK Java 7 Runtime и после попробуйте установить свою программу.

центр приложений при запуске пишет "Элементы не могут быть установлены или удалены пока не будет восстановлен каталог пакетов"

Оффлайн vovan--vovan

  • Активист
  • *
  • Сообщений: 342
    • Просмотр профиля
Re: 12.04 проблемы с обновлениями
« Ответ #3 : 13 Апрель 2012, 21:42:49 »
Попробуй для начала изменить в центре приложений источник приложений с сервера Российской федерации на основной сервер и загрузить менеджер пакетов synaptic, а затем открыв менеджер пакетов найти свои неудачные пакеты программ и поставить галочку на удаление этих пакетов полностью.

Оффлайн dfm

  • Автор темы
  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
Re: 12.04 проблемы с обновлениями
« Ответ #4 : 14 Апрель 2012, 00:31:53 »
Попробуй для начала изменить в центре приложений источник приложений с сервера Российской федерации на основной сервер
это помогло, подвисший пакет исчез, спасибо

Оффлайн vovan--vovan

  • Активист
  • *
  • Сообщений: 342
    • Просмотр профиля
Re: 12.04 проблемы с обновлениями
« Ответ #5 : 14 Апрель 2012, 10:34:18 »
Попробуй для начала изменить в центре приложений источник приложений с сервера Российской федерации на основной сервер
это помогло, подвисший пакет исчез, спасибо
Да, пожалуйста. Мы рады за тебя.

 

Страница сгенерирована за 0.066 секунд. Запросов: 25.