Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: apt-get поломался  (Прочитано 2601 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн saber

  • Автор темы
  • Участник
  • *
  • Сообщений: 224
    • Просмотр профиля
    • Блог админа
apt-get поломался
« : 20 Апрель 2012, 11:11:15 »
День добрый, всё началось с пакета mdadm я его снёс уже 3 раза переустанавливал что только не делал. беда вот такая осталась

# dpkg --configure -a
Настраивается пакет samba (2:3.5.6~dfsg-3squeeze7) ...
dpkg: не удалось обработать параметр samba (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 1
Настраивается пакет module-init-tools (3.12-2) ...
dpkg: не удалось обработать параметр module-init-tools (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 1
dpkg: зависимости пакетов не позволяют настроить пакет linux-image-2.6.32-5-amd64:
 linux-image-2.6.32-5-amd64 зависит от module-init-tools, однако:
  Пакет module-init-tools пока не настроен.
dpkg: не удалось обработать параметр linux-image-2.6.32-5-amd64 (--configure):
 проблемы зависимостей -- оставляем не настроенным
Настраивается пакет winbind (2:3.5.6~dfsg-3squeeze7) ...
dpkg: не удалось обработать параметр winbind (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 1
dpkg: зависимости пакетов не позволяют настроить пакет swat:
 swat зависит от samba (= 2:3.5.6~dfsg-3squeeze7), однако:
  Пакет samba пока не настроен.
dpkg: не удалось обработать параметр swat (--configure):
 проблемы зависимостей -- оставляем не настроенным
При обработке следующих пакетов произошли ошибки:
 samba
 module-init-tools
 linux-image-2.6.32-5-amd64
 winbind
 swat

как быть не знаю :( что не нравится тоже не понимаю

Пользователь решил продолжить мысль 20 Апрель 2012, 11:15:29:
3 дня маялся в итоге удалил скрипты

/etc/init.d/wmware
/etc/init.d/haspd

в итоге всё вроде прошло

Жесть какая а, как эти скрипты влияют то на установку пакетов о_О

Пользователь решил продолжить мысль 20 Апрель 2012, 11:17:34:
Хотя нет вру не починил


# aptitude install munin munin-node
Следующие НОВЫЕ пакеты будут установлены:
  munin munin-node
0 пакетов обновлено, 2 установлено новых, 0 пакетов отмечено для удаления, и 0 пакетов не обновлено.
Необходимо получить 602 kB архивов. После распаковки 2 421 kB будет занято.
Получить:1 http://ftp.ru.debian.org/debian/ squeeze/main munin all 1.4.5-3 [210 kB]
Получить:2 http://ftp.ru.debian.org/debian/ squeeze/main munin-node all 1.4.5-3 [392 kB]
Получено 602 kБ в 2с (264 kБ/с)
Выбор ранее не выбранного пакета munin.
(Чтение базы данных ... на данный момент установлено 45332 файла и каталога.)
Распаковывается пакет munin (из файла .../archives/munin_1.4.5-3_all.deb)...
Выбор ранее не выбранного пакета munin-node.
Распаковывается пакет munin-node (из файла .../munin-node_1.4.5-3_all.deb)...
Обрабатываются триггеры для man-db ...
Настраивается пакет munin (1.4.5-3) ...
No apache MPM package installed
Настраивается пакет munin-node (1.4.5-3) ...
Initializing new plugins..done.
Restarting munin-node..invoke-rc.d: unknown initscript, /etc/init.d/munin-node not found.
dpkg: не удалось обработать параметр munin-node (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 100
configured to not write apport reports
                                      При обработке следующих пакетов произошли ошибки:
 munin-node
E: Sub-process /usr/bin/dpkg returned an error code (1)
Не удалось установить пакет. Попытка восстановить:
Настраивается пакет munin-node (1.4.5-3) ...
Initializing new plugins..done.
Restarting munin-node..invoke-rc.d: unknown initscript, /etc/init.d/munin-node not found.
dpkg: не удалось обработать параметр munin-node (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 100
При обработке следующих пакетов произошли ошибки:
 munin-node

Пользователь решил продолжить мысль 20 Апрель 2012, 11:21:53:
удалем пакеты из /var/cache/apt
удаляем все следы мунина
aptitude purge munin munin-node

после чего устанавливается
« Последнее редактирование: 20 Апрель 2012, 11:21:53 от saber »
odmin4eg.ru - Мои шпаргалки по ubuntu

Оффлайн Rabinovitch

  • Новичок
  • *
  • Сообщений: 31
    • Просмотр профиля
Re: apt-get поломался
« Ответ #1 : 27 Март 2013, 06:46:45 »
Аналогичная проблема. Чего только не делал.  :( Переустановить, конечно, можно, система далеко не критической важности, но хочется true way всё-таки... Уже и в файле status удалял информацию по проблемным пакетам, чистил кэш, обновлял списки пакетов (сменив сервер притом) - ни в какую. Ни purge, ни install -f, ни какие другие очевидные методы. Дожили. Система отказывается подчиниться прямому приказу удалить (!!!) пакеты. Восстание машин, ёлки.

chemtech

  • Гость
Re: apt-get поломался
« Ответ #2 : 27 Март 2013, 07:00:55 »
saber,
Rabinovitch,
Что-то вы сломали в системе, явно.

Говорит же нет файла:
Restarting munin-node..invoke-rc.d: unknown initscript, /etc/init.d/munin-node not found.

Оффлайн artifactor

  • Старожил
  • *
  • Сообщений: 1769
    • Просмотр профиля
    • Leaf Watoru's notes
Re: apt-get поломался
« Ответ #3 : 27 Март 2013, 08:02:28 »
Лично я тоже поломал apt. Если через него хочу что-то удалить, то предлагает снести сразу всю систему.
Попробуйте программы через синаптик поставить.
Решить проблему с аптом можно, но, думаю, тут вряд ли есть такие гуру. Есть шансы найти ответ на зарубежных форумах.
Xubuntu 16.04 x64
Обои для рабочего стола и Space Ambient

Оффлайн БТР

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 5367
    • Просмотр профиля
Re: apt-get поломался
« Ответ #4 : 27 Март 2013, 08:14:41 »
Лично я тоже поломал apt. Если через него хочу что-то удалить, то предлагает снести сразу всю систему.
а осознать вывод, почему он это хочет сделать, не судьба? Скорее всего, удалили какой-то метапакет, и теперь apt хочет удалить "лишние" пакеты, или конфликт версий.

Решить проблему с аптом можно, но, думаю, тут вряд ли есть такие гуру. Есть шансы найти ответ на зарубежных форумах.
Ага, там народ в основном спрашивает, как поменять обои и установить новые значки. Чтобы разобраться с пакетной системой, не нужно быть гуру - надо всего лишь прочитать, что хочет система. К сожалению, у многих и на это разума не хватает.

Оффлайн artifactor

  • Старожил
  • *
  • Сообщений: 1769
    • Просмотр профиля
    • Leaf Watoru's notes
Re: apt-get поломался
« Ответ #5 : 27 Март 2013, 08:45:10 »
БТР, я удалял все файлы, связанные с вайном(т.к. ставил через исходники кучу версий и поломал). думаю, что задел файл индекса апт. Думал, что после апгрейда на стабильную версию это пропадёт - ан, нет!

Насчёт зарубежных форумов могу сказать следующее: английский язык более прост. По английски вопрос задать можно только одним способом. По-русски я могу страницами придумывать запросы в гугл на один и тот же вопрос.

И вообще имел ввиду не сами форумы, а mailing lists, т.е. где обычно рассылаются новости и кто-то задаёт вопросы разработчикам.
Xubuntu 16.04 x64
Обои для рабочего стола и Space Ambient

Оффлайн asterisk1

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Re: apt-get поломался
« Ответ #6 : 11 Март 2015, 14:35:46 »
sudo apt-get remove --purge samba-common
sudo apt-get remove --purge samba
sudo apt-get install samba
и все начинает работать

Оффлайн peregrine

  • FSM
  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 7169
  • Gentoo x64 Ubuntu 16.04.1 x64
    • Просмотр профиля
Re: apt-get поломался
« Ответ #7 : 11 Март 2015, 18:40:10 »
Поскольку тема датируется 2013 годом - закрыто.

 

Страница сгенерирована за 0.115 секунд. Запросов: 25.