Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: проблемка с grub  (Прочитано 1635 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн xorizont

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
проблемка с grub
« : 28 Апрель 2012, 00:17:32 »
Установил я Ubuntu 12.04
Рядом стоит windows 7.
Решил отредактировать окно запуска grub, а именно убрать лишние пункты. Скачал grub customizer. Вроде все поменял как надо. Все работает. Но есть два НО:
1) при запуске убунты вытащил такое сообщение "ошибка: unknown command "gfxmode". Для продолжения нажмите любую клавишу"
2) исчез сплэш выключения в убунте. Вместо него бежит текст...

Можно как нить это исправить?
Заранее спасибо

Оффлайн avi9526

  • Активист
  • *
  • Сообщений: 618
  • ахтыжъёшкинкот
    • Просмотр профиля
    • Блог av9526
Re: проблемка с grub
« Ответ #1 : 28 Апрель 2012, 01:33:34 »
1) Приложи вывод команды
cat /etc/default/grubвыполненной в терминале (только плиз поставь тег "код" когда тут постить будешь)
2) Советую не пользоваться подобными настройщиками, мона траблов схлопотать немерено...
Ubuntu 14.10

Оффлайн xorizont

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: проблемка с grub
« Ответ #2 : 28 Апрель 2012, 07:19:07 »
вот:
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT="0"
#GRUB_HIDDEN_TIMEOUT="0"
GRUB_HIDDEN_TIMEOUT_QUIET="true"
GRUB_TIMEOUT="10"
GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL="console"

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE="1440x900x24"

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID="true"

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

export GRUB_MENU_PICTURE="/home/vladex/lucid_complete_pack/lucid_v1/02.png"
export GRUB_COLOR_NORMAL="white/black"
export GRUB_COLOR_HIGHLIGHT="red/black"vladex@vladex-PC:~$

Оффлайн xorizont

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: проблемка с grub
« Ответ #3 : 02 Май 2012, 07:19:14 »
up

Оффлайн alan_derua

  • Активист
  • *
  • Сообщений: 552
  • Свободный от забот
    • Просмотр профиля
Re: проблемка с grub
« Ответ #4 : 02 Май 2012, 08:29:51 »
Цитировать
export GRUB_MENU_PICTURE="/home/vladex/lucid_complete_pack/lucid_v1/02.png"
Смущает меня эта строчка.

Пользователь решил продолжить мысль 02 Май 2012, 08:30:28:
2) Советую не пользоваться подобными настройщиками, мона траблов схлопотать немерено...
+1

Оффлайн avi9526

  • Активист
  • *
  • Сообщений: 618
  • ахтыжъёшкинкот
    • Просмотр профиля
    • Блог av9526
Re: проблемка с grub
« Ответ #5 : 02 Май 2012, 12:38:23 »
1) Да, эти строчки вызывают подозрения. Надо проверить
выполни
gksu gedit /etc/default/grub
и удали последние три строчки
export GRUB_MENU_PICTURE="/home/vladex/lucid_complete_pack/lucid_v1/02.png"
export GRUB_COLOR_NORMAL="white/black"
export GRUB_COLOR_HIGHLIGHT="red/black"

потом в консоли
sudo update-grub
2) Если все прошло успешно и если ты хочешь чтобы у grub'а была фоновая картинка, можно просто кинуть любой графический файл (png, jpg, tga) в папку
/boot/grubтолько имя желательно простое у него должно быть (без пробелов и т.п.), типа "image.png".
А потом
sudo update-grubу меня он выдает что картинка найдена и потом в меню есть фоновая картинка
avi9526@avi9526-PC:~/Documents$ sudo update-grub
...
Found background: /boot/grub/stripes.jpg
Found background image: /boot/grub/stripes.jpg
...
done

но это не единственный способ, подробнее описано тут https://help.ubuntu.com/community/Grub2

Ubuntu 14.10

Оффлайн xorizont

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: проблемка с grub
« Ответ #6 : 03 Май 2012, 15:54:10 »
Проблему решил удалением строк с "gfxmode"  в файле linux в папке proxifiedscripts)
но пока я все это мутил, у меня теперь нету картинок загрузки и выключения. Плюс монитор выдает сообщение о неоптимальном разрешении)
Это можно тоже поправить?)

Оффлайн avi9526

  • Активист
  • *
  • Сообщений: 618
  • ахтыжъёшкинкот
    • Просмотр профиля
    • Блог av9526
Re: проблемка с grub
« Ответ #7 : 03 Май 2012, 17:20:32 »
Ну, если у тя "/home" отдельный диск можно систему переставить. Если для тебя это не затруднительно.

Вот какой-то совет на похожую проблему
http://askubuntu.com/a/127334

Или же здесь некто описывает жесткие меры (будь готов после такого к переустановке системы)
https://forum.ubuntu.ru/index.php?topic=74165.msg989588#msg989588
« Последнее редактирование: 03 Май 2012, 17:24:52 от avi9526 »
Ubuntu 14.10

 

Страница сгенерирована за 0.134 секунд. Запросов: 24.