Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: При обновлении Ubuntu с 11.10 до 12.04 выдает ошибку,прошу помощи!  (Прочитано 2499 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн VVladas

  • Автор темы
  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
Добрый вечер, суть вопроса такая, сегодня обновил систему  Ubuntu с 11.10 до 12.04, во время обновления системы несколько раз появлялось окно с ошибкой пакета, при этом активной кнопой можно было только закрыть окно сообщения. Изначально была установлена версия 10.10, затем были обновления по порядку  до 12.04 и проблем при обновлениях не было. После запуска в Unytu на верхней панели, кроме времени  ничего не отображается. Если зайти через Гном,то на панели отображается все, но есть уведомления об ошибках при обновлении пакетов. По подсказке уведомления, через терминал ввожу "sudo apt-get install -f" , но команда выдает ошибку.  Не могу разобраться, в чем дело. Прошу помочь, может быть кто то сталкивался с данной проблемой.
код ошибки:
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Исправление зависимостей... Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  gir1.2-folks-0.6 gir1.2-polkit-1.0 libcaribou0 libsushi-1.0-0
  ttf-sil-gentium gir1.2-accountsservice-1.0 gir1.2-sushi-1.0
  unity-2d-launcher libglew1.5 gir1.2-gkbd-3.0 libglewmx1.5 libnux-1.0-0
  gir1.2-networkmanager-1.0 folks-common libnux-1.0-common gir1.2-caribou-1.0
  libjaxp1.3-java gir1.2-dee-0.5 gir1.2-telepathylogger-0.2 libtextcat0
  libtextcat-data libcaribou-common gir1.2-upowerglib-1.0 libgammu-i18n
  gnome-contacts libreoffice-l10n-common gir1.2-telepathyglib-0.12
  libreoffice-report-builder-bin gir1.2-gee-1.0 unity-2d-places libllvm2.9
  gnome-shell-common python-debtagshw gir1.2-gudev-1.0
  software-center-aptdaemon-plugins
Для их удаления используйте 'apt-get autoremove'.
Будут установлены следующие дополнительные пакеты:
  activity-log-manager-common activity-log-manager-control-center aptdaemon
  baobab checkbox checkbox-gtk checkbox-qt chromium-browser
  chromium-browser-l10n cmap-adobe-japan2 evince evince-common fonts-kacst
  fonts-kacst-one fonts-khmeros-core fonts-lao fonts-nanum fonts-thai-tlwg
  fonts-tlwg-garuda fonts-tlwg-kinnari fonts-tlwg-loma fonts-tlwg-mono
  fonts-tlwg-norasi fonts-tlwg-purisa fonts-tlwg-sawasdee
  fonts-tlwg-typewriter fonts-tlwg-typist fonts-tlwg-typo fonts-tlwg-umpush
  fonts-tlwg-waree gir1.2-dee-1.0 gir1.2-gnomekeyring-1.0 gir1.2-gudev-1.0
  gir1.2-indicate-0.7 gir1.2-ubuntuoneui-3.0 gir1.2-unity-5.0 gnome-dictionary
  gnome-games-data gnome-screenshot gnome-search-tool gnome-sudoku gnome-sushi
  gnome-system-log gnomine gwibber gwibber-service landscape-client-ui-install
  libatk-adaptor-schemas libevince3-3 libfreerdp-plugins-standard libfreerdp1
  libgdict-1.0-6 libgdict-common libindicate5 libpoppler-glib8
  libproxy1-plugin-gsettings libproxy1-plugin-networkmanager libsdl1.2debian
  libubuntuoneui-3.0-1 linux-headers-3.2.0-24
  linux-headers-3.2.0-24-generic-pae linux-headers-generic-pae mahjongg
  min12xxw printer-driver-min12xxw printer-driver-ptouch printer-driver-pxljr
  printer-driver-sag-gdi printer-driver-splix ptouch-driver pxljr
  python-aptdaemon python-aptdaemon-gtk python-aptdaemon.gtk3widgets
  python-aptdaemon.gtkwidgets python-aptdaemon.pkcompat python-debtagshw
  python-dirspec python-gi python-gi-cairo python-indicate python-packagekit
  rastertosag-gdi remmina remmina-common remmina-plugin-rdp remmina-plugin-vnc
  rhythmbox-ubuntuone software-center-aptdaemon-plugins splix syslinux-legacy
  ttf-khmeros-core ttf-thai-tlwg ubuntu-desktop usb-creator-common
  usb-creator-gtk whoopsie xz-lzma
Предлагаемые пакеты:
  bonnie++ bootchart bzr cvs ethtool flex fwts git-core nmap smartmontools sox
  stress unrar poppler-data gwibber-service-flickr gwibber-service-digg
  gwibber-service-statusnet gwibber-service-foursquare
  gwibber-service-friendfeed gwibber-service-pingfm gwibber-service-qaiku
  unity-lens-gwibber xfreerdp gnome-games-extra-data
Рекомендуемые пакеты:
  fonts-takao-pgothic gnome-screensaver rhythmbox-plugin-magnatune thunderbird
  thunderbird-gnome-support
НОВЫЕ пакеты, которые будут установлены:
  activity-log-manager-common activity-log-manager-control-center checkbox-qt
  cmap-adobe-japan2 fonts-kacst fonts-kacst-one fonts-khmeros-core fonts-lao
  fonts-nanum fonts-thai-tlwg fonts-tlwg-garuda fonts-tlwg-kinnari
  fonts-tlwg-loma fonts-tlwg-mono fonts-tlwg-norasi fonts-tlwg-purisa
  fonts-tlwg-sawasdee fonts-tlwg-typewriter fonts-tlwg-typist fonts-tlwg-typo
  fonts-tlwg-umpush fonts-tlwg-waree gir1.2-dee-1.0 gir1.2-gnomekeyring-1.0
  gir1.2-gudev-1.0 gir1.2-indicate-0.7 gir1.2-ubuntuoneui-3.0 gir1.2-unity-5.0
  gnome-games-data landscape-client-ui-install libatk-adaptor-schemas
  libfreerdp-plugins-standard libfreerdp1 libgdict-common libpoppler-glib8
  libproxy1-plugin-gsettings libproxy1-plugin-networkmanager
  libubuntuoneui-3.0-1 linux-headers-3.2.0-24
  linux-headers-3.2.0-24-generic-pae linux-headers-generic-pae mahjongg
  printer-driver-min12xxw printer-driver-ptouch printer-driver-pxljr
  printer-driver-sag-gdi printer-driver-splix python-aptdaemon.pkcompat
  python-debtagshw python-dirspec python-gi-cairo python-packagekit remmina
  remmina-common remmina-plugin-rdp remmina-plugin-vnc rhythmbox-ubuntuone
  software-center-aptdaemon-plugins syslinux-legacy whoopsie xz-lzma
Пакеты, которые будут обновлены:
  aptdaemon baobab checkbox checkbox-gtk chromium-browser
  chromium-browser-l10n evince evince-common gnome-dictionary gnome-screenshot
  gnome-search-tool gnome-sudoku gnome-sushi gnome-system-log gnomine gwibber
  gwibber-service libevince3-3 libgdict-1.0-6 libindicate5 libsdl1.2debian
  min12xxw ptouch-driver pxljr python-aptdaemon python-aptdaemon-gtk
  python-aptdaemon.gtk3widgets python-aptdaemon.gtkwidgets python-gi
  python-indicate rastertosag-gdi splix ttf-khmeros-core ttf-thai-tlwg
  ubuntu-desktop usb-creator-common usb-creator-gtk
обновлено 37, установлено 61 новых пакетов, для удаления отмечено 0 пакетов, и 838 пакетов не обновлено.
не установлено до конца или удалено 204 пакетов.
Необходимо скачать 0 B/59,1 MB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 89,1 MB.
Хотите продолжить [Д/н]? д
Извлечение шаблонов из пакетов: 100%
Предварительная настройка пакетов ...
dpkg: ошибка: parsing file '/var/lib/dpkg/available' near line 18389 package 'skype-wrapper':
 blank line in value of field 'Description'
E: Sub-process /usr/bin/dpkg returned an error code (2)
v@v:~$ apt-get autoremove
E: Не удалось открыть файл блокировки /var/lib/dpkg/lock - open (13: Отказано в доступе)
E: Не удалось выполнить блокировку управляющего каталога (/var/lib/dpkg/); у вас есть права суперпользователя?
v@v:~$ sudo apt-get autoremove
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться `apt-get -f install'.
Пакеты, имеющие неудовлетворённые зависимости:
 baobab : Зависит: gnome-utils-common (>= 3.2) но он не может быть установлен
          Зависит: gnome-utils-common (< 3.3) но он не может быть установлен
 chromium-browser : ПредЗависит: lzma
 chromium-browser-l10n : ПредЗависит: lzma
 gnome-dictionary : Зависит: gnome-utils-common (>= 3.2) но он не может быть установлен
                    Зависит: gnome-utils-common (< 3.3) но он не может быть установлен
 gnome-screenshot : Зависит: gnome-utils-common (>= 3.2) но он не может быть установлен
                    Зависит: gnome-utils-common (< 3.3) но он не может быть установлен
 gnome-search-tool : Зависит: gnome-utils-common (>= 3.2) но он не может быть установлен
                     Зависит: gnome-utils-common (< 3.3) но он не может быть установлен
 gnome-sudoku : Зависит: gnome-games-common (= 1:3.2.1-0ubuntu3~oneiric1) но он не может быть установлен
 gnome-sushi : Зависит: gnome-sushi-common но он не может быть установлен
 gnome-system-log : Зависит: gnome-utils-common (>= 3.2) но он не может быть установлен
                    Зависит: gnome-utils-common (< 3.3) но он не может быть установлен
 gnomine : Зависит: gnome-games-common (= 1:3.2.1-0ubuntu3~oneiric1) но он не может быть установлен
 gwibber-service : Зависит: gir1.2-indicate-0.6 (>= 0.5.90) но он не может быть установлен
 libgdict-1.0-6 : Зависит: gnome-utils-common (>= 3.2) но он не может быть установлен
                  Зависит: gnome-utils-common (< 3.3) но он не может быть установлен
 libsdl1.2debian : Зависит: libsdl1.2debian-alsa (= 1.2.14-6.1ubuntu4) но он не может быть установлен или
                                   libsdl1.2debian-all (= 1.2.14-6.1ubuntu4) но он не может быть установлен или
                                   libsdl1.2debian-esd (= 1.2.14-6.1ubuntu4) но он не может быть установлен или
                                   libsdl1.2debian-oss (= 1.2.14-6.1ubuntu4) но он не может быть установлен или
                                   libsdl1.2debian-nas (= 1.2.14-6.1ubuntu4) но он не может быть установлен или
                                   libsdl1.2debian-pulseaudio (= 1.2.14-6.1ubuntu4) но он не может быть установлен
 software-center : Зависит: python-gobject-cairo
                   Рекомендует: lzma
 ubuntu-desktop : Зависит: libsdl1.2debian-pulseaudio но он не может быть установлен
                  Рекомендует: banshee-extension-ubuntuonemusicstore но он не может быть установлен
                  Рекомендует: gnome-codec-install
                  Рекомендует: gnome-mahjongg но он не может быть установлен
                  Рекомендует: gnome-screensaver но он не установлен
                  Рекомендует: libgail-3-common но он не может быть установлен
                  Рекомендует: thunderbird но он не установлен
                  Рекомендует: thunderbird-gnome-support но он не установлен
                  Рекомендует: ttf-kacst-one но он не установлен
 usb-creator-gtk : Зависит: gir1.2-unity-4.0 но он не может быть установлен
E: Неудовлетворённые зависимости. Попытайтесь использовать -f.
 

Оффлайн Henryh

  • Активист
  • *
  • Сообщений: 427
    • Просмотр профиля
Мой печальный опыт говорит что обновление до 12.04 нежелательно, система оказалось в полубитом состоянии. Если нет пары лишних дней на разбор полетов, лучше не стоит.
Что же касается конкретно вашего случая, то вроде как просит пройтись коммандой sudo apt-get update -f а потом пробовать.

Оффлайн VVladas

  • Автор темы
  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
Спасибо за совет, но после данной команды выдает вот такую ошибку:
dpkg: ошибка: parsing file '/var/lib/dpkg/available' near line 18389 package 'skype-wrapper':
 blank line in value of field 'Description'
E: Sub-process /usr/bin/dpkg returned an error code (2)
Вы предлагаете переустановить систему? Стоит наверное вернуться на 11.10, а может и на 10.10, только как быть с данными?
Честно сказать, впервые столкнулся с такими заморочками :), около года назад перешел на Ubuntu и радовался:), предлагают обновиться, обновлюсь и все(видимо новичкам везет:))!


Оффлайн Nikki1993

  • Заслуженный пользователь
  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 3261
  • Owner of Dell XPS 13 Developer Edition :D
    • Просмотр профиля
Цитировать
Вы предлагаете переустановить систему?
не предлагаем, а настаиваем. Всю важную инфу скиньте на жесткий диск (не скидывайте конфиги старых приложений!) и сделайте переустановку.
First i was like :0 Then i was like :D But now i am like(╯°□°)╯︵ ┻━┻
http://www.abload.de/img/banner_505uxa.png

Оффлайн Ydacha

  • Любитель
  • *
  • Сообщений: 70
    • Просмотр профиля
    • NetworkDoc.ru
откатиться назад, удалить пакет skype-wrapper, попробывать обновиться заного.

skype-wrapper - пакет интеграции skype с unity, взятый со стороннего репозитория, при обновлении до 12.04 все сторонние репозитории отваливаются.

Если нет возможности откатиться назад, предлагаю сходить в файлег 
sudo nano /var/lib/dpkg/availableCtrl+W > skype-wrapper > Enter
найти ниже строчку номер 18389 "Description:..." и посмотреть что с ней не так, на крайняк я бы исправил в ручную, наверняка она тупо пустая. Но боюсь щаз в меня полетят ссаные веники за такие советы. 
GNU not unix
дружим с NetworkDoc.ru

Оффлайн Henryh

  • Активист
  • *
  • Сообщений: 427
    • Просмотр профиля
Спасибо за совет, но после данной команды выдает вот такую ошибку:
dpkg: ошибка: parsing file '/var/lib/dpkg/available' near line 18389 package 'skype-wrapper':
 blank line in value of field 'Description'
E: Sub-process /usr/bin/dpkg returned an error code (2)
Ошибка это уже лучше чем не чего! Ведь теперь мы знаем кто виноват, и можем наказать виновного исправить ее, как пишут люди выше.
Вы предлагаете переустановить систему? Стоит наверное вернуться на 11.10, а может и на 10.10
Я сам домашний комп боюсь трогать, стоит 10.10 работает и нормально, времени заниматься им нет. ХОТЯ МНЕ ВСЕ БОЛЬШЕ КАЖЕТСЯ ЧТО 10.10 это последний действительно стабильный релиз ubuntu, дальше логотип превращается в бубен и поехали...
только как быть с данными?
Тут слава богу все просто, 99% программ хранят все самое нужное и вкусное в каталоге домашнего пользователя - /home/%username%. Сохранив эту папку вы скорей всего сохраните все что вам нужно (бывают исключения, например mysql хранит БД в другом месте, поэтому проверьте все). После переустановки вдумчиво поочередно возвращайте то что действительно нужно и не может вызвать конфликта. Например рабочий стол, документы, файлы браузера итп.
Честно сказать, впервые столкнулся с такими заморочками :), около года назад перешел на Ubuntu и радовался:), предлагают обновиться, обновлюсь и все(видимо новичкам везет:))!
А мне вот не повезло - и теперь я все это знаю :) . Пройтись ручками по системе обновиться и вообще тесно пообщаться с консолью очень полезно, развивает и увлекательно.

Удачи.
« Последнее редактирование: 04 Май 2012, 04:03:29 от keysi_ »

Оффлайн VVladas

  • Автор темы
  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
Добрый день! Благодарю вас  за содержательные советы! В воскресенье займусь исправлением. О результатах обязательно напишу!

Оффлайн Folko85

  • Участник
  • *
  • Сообщений: 116
    • Просмотр профиля
sudo nano /var/lib/dpkg/available
Ctrl+W > skype-wrapper > Enter
найти ниже строчку номер 18389 "Description:..." и посмотреть что с ней не так, на крайняк я бы исправил в ручную, наверняка она тупо пустая. Но боюсь щаз в меня полетят ссаные веники за такие советы.
Мне помогло. Надо удалить описание пакета и всё будет в норме.
Можно использовать gedit вместо nano.

Оффлайн Ydacha

  • Любитель
  • *
  • Сообщений: 70
    • Просмотр профиля
    • NetworkDoc.ru
ИМХО проблема не в релизе, а в пакетах которые были дополнительно установлены.
Предлагаю создать чёрный список пакетов, которые необходимо удалить до попытки миграции.
Для начала:
sudo aptitude remove testdisk skype-wrapper
testdisk - репозиторий 11.10 - устаревшее или неправильное описание зависимостей [< 9 libntfs10]
skype-wrapper - сторонний репозиторий - ошибка в описании.
GNU not unix
дружим с NetworkDoc.ru

Оффлайн Nikki1993

  • Заслуженный пользователь
  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 3261
  • Owner of Dell XPS 13 Developer Edition :D
    • Просмотр профиля
вместо
aptitudeиспользуй
apt-getтак как aptitude по умолчанию не установлен!
First i was like :0 Then i was like :D But now i am like(╯°□°)╯︵ ┻━┻
http://www.abload.de/img/banner_505uxa.png

Оффлайн VVladas

  • Автор темы
  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
Добрый вечер! Сегодня занимаюсь исправлением ошибок :) Пробую несколько предложенных вариантов, пока без кардинальных мер. Итак по команде v@v:~$ sudo apt-get remove testdisk skype-wrapper выдает вот такую информацию:
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
E: Не удалось найти пакет skype-wrapper
Что это так и не понял :)

Оффлайн Nikki1993

  • Заслуженный пользователь
  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 3261
  • Owner of Dell XPS 13 Developer Edition :D
    • Просмотр профиля
у вас нет установленого пакета в системе под названием skype-wrapper вот, что значит  :)
First i was like :0 Then i was like :D But now i am like(╯°□°)╯︵ ┻━┻
http://www.abload.de/img/banner_505uxa.png

Оффлайн VVladas

  • Автор темы
  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
Пробую второй вариант:sudo nano /var/lib/dpkg/available
Ctrl+W > skype-wrapper > Enter
найти ниже строчку номер 18389 "Description:..."

В поиске строки 18389 выдает строку 1838998
Package: language-pack-gnome-lt-base
Priority: optional
Section: translations
Installed-Size: 6936
Maintainer: Language pack maintainers <language-packs@ubuntu.com>
Architecture: all
Version: 1:10.10+20100930
Replaces: language-pack-gnome-lt (<< 1:10.10+20100930), language-pack-gnome-lt-base (<< 1:10.10+20100930), language-pack-kde-lt-base (<< 1:10.10+20100$
Depends: locales (>= 2.3.6), language-pack-gnome-lt (>= 1:10.10+20100930), language-pack-lt-base
Pre-Depends: dpkg (>= 1.10.27ubuntu1)
Suggests: language-support-lt
Conflicts: language-pack-gnome-lt (<< 1:10.10+20100930)
Size: 1838998
Description: GNOME translations for language Lithuanian
 Translation data for all supported GNOME packages for:
 Lithuanian
Что это тоже не знаю, что тут нужно сделать?

Пользователь решил продолжить мысль 06 Май 2012, 21:17:27:
у вас нет установленого пакета в системе под названием skype-wrapper вот, что значит  :)
ясно, выше , в ошибке как раз и ссылается на этот файл.

Пользователь решил продолжить мысль 06 Май 2012, 21:19:21:
Может быть действительно не мудрствуя переустановить систему :), только не хочется заморачиваться с переносом документов
« Последнее редактирование: 06 Май 2012, 21:19:21 от VVladas »

Оффлайн Nikki1993

  • Заслуженный пользователь
  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 3261
  • Owner of Dell XPS 13 Developer Edition :D
    • Просмотр профиля
поставьте начисто, и проще и волнений меньше. 1 час поработаете с переносом файлов зато сохраните свое будущее время  :)
First i was like :0 Then i was like :D But now i am like(╯°□°)╯︵ ┻━┻
http://www.abload.de/img/banner_505uxa.png

Оффлайн VVladas

  • Автор темы
  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
После долгих мытарств в воскресенье,работы над исправлением ошибок, принято решение переустановить  систему. Установил 12.04 :), буду приобщаться к новому! Пока все работает отлично. Удивило, что установка заняла всего 30 минут, причем с обновлением! Радует стабильность!

 

Страница сгенерирована за 0.108 секунд. Запросов: 24.