Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Собираем GIMP 2.8, не собирается BABL  (Прочитано 1946 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн unclechu

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
    • WAVE FOR YOU band
Приветствую. Не могу собрать BABL. Сделал git clone git://git.gnome.org/babl && cd babl и пытаюсь выполнить ./autogen.sh, вот крайний нижний кусок отчёта:
checking for gcc... (cached) gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ISO C89... (cached) none needed
checking dependency style of gcc... (cached) gcc3
./configure: line 4958: syntax error near unexpected token `2.2'
./configure: line 4958: `LT_PREREQ(2.2)'
В чём собственно кроется проблема? Каких-то либ недостаёт?

Заранее благодарю за помощь!

Оффлайн v!tax

  • Старожил
  • *
  • Сообщений: 4154
  • Gentoo x64 bspwm
    • Просмотр профиля
Re: Собираем GIMP 2.8, не собирается BABL
« Ответ #1 : 08 Мая 2012, 02:00:31 »
а зачем такое извращение?
господь ведет твою руку, сын мой....

string

  • Гость
Re: Собираем GIMP 2.8, не собирается BABL
« Ответ #2 : 08 Мая 2012, 06:24:17 »
Зачем собирать? Из спортивного интереса?

Оффлайн unclechu

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
    • WAVE FOR YOU band
Re: Собираем GIMP 2.8, не собирается BABL
« Ответ #3 : 08 Мая 2012, 13:31:48 »
Затем, что в офф репозитории старая версия GIMP-а. А чтобы установить новую, нужно поставить GEGL и BABL. BABL-а в офф-репах нету. Какие альтернативы?

Оффлайн v!tax

  • Старожил
  • *
  • Сообщений: 4154
  • Gentoo x64 bspwm
    • Просмотр профиля
Re: Собираем GIMP 2.8, не собирается BABL
« Ответ #4 : 08 Мая 2012, 13:39:47 »
Какая старая?ты чего?  :)
sudo add-apt-repository ppa:otto-kesselgulasch/gimp
sudo apt-get update && sudo apt-get install gimp
для ubuntu 12.04
господь ведет твою руку, сын мой....

Оффлайн evg89

  • Активист
  • *
  • Сообщений: 468
  • СПО'шник
    • Просмотр профиля
Re: Собираем GIMP 2.8, не собирается BABL
« Ответ #5 : 09 Мая 2012, 13:14:19 »
Какая старая?ты чего?  :)
sudo add-apt-repository ppa:otto-kesselgulasch/gimp
sudo apt-get update && sudo apt-get install gimp
для ubuntu 12.04

это не оффициальный репозиторий, когда нибудь прилетит тебе оттуда.... как из уалинукс)))

unclechu, в какой системе собираете?
здесь смотрели: https://forum.ubuntu.ru/index.php?topic=190685.0?
РАБОТА: win server 2008 r2, ubuntu server 12.04, freebsd 8.3 - сервера; edubuntu 10.04, win 7 pro - обслуживаемые ПК.
ДОМ: ubuntu 12.04 - ПК; windows 7 starter - нетбук;  android 2.2 - коммуникатор.

Оффлайн unclechu

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
    • WAVE FOR YOU band
Re: Собираем GIMP 2.8, не собирается BABL
« Ответ #6 : 09 Мая 2012, 14:43:43 »
Какая старая?ты чего?  :)
sudo add-apt-repository ppa:otto-kesselgulasch/gimp
sudo apt-get update && sudo apt-get install gimp
для ubuntu 12.04

это не оффициальный репозиторий, когда нибудь прилетит тебе оттуда.... как из уалинукс)))

unclechu, в какой системе собираете?
здесь смотрели: https://forum.ubuntu.ru/index.php?topic=190685.0?

Смотрел, в том-то и дело, что как там описано не собирается, на ./autogen.sh ёк. Ошибку я привёл.
Собираю в убунте 12.04, недавно обновился. Граф-оболочка стоит xubuntu-desktop. Вот uname -a на всякий:Linux unclechu-nb 3.2.0-24-generic-pae #37-Ubuntu SMP Wed Apr 25 10:47:59 UTC 2012 i686 athlon i386 GNU/Linux
Пользователь решил продолжить мысль 09 Мая 2012, 14:51:14:
Ой, прошу прощения, после этого заработало: sudo apt-get build-dep gimpМне казалось я сделал, видимо нет.
« Последнее редактирование: 09 Мая 2012, 14:51:14 от unclechu »

Оффлайн evg89

  • Активист
  • *
  • Сообщений: 468
  • СПО'шник
    • Просмотр профиля
Re: Собираем GIMP 2.8, не собирается BABL
« Ответ #7 : 09 Мая 2012, 15:00:33 »
Тот же пост, но уже в вики-статье: https://help.ubuntu.ru/wiki/gimp2.8
Отпишитесь о результатах, если потребуются какие либо изменения в статью.
РАБОТА: win server 2008 r2, ubuntu server 12.04, freebsd 8.3 - сервера; edubuntu 10.04, win 7 pro - обслуживаемые ПК.
ДОМ: ubuntu 12.04 - ПК; windows 7 starter - нетбук;  android 2.2 - коммуникатор.

Оффлайн unclechu

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
    • WAVE FOR YOU band
Re: Собираем GIMP 2.8, не собирается BABL
« Ответ #8 : 09 Мая 2012, 15:55:47 »
Тот же пост, но уже в вики-статье: https://help.ubuntu.ru/wiki/gimp2.8
Отпишитесь о результатах, если потребуются какие либо изменения в статью.

Возникла ошибка при make gegl-а, не такая, как описано:...
Making all in data
make[4]: Вход в каталог `/home/unclechu/gegl/docs/gallery/data'
make[4]: Цель `all' не требует выполнения команд.
make[4]: Выход из каталога `/home/unclechu/gegl/docs/gallery/data'
make[4]: Вход в каталог `/home/unclechu/gegl/docs/gallery'
--[Updating sample compositions]--
./clones.xml
/home/unclechu/gegl/bin/.libs/lt-gegl: error while loading shared libraries: libbabl-0.1.so.0: cannot open shared object file: No such file or directory
make[5]: *** [clones.png] Ошибка 127
./OpenRaster-00.xml
/home/unclechu/gegl/bin/.libs/lt-gegl: error while loading shared libraries: libbabl-0.1.so.0: cannot open shared object file: No such file or directory
make[5]: *** [OpenRaster-00.png] Ошибка 127
./OpenRaster-01.xml
/home/unclechu/gegl/bin/.libs/lt-gegl: error while loading shared libraries: libbabl-0.1.so.0: cannot open shared object file: No such file or directory
make[5]: *** [OpenRaster-01.png] Ошибка 127
./OpenRaster-04.xml
/home/unclechu/gegl/bin/.libs/lt-gegl: error while loading shared libraries: libbabl-0.1.so.0: cannot open shared object file: No such file or directory
make[5]: *** [OpenRaster-04.png] Ошибка 127
make[4]: *** [images.stamp] Ошибка 2
make[4]: Выход из каталога `/home/unclechu/gegl/docs/gallery'
make[3]: *** [all-recursive] Ошибка 1
make[3]: Выход из каталога `/home/unclechu/gegl/docs/gallery'
make[2]: *** [all-recursive] Ошибка 1
make[2]: Выход из каталога `/home/unclechu/gegl/docs'
make[1]: *** [all-recursive] Ошибка 1
make[1]: Выход из каталога `/home/unclechu/gegl'
make: *** [all] Ошибка 2

И ещё по описанию установки, в репе git://git.gnome.org/gimp нету configure, там так же как и gegl и babl, конфиг происходить через autogen.sh, так что статья нуждается в освежении.

Пользователь решил продолжить мысль 09 Мая 2012, 15:59:13:
Пытаюсь произвести операцию как в описании, не выходит. Может libbabl0.1-0 по логике?
sudo apt-get remove libbabl0.0-0
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
E: Не удалось найти пакет libbabl0.0-0
E: Не удалось найти пакет по регулярному выражению «libbabl0.0-0»
« Последнее редактирование: 09 Мая 2012, 15:59:13 от unclechu »

Оффлайн evg89

  • Активист
  • *
  • Сообщений: 468
  • СПО'шник
    • Просмотр профиля
Re: Собираем GIMP 2.8, не собирается BABL
« Ответ #9 : 09 Мая 2012, 16:04:54 »
нужно
sudo apt-get remove libbabl-0.0-0
тире пропустили.

Пользователь решил продолжить мысль 09 Мая 2012, 16:06:24:

И ещё по описанию установки, в репе git://git.gnome.org/gimp нету configure, там так же как и gegl и babl, конфиг происходить через autogen.sh, так что статья нуждается в освежении.

спасибо за поправку
РАБОТА: win server 2008 r2, ubuntu server 12.04, freebsd 8.3 - сервера; edubuntu 10.04, win 7 pro - обслуживаемые ПК.
ДОМ: ubuntu 12.04 - ПК; windows 7 starter - нетбук;  android 2.2 - коммуникатор.

Оффлайн Zeka13

  • Старожил
  • *
  • Сообщений: 1177
  • 18.10 Gnome x64 GTX 970
    • Просмотр профиля
Re: Собираем GIMP 2.8, не собирается BABL
« Ответ #10 : 09 Мая 2012, 16:46:10 »
я из ppa нормально поставил
Если Wine - это костыль , то  Punto Switcher - это протез , а Daemon Tools инвалидное кресло.

Оффлайн v!tax

  • Старожил
  • *
  • Сообщений: 4154
  • Gentoo x64 bspwm
    • Просмотр профиля
Re: Собираем GIMP 2.8, не собирается BABL
« Ответ #11 : 09 Мая 2012, 16:47:34 »
у людей боязнь накосячить при установке не из офф репозитория.Если ждать лобаления в офф,то можно состариться  :)
господь ведет твою руку, сын мой....

Оффлайн evg89

  • Активист
  • *
  • Сообщений: 468
  • СПО'шник
    • Просмотр профиля
Re: Собираем GIMP 2.8, не собирается BABL
« Ответ #12 : 09 Мая 2012, 17:03:59 »
у людей боязнь накосячить при установке не из офф репозитория.Если ждать лобаления в офф,то можно состариться  :)

а можно собрать самому. тем более - это не сложнее, чем накосячить
РАБОТА: win server 2008 r2, ubuntu server 12.04, freebsd 8.3 - сервера; edubuntu 10.04, win 7 pro - обслуживаемые ПК.
ДОМ: ubuntu 12.04 - ПК; windows 7 starter - нетбук;  android 2.2 - коммуникатор.

Оффлайн unclechu

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
    • WAVE FOR YOU band
Re: Собираем GIMP 2.8, не собирается BABL
« Ответ #13 : 09 Мая 2012, 22:52:56 »
нужно
sudo apt-get remove libbabl-0.0-0
тире пропустили.
Спасибо! Теперь всё отлично собралось, гимп запускается! Причём не 2.8, а 2.9.1 оказывается уже! Это в репе git://git.gnome.org/gimp

Оффлайн evg89

  • Активист
  • *
  • Сообщений: 468
  • СПО'шник
    • Просмотр профиля
Re: Собираем GIMP 2.8, не собирается BABL
« Ответ #14 : 10 Мая 2012, 05:03:21 »
2.8 стабильный, про 2.9 пока ничего не скажу, не читал. тоже попробую.
РАБОТА: win server 2008 r2, ubuntu server 12.04, freebsd 8.3 - сервера; edubuntu 10.04, win 7 pro - обслуживаемые ПК.
ДОМ: ubuntu 12.04 - ПК; windows 7 starter - нетбук;  android 2.2 - коммуникатор.

 

Страница сгенерирована за 0.038 секунд. Запросов: 25.