Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Sony VAIO Ubuntu 12.04 Realtek RTL8111/8168B "Устройство не управляется"  (Прочитано 2974 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн dclg

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Поставил Xubuntu 12.04 на Sony Vaio VPCEJ.
В области уведомлений показывает постоянно "проводное соединение - устройство не управляется"
Поставил драйвер от производителя.
lspci показывает вроде то что нужно.
интерфейс в ifconfig видно.
Интернет от провода работает, но только при выключенном wifi.
Сам wifi при это работает очень меделенно, хотя раздается с того же роутера что и проводной.
Но "устройство не управляется" что я делаю не так?





« Последнее редактирование: 08 Мая 2012, 22:38:24 от dclg »

Оффлайн victor00000

  • Старожил
  • *
  • Сообщений: 15568
  • Глухонемой (Deaf)
    • Просмотр профиля
lspci -knn | grep "Eth\|Net" -A2
Wars ~.o

Оффлайн dclg

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
07:00.0 Network controller [0280]: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)
Subsystem: Foxconn International, Inc. Device [105b:e037]
Kernel driver in use: ath9k
--
13:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 06)
Subsystem: Sony Corporation Device [104d:908b]
Kernel driver in use: r8168

Оффлайн victor00000

  • Старожил
  • *
  • Сообщений: 15568
  • Глухонемой (Deaf)
    • Просмотр профиля
modprobe -c | grep -i 10ec | grep 8168modprobe -c | grep -i 168c | grep -i 002b
Wars ~.o

Оффлайн dclg

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
~$ modprobe -c | grep -i 10ec | grep 8168
alias pci:v000010ECd00008168sv*sd*bc*sc*i* r8168
~$ modprobe -c | grep -i 168c | grep -i 002b
alias pci:v0000168Cd0000002Bsv*sd*bc*sc*i* ath9k

Оффлайн victor00000

  • Старожил
  • *
  • Сообщений: 15568
  • Глухонемой (Deaf)
    • Просмотр профиля
нормально
Wars ~.o

Оффлайн dclg

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
В том то и дело) Все должно работать, но не работает. Когда жму на иконку соединений пишет что "проводная сеть - устройство не управляется" wifi показывает норм. В "сетевых соединениях" проводных соединений нет. Я плохо в этом разбираюсь, поэтому не понимаю на каком уровне с этим бороться.

Пользователь решил продолжить мысль 09 Мая 2012, 01:33:43:
Все оказалось чертовски просто, как написано здесь:

http://oleg.in-da.ru/soft/networkmanager/ustrojstvo_ne_upravljaetsja

Network Manager управляет только интерфейсами, не имеющими настроек IP-адреса в файле /etc/network/interfaces.

Соответственно, решением является комментирование строк назначения IP-адресов для интерфейсов, которыми Вы хотите управлять через Network Manager.

Я закоментировал строчку #iface eth0 inet dhcp
И перезапустил sudo service network-manager restart

И проводной интерфейс появился там где должен был. То есть по сути это была даже не проблема а misconfiguration так что простите за беспокойство.
« Последнее редактирование: 09 Мая 2012, 01:33:43 от dclg »

Оффлайн victor00000

  • Старожил
  • *
  • Сообщений: 15568
  • Глухонемой (Deaf)
    • Просмотр профиля
echo "options ath9k nohwcrypt=1" | sudo tee /etc/modprobe.d/ath9k.conf
sudo reboot
?
Wars ~.o

Оффлайн MrFree

  • Активист
  • *
  • Сообщений: 290
  • вечно начинающий линуксоид
    • Просмотр профиля
cat /etc/network/interfaces
Ubuntu 22.04 /i5-7500/32GB/ssd512(boot/root/home)/3000HDD/GTX1063
Как правильно задавать вопросы

Оффлайн dclg

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
victor00000,
Да, это тоже сделал позже и пропали тормоза с wifi, так что все проблемы решены, спасибо!

 

Страница сгенерирована за 0.057 секунд. Запросов: 25.