Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: \"Ломается\" видео..  (Прочитано 846 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ramses

  • Автор темы
  • Новичок
  • *
  • Сообщений: 23
    • Просмотр профиля
\"Ломается\" видео..
« : 10 Мая 2012, 13:36:28 »
Накладываю субтитры mencoder'ом

примерно так: transcode -i film.avi -x mplayer="-sub sub.srt -utf8 -subfont-text-scale 3" -o 1.avi -y xvid
а бывает и так: mencoder film.avi -sub sub.srt -utf8 -subfont-text-scale 3 -oac mp3lame -ovc lavc -lameopts preset=extreme -lavcopts vcodec=mpeg4:vbitrate=2048:autoaspect=1 -o 1.avi

, и через какое-то время видеофайл "ломается": сокращается продолжительность, перестаёт воспроизводиться или всё несмотрибельно становится. В чём дело может быть?

Пользователь решил продолжить мысль 10 Мая 2012, 14:19:58:
Могу небольшой кусок испорченного файла выложить.
« Последнее редактирование: 10 Мая 2012, 15:12:11 от ramses »

Оффлайн start733

  • Участник
  • *
  • Сообщений: 248
    • Просмотр профиля
Re: \"Ломается\" видео..
« Ответ #1 : 13 Мая 2012, 20:09:29 »
Попробуй плохой файл проиндексировать:
mencoder -idx 1.avi -ovc copy -oac copy -o Index.avi

Оффлайн ramses

  • Автор темы
  • Новичок
  • *
  • Сообщений: 23
    • Просмотр профиля
Re: \"Ломается\" видео..
« Ответ #2 : 14 Мая 2012, 08:44:41 »
Попробую при случае. Странно, но пока всё хорошо..

 

Страница сгенерирована за 0.04 секунд. Запросов: 25.