Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Нужны кодеки libx264 и libmp3lame  (Прочитано 3126 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Rus_Lan

  • Автор темы
  • Гость
Нужны кодеки libx264 и libmp3lame
« : 18 Май 2012, 14:40:19 »
Мир всем ребята

Работаю в Openshot но при выборе записи в FLV или HD - просит эти кодеки:

1) libx264
2) libmp3lame

где скачать или как установить еще можно?

Оффлайн v!tax

  • Старожил
  • *
  • Сообщений: 4157
  • Gentoo x64 bspwm
    • Просмотр профиля
Re: Нужны кодеки libx264 и libmp3lame
« Ответ #1 : 18 Май 2012, 14:43:24 »
a) libavformat-extra
или то или это
b) libavformat-unstripped

(Нажмите, чтобы показать/скрыть)
« Последнее редактирование: 18 Май 2012, 14:48:09 от Jolly Roger »
господь ведет твою руку, сын мой....

Оффлайн Bamb

  • Активист
  • *
  • Сообщений: 798
  • Arch Linux
    • Просмотр профиля
Re: Нужны кодеки libx264 и libmp3lame
« Ответ #2 : 18 Май 2012, 14:52:50 »
А по-моему, достаточно установить ffmpeg

Оффлайн v!tax

  • Старожил
  • *
  • Сообщений: 4157
  • Gentoo x64 bspwm
    • Просмотр профиля
Re: Нужны кодеки libx264 и libmp3lame
« Ответ #3 : 18 Май 2012, 14:54:04 »
нужно больше инфы.спросил кодеки,я ему ответил.
господь ведет твою руку, сын мой....

Оффлайн Bamb

  • Активист
  • *
  • Сообщений: 798
  • Arch Linux
    • Просмотр профиля
Re: Нужны кодеки libx264 и libmp3lame
« Ответ #4 : 18 Май 2012, 15:00:06 »
Со временем понадобится mpeg2video, потом libxvid... :)
http://ru.wikipedia.org/wiki/FFmpeg

Rus_Lan

  • Автор темы
  • Гость
Re: Нужны кодеки libx264 и libmp3lame
« Ответ #5 : 18 Май 2012, 16:47:16 »
Установил FFmpeg но при сохранение в FLV все равно требует кодеки:

The following formats/codecs are missing from your system:

libx264
libmp3lame

You will not be able to use the selected export profile.  You will need to install the missing formats/codecs or choose a different export profile.

Может еще дополнительно что-то сделать нужно?

Оффлайн v!tax

  • Старожил
  • *
  • Сообщений: 4157
  • Gentoo x64 bspwm
    • Просмотр профиля
Re: Нужны кодеки libx264 и libmp3lame
« Ответ #6 : 18 Май 2012, 16:47:59 »
я от фонаря отзыв тебе написал?пробуй мой вариант.
господь ведет твою руку, сын мой....

Rus_Lan

  • Автор темы
  • Гость
Re: Нужны кодеки libx264 и libmp3lame
« Ответ #7 : 18 Май 2012, 18:43:59 »
a) libavformat-extra
или то или это
b) libavformat-unstripped

(Нажмите, чтобы показать/скрыть)


Все работает, только по варианту b) 
благодарю тебя за помощь,

Да благословит тебя Иисус Христос!

Оффлайн Sorius

  • Новичок
  • *
  • Сообщений: 27
    • Просмотр профиля
Re: Нужны кодеки libx264 и libmp3lame
« Ответ #8 : 20 Январь 2013, 11:08:48 »
Огромное спасибо, у меня сработал и способ а. Видео сохраняются.

Оффлайн Genyj

  • Новичок
  • *
  • Сообщений: 43
    • Просмотр профиля
    • ЦМК Большие возможности
Re: Нужны кодеки libx264 и libmp3lame
« Ответ #9 : 25 Июнь 2014, 11:45:08 »
Странно, что у меня установлен пакет ffmpeg и при этом программа ругается, что кодеков нет.
Я работаю в kdenlive. Тоже требуются кодеки:
libmp3lame
libxvid

Как быть?

пишет "Неподдерживаемый аудио-кодек: libmp3lame"


sudo apt-get install ffmpeg
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Уже установлена самая новая версия ffmpeg.
« Последнее редактирование: 25 Июнь 2014, 11:51:50 от Genyj »
Пространство Любви начинается в моём сердце (с)

Оффлайн Bamb

  • Активист
  • *
  • Сообщений: 798
  • Arch Linux
    • Просмотр профиля
Re: Нужны кодеки libx264 и libmp3lame
« Ответ #10 : 25 Июнь 2014, 15:49:44 »
libmp3lame принадлежит пакету lame, libxvid - пакету xvidcore. Оба находятся в зависимостях у ffmpeg, так что странно, что они у вас не установлены.

Krjd

  • Автор темы
  • Гость
Re: Нужны кодеки libx264 и libmp3lame
« Ответ #11 : 25 Июнь 2014, 16:17:54 »
Genyj,
какая версия Ubuntu? в 14.04 выпилен ffmpeg...
http://askubuntu.com/a/432585

Оффлайн arch!ver

  • Забанен
  • Старожил
  • *
  • Сообщений: 1260
    • Просмотр профиля
Re: Нужны кодеки libx264 и libmp3lame
« Ответ #12 : 26 Июнь 2014, 01:37:21 »
Genyj,
А вы вообще устанавливали пакеты кодеков?
sudo apt-get install ubuntu restricted extras
Поставте оригинальный ffmpeg отсюда - и не мучайтесь: https://trac.ffmpeg.org/wiki/CompilationGuide/Ubuntu ...
В репозиториях стоит Libav (форк ffmpeg-a), а не ffmpeg
« Последнее редактирование: 26 Июнь 2014, 01:42:30 от archiver »
Шизофреник админ, - горе в семье...

Оффлайн Genyj

  • Новичок
  • *
  • Сообщений: 43
    • Просмотр профиля
    • ЦМК Большие возможности
Re: Нужны кодеки libx264 и libmp3lame
« Ответ #13 : 12 Август 2014, 12:50:33 »
Genyj,
А вы вообще устанавливали пакеты кодеков?
sudo apt-get install ubuntu restricted extras
Поставте оригинальный ffmpeg отсюда - и не мучайтесь: https://trac.ffmpeg.org/wiki/CompilationGuide/Ubuntu ...
В репозиториях стоит Libav (форк ffmpeg-a), а не ffmpeg
Пока Ubuntu удалил. Поставлю новую - отпишусь о результатах. Благодарю за ответ
Пространство Любви начинается в моём сердце (с)

Оффлайн altwazar

  • Активист
  • *
  • Сообщений: 413
    • Просмотр профиля
Re: Нужны кодеки libx264 и libmp3lame
« Ответ #14 : 12 Август 2014, 17:16:21 »
Как быть?

Попробуй поставить "ubuntu-restricted-addons ubuntu-restricted-extras" (для Ubuntu) или "kubuntu-restricted-addons kubuntu-restricted-extras"(для Kubuntu). Для kdenlive если не ошибаюсь они и нужны.
Если не сработает и потребуется ffmpeg, то есть ppa с ним: ppa:jon-severinsson/ffmpeg
« Последнее редактирование: 12 Август 2014, 17:19:36 от altwazar »

 

Страница сгенерирована за 0.287 секунд. Запросов: 24.