Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: пропал интернет на сервере  (Прочитано 2250 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Rydj

  • Автор темы
  • Участник
  • *
  • Сообщений: 158
    • Просмотр профиля
пропал интернет на сервере
« : 19 Июнь 2012, 17:25:33 »
Добрый день, сегодня настраивал новый сервер в офисе сначало все было здорово поставил ubuntu-server 12.04 настроил интернет, обновился начал ставить dhcp-server, squid, squidguard потом сделал ребут и обнаружил что интернета нет причем вся магия в том что eth0 вроде как работает так как он пингует серверы (x.x.x.210) но при этом днс 8.8.8.8 и вообще ya.ru не пингует.

auto lo
iface lo inet loopback
iface eth0 inet static
address x.x.x.221
netmask 255.255.255.240
gateway x.x.x.209
dns-nameservers 8.8.8.8
iface eth1 inet static
address 10.0.0.1
netmask 255.0.0.0
gateway 10.0.0.1
dns-nameservers 10.0.0.1
auto eth1 eth0

Оффлайн SvMidi

  • Активист
  • *
  • Сообщений: 815
    • Просмотр профиля
Re: пропал интернет на сервере
« Ответ #1 : 19 Июнь 2012, 17:30:55 »
думаю ключевое слово здесь "шлюз по умолчанию"
route
Я знаю только то, что ничего не знаю, остальные не знают и этого.

Оффлайн Rydj

  • Автор темы
  • Участник
  • *
  • Сообщений: 158
    • Просмотр профиля
Re: пропал интернет на сервере
« Ответ #2 : 19 Июнь 2012, 17:36:43 »
root@main:~# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
x.x.x.208  *               255.255.255.240 U     0      0        0 eth0
немного подошел ближе к разгадке увидел что в resolv.conf сформировался днс 10.0.0.1 пока я вообще отключил eth1 теперь файл вообще пустой хотя по идее должен писать 8.8.8.8 но пока как решить проблему не понимаю
« Последнее редактирование: 19 Июнь 2012, 17:40:04 от Rydj »

Оффлайн SvMidi

  • Активист
  • *
  • Сообщений: 815
    • Просмотр профиля
Re: пропал интернет на сервере
« Ответ #3 : 19 Июнь 2012, 17:45:47 »
route add default gw <свой шлюз> eth0Спасёт отца русской демократии
Я знаю только то, что ничего не знаю, остальные не знают и этого.

Оффлайн Rydj

  • Автор темы
  • Участник
  • *
  • Сообщений: 158
    • Просмотр профиля
Re: пропал интернет на сервере
« Ответ #4 : 19 Июнь 2012, 17:54:32 »
прогресс стал пинговаться 8.8.8.8 спасибо, но почему настройки с interfaces не проходят в resolv.conf не прописано ничего и ya.ru не пингуется.
Да вот еще при перезагрузке интерфейса вот что пишется:
root@main:~# /etc/init.d/networking restart
 * Running /etc/init.d/networking restart is deprecated because it may not enable again some interfaces
 * Reconfiguring network interfaces...                                          RTNETLINK answers: File exists
Failed to bring up eth0.
                                                                         [ OK ]

vim /etc/network/interfaces
auto lo
iface lo inet loopback
iface eth0 inet static
address x.x.x.221
netmask 255.255.255.240
gateway x.x.x.209
dns-nameservers 8.8.8.8

[color=blue]#iface eth1 inet static
#address 10.0.0.1
#netmask 255.0.0.0
#gateway 10.0.0.1[/color]
auto eth0

Оффлайн SvMidi

  • Активист
  • *
  • Сообщений: 815
    • Просмотр профиля
Re: пропал интернет на сервере
« Ответ #5 : 19 Июнь 2012, 18:00:03 »

Хз, запиши eth0 так:
auto eth0
iface eth0 inet static
address x.x.x.221
netmask 255.255.255.240
gateway x.x.x.209
dns-nameservers 8.8.8.8

по крайней мере народ не будет путаться.

Я знаю только то, что ничего не знаю, остальные не знают и этого.

Оффлайн Rydj

  • Автор темы
  • Участник
  • *
  • Сообщений: 158
    • Просмотр профиля
Re: пропал интернет на сервере
« Ответ #6 : 19 Июнь 2012, 18:02:34 »
перезагрузился и все стало как надо, спасибо за шлюз до этого ебут не помогал. Хотя чертовски интересно что же это было... будет очень не приятно если это случится когда сервер переведу в боевой режим.

Оффлайн SvMidi

  • Активист
  • *
  • Сообщений: 815
    • Просмотр профиля
Re: пропал интернет на сервере
« Ответ #7 : 19 Июнь 2012, 18:05:01 »
Ну шлюз прописаный таким образом после ребута исчезает, так что маршрут не причём.
Если привели запись к виду:
auto eth0
iface eth0 inet static
address x.x.x.221
netmask 255.255.255.240
gateway x.x.x.209
dns-nameservers 8.8.8.8
то вероятно в этом и была причина.
Я знаю только то, что ничего не знаю, остальные не знают и этого.

 

Страница сгенерирована за 0.174 секунд. Запросов: 24.