Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: PHP 5.2.17 + PHP 5.3.x + PHP 5.4.x  (Прочитано 2567 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн san4ez

  • Автор темы
  • Участник
  • *
  • Сообщений: 113
  • Хочу всё знать
    • Просмотр профиля
PHP 5.2.17 + PHP 5.3.x + PHP 5.4.x
« : 17 Июль 2012, 16:22:19 »
Каким образом можно иметь данную связку в Ubuntu 12.04 ?

Оффлайн sash23

  • Участник
  • *
  • Сообщений: 130
    • Просмотр профиля
Re: PHP 5.2.17 + PHP 5.3.x + PHP 5.4.x
« Ответ #1 : 17 Июль 2012, 16:33:03 »
собрать из исходников
5.3 из репов можно поставить остальные собирать

а зачем???
« Последнее редактирование: 17 Июль 2012, 16:38:34 от sash23 »

Оффлайн san4ez

  • Автор темы
  • Участник
  • *
  • Сообщений: 113
  • Хочу всё знать
    • Просмотр профиля
Re: PHP 5.2.17 + PHP 5.3.x + PHP 5.4.x
« Ответ #2 : 17 Июль 2012, 18:23:21 »
собрать из исходников
5.3 из репов можно поставить остальные собирать

А какой-то мануал есть ? Как потом переключаться между версиями ?

а зачем???

Да масса причин. Например, Joomla 1.5.x работает без ошибок только на 5.2.17. На 5.3.х сыпется куча ошибок. И не хочется заниматься шаманством, чтоб заставить работать эту версию на локалке.

Оффлайн sash23

  • Участник
  • *
  • Сообщений: 130
    • Просмотр профиля
Re: PHP 5.2.17 + PHP 5.3.x + PHP 5.4.x
« Ответ #3 : 17 Июль 2012, 18:37:53 »
вот какой-то мануал на английском: http://blog.servergrove.com/2011/08/22/how-to-setup-multiple-php-versions-on-apache/


Оффлайн san4ez

  • Автор темы
  • Участник
  • *
  • Сообщений: 113
  • Хочу всё знать
    • Просмотр профиля
Re: PHP 5.2.17 + PHP 5.3.x + PHP 5.4.x
« Ответ #4 : 17 Июль 2012, 20:30:36 »
Млин, как всё сложно.
(Нажмите, чтобы показать/скрыть)

Оффлайн victor00000

  • Забанен
  • Старожил
  • *
  • Сообщений: 15570
  • Глухонемой (Deaf)
    • Просмотр профиля
Re: PHP 5.2.17 + PHP 5.3.x + PHP 5.4.x
« Ответ #5 : 17 Июль 2012, 21:57:19 »
san4ez,
Joomla дайте сылку.
Нельзя друзья, дулу - AnrDaemon видите?
~.o

Оффлайн sash23

  • Участник
  • *
  • Сообщений: 130
    • Просмотр профиля
Re: PHP 5.2.17 + PHP 5.3.x + PHP 5.4.x
« Ответ #6 : 17 Июль 2012, 22:19:28 »
Как это не парадоксально, но под Windows всё гораздо проще обстоит. Печально((

а как в винде делаете это. каким образом к одному апачу подключаете разные версии php?

Оффлайн san4ez

  • Автор темы
  • Участник
  • *
  • Сообщений: 113
  • Хочу всё знать
    • Просмотр профиля
Re: PHP 5.2.17 + PHP 5.3.x + PHP 5.4.x
« Ответ #7 : 17 Июль 2012, 22:29:10 »
san4ez,
Joomla дайте сылку.

Ссылку на что ?

Вот ссылка на системные требования для Joomla http://www.joomla.org/technical-requirements.html
Смотрите раздел для 1.5.х Это пруфлинк.


Пользователь решил продолжить мысль 17 Июль 2012, 22:30:14:
Как это не парадоксально, но под Windows всё гораздо проще обстоит. Печально((

а как в винде делаете это. каким образом к одному апачу подключаете разные версии php?

open-server.ru
Тут сразу две версии апача, три версии php, nginx, две версии MySQL, PostgreSQL...
« Последнее редактирование: 17 Июль 2012, 22:32:54 от san4ez »

Оффлайн victor00000

  • Забанен
  • Старожил
  • *
  • Сообщений: 15570
  • Глухонемой (Deaf)
    • Просмотр профиля
Re: PHP 5.2.17 + PHP 5.3.x + PHP 5.4.x
« Ответ #8 : 18 Июль 2012, 00:47:24 »
я собирал на папка и тестур http://victor2012.info/joom/ у меня нет mysql мне ненадо.))
Нельзя друзья, дулу - AnrDaemon видите?
~.o

Оффлайн san4ez

  • Автор темы
  • Участник
  • *
  • Сообщений: 113
  • Хочу всё знать
    • Просмотр профиля
Re: PHP 5.2.17 + PHP 5.3.x + PHP 5.4.x
« Ответ #9 : 18 Июль 2012, 00:56:00 »
я собирал на папка и тестур http://victor2012.info/joom/ у меня нет mysql мне ненадо.))

сорри, но ты вообще о чём ?
Во-первых, пример с Joomla - это как один из примеров, для чего мне в Ubuntu 12.04 нужна не только версия 5.3.х, но и 5.2.17
Ещё не помешала бы и 5.4.х

По твоей ссылке идёт Joomla 2.5.х
Я же писал про 1.5.х

Оффлайн victor00000

  • Забанен
  • Старожил
  • *
  • Сообщений: 15570
  • Глухонемой (Deaf)
    • Просмотр профиля
Re: PHP 5.2.17 + PHP 5.3.x + PHP 5.4.x
« Ответ #10 : 18 Июль 2012, 01:01:40 »
я не внимание версия пхп, пмшет ДА вот работает.
Нельзя друзья, дулу - AnrDaemon видите?
~.o

Оффлайн san4ez

  • Автор темы
  • Участник
  • *
  • Сообщений: 113
  • Хочу всё знать
    • Просмотр профиля
Re: PHP 5.2.17 + PHP 5.3.x + PHP 5.4.x
« Ответ #11 : 18 Июль 2012, 01:19:27 »
я не внимание версия пхп, пмшет ДА вот работает.

Сорри, моя твоя не понимать.

Оффлайн victor00000

  • Забанен
  • Старожил
  • *
  • Сообщений: 15570
  • Глухонемой (Deaf)
    • Просмотр профиля
Re: PHP 5.2.17 + PHP 5.3.x + PHP 5.4.x
« Ответ #12 : 18 Июль 2012, 01:29:02 »
PHP 5.2.17 + PHP 5.3.x + PHP 5.4.x как это? пишет Нет?
Нельзя друзья, дулу - AnrDaemon видите?
~.o

Оффлайн san4ez

  • Автор темы
  • Участник
  • *
  • Сообщений: 113
  • Хочу всё знать
    • Просмотр профиля
Re: PHP 5.2.17 + PHP 5.3.x + PHP 5.4.x
« Ответ #13 : 18 Июль 2012, 11:13:45 »
PHP 5.2.17 + PHP 5.3.x + PHP 5.4.x как это? пишет Нет?

Млин!
Только у меня такое впечатление, что вы меня троллите ? )))

Что "как это" ? Кто или что "пишет Нет" ?

Я не имел в виду, одновременное использование сразу трёх версий. А чтоб в системе было 3 версии и был какой-то простой механизм переключения оных по мере необходимости.

Пользователь решил продолжить мысль 18 Июль 2012, 18:36:35:
Неужели программеры, пишущие под Ubuntu на PHP, не сталкивались с такой задачей ?!
« Последнее редактирование: 18 Июль 2012, 18:36:35 от san4ez »

Оффлайн victor00000

  • Забанен
  • Старожил
  • *
  • Сообщений: 15570
  • Глухонемой (Deaf)
    • Просмотр профиля
Re: PHP 5.2.17 + PHP 5.3.x + PHP 5.4.x
« Ответ #14 : 19 Июль 2012, 00:49:43 »
aptitude search php???
Нельзя друзья, дулу - AnrDaemon видите?
~.o

 

Страница сгенерирована за 0.101 секунд. Запросов: 24.