Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Не собирается Wine 1.5.6-1.5.9  (Прочитано 1556 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн dj--alex

  • Автор темы
  • Старожил
  • *
  • Сообщений: 3224
  • Понимаешь, я какбы беру в руки лопату и говорю...
    • Просмотр профиля
    • все мои творения и занятия
Не собирается Wine 1.5.6-1.5.9
« : 20 Июль 2012, 22:50:15 »
делаю ./configure   на Ubuntu 10.10
добавлял  precise репозиторий - не помогло .

знает кто нибудь как это лечить?

hecking whether gcc -m32 works... no
configure: error: Cannot build a 32-bit program, you need to install 32-bit development libraries.

по идее эта проблема эта решается этой командой

user@user-desktop:~/wine-1.5.6$ sudo apt-get build-dep wine
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
E: Не удалось открыть файл /var/lib/apt/lists/ppa.launchpad.net_ubuntu-wine_ppa_ubuntu_dists_precise_universe_source_Sources - open (2: Нет такого файла или каталога)
user@user-desktop:~/wine-1.5.6$
Ubuntu 16.04.1 MATE x64, 18.1 x64 Mate, MX-Linux 16 Mate Mate Mate Mate. PC:?\FX4100@4ghz\8Gb\2TB HDD\1060gtx\90GB Ocz
https://forum.ubuntu.ru/index.php?topic=199897.0

Оффлайн Olej

  • Забанен
  • Активист
  • *
  • Сообщений: 884
    • Просмотр профиля
Re: Не собирается Wine 1.5.6-1.5.9
« Ответ #1 : 21 Июль 2012, 12:55:09 »
делаю ./configure   на Ubuntu 10.10
wine нормально собирается

знает кто нибудь как это лечить?

hecking whether gcc -m32 works... no
configure: error: Cannot build a 32-bit program, you need to install 32-bit development libraries.
вы собираете 32-бит wine в 64-бит Linux?
не имея 32-бит библиотек.
так их надо установить.

Оффлайн dj--alex

  • Автор темы
  • Старожил
  • *
  • Сообщений: 3224
  • Понимаешь, я какбы беру в руки лопату и говорю...
    • Просмотр профиля
    • все мои творения и занятия
Re: Не собирается Wine 1.5.6-1.5.9
« Ответ #2 : 22 Июль 2012, 18:33:39 »
правда?  собирается?  ага?

раньше полгода назад когда то до окончания поддержки ещё компилировалось.
счас почему то перестало почему то...а друг каждый раз советует - переходи на арч забудешь про окончания сроков какой то там поддержки

я же писал build-dep пишет какую то фигню
не знаю чего он хочет.


и как их изволите установить если срок поддержки Ubuntu 10.10 окончился?


мне с трудом удалось выкачать из инета 2 пакета-
вот этот из моего собственного кэша
wine1.5_1.5.5-0ubuntu1~ppa1~oneiric1+pulse17_amd64.deb
wine1.5-dev_1.5.5-0ubuntu1~ppa1~oneiric1+pulse17_amd64.deb

этот пишет каждый  раз разные жалобы . счас вот gDebi инсталлер пишет нарушен кэш

и вот этот ещё откуда то
wine1.5-amd64_1.5.9-0ubuntu2~pulse19+build1_amd64.deb
у этого какие то зависимости  (к чему блин!? зависимости!? )
мне неинтересны зависимости мне нужно поставить wine 1.5.9 на 4 копиях Ubuntu 10.10
переустанавливать системы на всех компах и заново всё настраивать нет никакого желания.

обновлятся нельзя потому что на каждом из компов что нибудь да отвалится или bluetooth мышь или ещё что нибудь.


в 12.04 wine ставится и Diablo III работает . но надо на 10.10

ни один не ставится




Пользователь решил продолжить мысль 22 Июль 2012, 18:54:29:
поставил пока обратно 1.5.5 wine это самый новый который удалось выцарапать из репозиториев oneiric и новее - не ставится
для свойств самого wine в нем тоже maverick поменял на oneiric
с precise этот фокус уже не прокатывает..
как надоели устаревшие на полгода программы в Ubuntu
никаких исправлений , никаких фиксов -только для firefox + устаревший отстой.
 
« Последнее редактирование: 22 Июль 2012, 18:54:29 от dj--alex »
Ubuntu 16.04.1 MATE x64, 18.1 x64 Mate, MX-Linux 16 Mate Mate Mate Mate. PC:?\FX4100@4ghz\8Gb\2TB HDD\1060gtx\90GB Ocz
https://forum.ubuntu.ru/index.php?topic=199897.0

Оффлайн dj--alex

  • Автор темы
  • Старожил
  • *
  • Сообщений: 3224
  • Понимаешь, я какбы беру в руки лопату и говорю...
    • Просмотр профиля
    • все мои творения и занятия
Re: Не собирается Wine 1.5.6-1.5.9
« Ответ #3 : 26 Июль 2012, 22:56:35 »
похоже это и есть принудительный переход на 12.04
хочешь или не хочешь переходить а придется ибо нужных либ нету больше


Ubuntu 16.04.1 MATE x64, 18.1 x64 Mate, MX-Linux 16 Mate Mate Mate Mate. PC:?\FX4100@4ghz\8Gb\2TB HDD\1060gtx\90GB Ocz
https://forum.ubuntu.ru/index.php?topic=199897.0

Оффлайн IvAlAl

  • Новичок
  • *
  • Сообщений: 13
    • Просмотр профиля
Re: Не собирается Wine 1.5.6-1.5.9
« Ответ #4 : 25 Ноябрь 2012, 17:16:29 »
делаю ./configure   на Ubuntu 10.10
wine нормально собирается

знает кто нибудь как это лечить?

hecking whether gcc -m32 works... no
configure: error: Cannot build a 32-bit program, you need to install 32-bit development libraries.
вы собираете 32-бит wine в 64-бит Linux?
не имея 32-бит библиотек.
так их надо установить.


Подскажите, пожалуйста, как это сделать?

 

Страница сгенерирована за 0.113 секунд. Запросов: 24.